summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-09 12:32:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-09 12:32:54 +0200
commitb76e8ed541040605773955463d2c17825efa48ad (patch)
tree3c73f3898a339237e505ffcb0db893d7e5e49148 /media-video
parentmedia-libs/libebur128: bump to 1.1.0; needed by ffmpeg, bug #584816 (diff)
downloadgentoo-b76e8ed541040605773955463d2c17825efa48ad.tar.gz
gentoo-b76e8ed541040605773955463d2c17825efa48ad.tar.bz2
gentoo-b76e8ed541040605773955463d2c17825efa48ad.zip
media-video/ffmpeg: add ebur128 useflag, bug #584816
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild7
-rw-r--r--media-video/ffmpeg/metadata.xml1
2 files changed, 5 insertions, 3 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 04c1164dee5c..19db1ed81bff 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -79,9 +79,9 @@ FFMPEG_FLAG_MAP=(
schroedinger:libschroedinger speex:libspeex vorbis:libvorbis vpx:libvpx
zvbi:libzvbi
# libavfilter options
- bs2b:libbs2b chromaprint flite:libflite frei0r fribidi:libfribidi
- fontconfig ladspa libass truetype:libfreetype rubberband:librubberband
- zimg:libzimg
+ bs2b:libbs2b chromaprint ebur128:libebur128 flite:libflite frei0r
+ fribidi:libfribidi fontconfig ladspa libass truetype:libfreetype
+ rubberband:librubberband zimg:libzimg
# libswresample options
libsoxr
# Threads; we only support pthread for now but ffmpeg supports more
@@ -162,6 +162,7 @@ RDEPEND="
cdio? ( >=dev-libs/libcdio-paranoia-0.90_p1-r1[${MULTILIB_USEDEP}] )
celt? ( >=media-libs/celt-0.11.1-r1[${MULTILIB_USEDEP}] )
chromaprint? ( >=media-libs/chromaprint-1.2-r1[${MULTILIB_USEDEP}] )
+ ebur128? ( >=media-libs/libebur128-1.1.0[${MULTILIB_USEDEP}] )
encode? (
amrenc? ( >=media-libs/vo-amrwbenc-0.1.2-r1[${MULTILIB_USEDEP}] )
faac? ( >=media-libs/faac-1.28-r3[${MULTILIB_USEDEP}] )
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index 06ac428a763e..3d626964e1c4 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -19,6 +19,7 @@
<flag name="chromaprint">Enables audio fingerprinting support with <pkg>media-libs/chromaprint</pkg>.</flag>
<flag name="cpudetection">Enables runtime CPU detection (useful for bindist, compatibility on other CPUs)</flag>
<flag name="dcadec">Enables DCA decoding with <pkg>media-sound/dcadec</pkg>.</flag>
+ <flag name="ebur128">Enables EBU R128 loudness normalization filter via <pkg>media-libs/libebur128</pkg></flag>
<flag name="faac">Use external faac library for AAC encoding</flag>
<flag name="fdk">Use external fdk-aac library for AAC encoding</flag>
<flag name="flite">Adds a text-to-speech filter based on <pkg>app-accessibility/flite</pkg>.</flag>