summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-03-09 15:26:47 +0100
committerJeroen Roovers <jer@gentoo.org>2019-03-09 15:29:29 +0100
commit4325ad655a462f1af68e2baac8d57432afb35868 (patch)
tree19e6b016618027d985f085255517452fc19f0adb /net-analyzer/cacti-spine
parentdev-util/vulkan-tools: Update vulkan-headers dependency (diff)
downloadgentoo-4325ad655a462f1af68e2baac8d57432afb35868.tar.gz
gentoo-4325ad655a462f1af68e2baac8d57432afb35868.tar.bz2
gentoo-4325ad655a462f1af68e2baac8d57432afb35868.zip
net-analyzer/cacti-spine: Version 1.2.2
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/cacti-spine')
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.2.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index c3e279521dda..69c9557550ad 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -2,3 +2,4 @@ DIST cacti-spine-1.1.20.tar.gz 801877 BLAKE2B 35da513691967e507b9d10c373de571e2e
DIST cacti-spine-1.1.21.tar.gz 801907 BLAKE2B cdcda765d349db12df1c672c4469770297d09a3946f19f1e686c251ef30d5be1e3f772efeeb3f344b21ecdba29275dde1b683025ae7c16b10561486397a484f3 SHA512 0dfdd3444639a471bc5c0d35ea3898532f2ebf16679677fee8ad291221ed607b54acc7fbf25e78da7c5597eeaed6b870ad7af66a95e20f95afce3270c8da5dd0
DIST cacti-spine-1.1.28.tar.gz 802006 BLAKE2B 79e833b6afb619a1d2361bad38c3a52dc1e29b296864670f830a3bc998e7e456638523da15032751d56c65aefe0480477e70b741b23882a2a38adb2262aef601 SHA512 2255823d29342b49babebbae175c29fc7054b05ec5ae5897609960d808409f46e6d0cfcba2038dfad9598bc23532794f6cf26032a0566d2d2d2c57d622d37ab1
DIST cacti-spine-1.1.38.tar.gz 805437 BLAKE2B 32d934f54e00d83e9807dd194a7cacf8d5526c8e5b84c44ffad201c07edcb117f862266843552299fe04cc780575b9b2dc7129a106a20bd709cb82844ade7812 SHA512 5409a690e89fcc74e1e87e34e1918cab27d1243825955eb8256a92f8e9658f312345c66b338a4a07a0e38c94e3275131cb4e58fb70e7b59837c0e6c47746e45e
+DIST cacti-spine-1.2.2.tar.gz 2310298 BLAKE2B 782fb21fda6acf06434c6e996863a235670970b19e5218624723df4736c388c2d9f00c1e3cc623dad7973bcbbe7ae5d4bbe89e366c1f47ce83eac9b416f88cb4 SHA512 ef2f839f7b247439a8576d49e311546cfd2346eea06cfb26b7a05d4757ae28334e6ed6ea00396027dc6c0c6e107121ed38f356ba62d8202003553fea3b5d139e
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.2.2.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.2.2.ebuild
new file mode 100644
index 000000000000..877f39bf52c9
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.2.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="https://cacti.net/spine_info.php"
+SRC_URI="https://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+CDEPEND="
+ dev-libs/openssl:*
+ net-analyzer/net-snmp:=
+ dev-db/mysql-connector-c:0=
+"
+DEPEND="
+ ${CDEPEND}
+ sys-apps/help2man
+"
+RDEPEND="
+ ${CDEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8d-ping.patch
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
+)
+
+src_prepare() {
+ default
+
+ AT_M4DIR="config" eautoreconf
+}
+
+src_install() {
+ dosbin spine
+
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+
+ doman spine.1
+ dodoc CHANGELOG
+}