summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/portbunny
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/portbunny')
-rw-r--r--net-analyzer/portbunny/Manifest1
-rw-r--r--net-analyzer/portbunny/metadata.xml7
-rw-r--r--net-analyzer/portbunny/portbunny-1.0_p20080423.ebuild57
3 files changed, 65 insertions, 0 deletions
diff --git a/net-analyzer/portbunny/Manifest b/net-analyzer/portbunny/Manifest
new file mode 100644
index 000000000000..a5d19f09ecb8
--- /dev/null
+++ b/net-analyzer/portbunny/Manifest
@@ -0,0 +1 @@
+DIST PortBunny230408.tar.gz 224753 SHA256 ace967834ffe36a0e2f073a46b3a81b48671cc78e2d2cca6eb2ca6a63d05ead3
diff --git a/net-analyzer/portbunny/metadata.xml b/net-analyzer/portbunny/metadata.xml
new file mode 100644
index 000000000000..a40624fba8f0
--- /dev/null
+++ b/net-analyzer/portbunny/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/net-analyzer/portbunny/portbunny-1.0_p20080423.ebuild b/net-analyzer/portbunny/portbunny-1.0_p20080423.ebuild
new file mode 100644
index 000000000000..29234edcf955
--- /dev/null
+++ b/net-analyzer/portbunny/portbunny-1.0_p20080423.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils linux-mod
+
+MY_PV_SNAP=${PV##*_p}
+if [[ ${MY_PV_SNAP} != ${PV} ]]; then
+ MY_PV=${MY_PV_SNAP:6:2}${MY_PV_SNAP:4:2}${MY_PV_SNAP:2:2}
+ MY_P=PortBunny${MY_PV}
+ S="${WORKDIR}"/${MY_P}-dev
+else
+ MY_P=PortBunny-${PV}
+ S="${WORKDIR}"/${MY_P}
+fi
+
+MODULE_NAMES="portbunny(kernel:)"
+BUILD_TARGETS="all"
+
+DESCRIPTION="A kernel based highspeed TCP SYN port scanner"
+HOMEPAGE="http://recurity-labs.com/portbunny/"
+SRC_URI="http://recurity-labs.com/portbunny/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lang/python"
+
+src_install() {
+ insinto /usr/share/portbunny
+ doins UI/share/portbunny/*
+ dosed "s:^\(ETC_SERVICES\)[[:space:]]\+=.*:\1 = '/usr/share/portbunny/services':g" \
+ /usr/share/portbunny/PBunnyServices.py
+ dobin UI/bin/portbunny.py
+ dosym portbunny.py /usr/bin/portbunny
+ dosed "s:^\(PBUNNY_SHARE\)[[:space:]]\+=.*:\1 = '/usr/share/portbunny/':g" \
+ /usr/bin/portbunny.py
+ dosed "s:^\(PBUNNY_SHARE2\)[[:space:]]\+=.*:\1 = '/usr/share/portbunny/':g" \
+ /usr/bin/portbunny.py
+
+ linux-mod_src_install
+}
+
+pkg_postinst() {
+ einfo
+ einfo "See http://recurity-labs.com/portbunny/README.pdf"
+ einfo
+ ewarn
+ ewarn "WARNING"
+ ewarn "WARNING: this software may HARM the stability of your system!"
+ ewarn "WARNING: do NOT use this on production machines!"
+ ewarn "WARNING"
+ ewarn
+ ebeep 10
+}