summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-11-11 20:40:13 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2015-11-11 20:41:17 +0100
commit4f8923a16e71cc8a8e3d543bb7e7e88ea3304822 (patch)
treed91306f563655b461b2430508dbe6dafe3d4739a /net-ftp/tlswrap
parentdev-python/ssl-fetch: Add python3.5 support (diff)
downloadgentoo-4f8923a16e71cc8a8e3d543bb7e7e88ea3304822.tar.gz
gentoo-4f8923a16e71cc8a8e3d543bb7e7e88ea3304822.tar.bz2
gentoo-4f8923a16e71cc8a8e3d543bb7e7e88ea3304822.zip
net-ftp/tlswrap: add libressl support, bug #565394
Patch provided by Marek Behun Cleaned ebuild, updated homepage Package-Manager: portage-2.2.24
Diffstat (limited to 'net-ftp/tlswrap')
-rw-r--r--net-ftp/tlswrap/files/tlswrap-1.04-libressl.patch16
-rw-r--r--net-ftp/tlswrap/tlswrap-1.04-r1.ebuild30
2 files changed, 46 insertions, 0 deletions
diff --git a/net-ftp/tlswrap/files/tlswrap-1.04-libressl.patch b/net-ftp/tlswrap/files/tlswrap-1.04-libressl.patch
new file mode 100644
index 000000000000..5c1f1083005f
--- /dev/null
+++ b/net-ftp/tlswrap/files/tlswrap-1.04-libressl.patch
@@ -0,0 +1,16 @@
+diff -Naur a/tls.c b/tls.c
+--- a/tls.c 2006-11-25 19:52:08.000000000 +0100
++++ b/tls.c 2015-11-10 16:16:25.000000000 +0100
+@@ -73,10 +73,12 @@
+ printf("egd_sock is %s\n", egd_sock);
+ #ifdef HAVE_RAND_STATUS
+ if (RAND_status() != 1) {
++#ifndef OPENSSL_NO_EGD
+ if ( RAND_egd(egd_sock) == -1 ) {
+ fprintf(stderr, "egd_sock is %s\n", egd_sock);
+ sys_err("RAND_egd failed\n");
+ }
++#endif
+ if (RAND_status() != 1)
+ sys_err("ssl_init: System without /dev/urandom, PRNG seeding must be done manually.\r\n");
+ }
diff --git a/net-ftp/tlswrap/tlswrap-1.04-r1.ebuild b/net-ftp/tlswrap/tlswrap-1.04-r1.ebuild
new file mode 100644
index 000000000000..62f8c9433a52
--- /dev/null
+++ b/net-ftp/tlswrap/tlswrap-1.04-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="a TLS/SSL FTP wrapper/proxy which allows to use TLS with every FTP client"
+HOMEPAGE="http://www.tlswrap.com"
+SRC_URI="http://www.tlswrap.com/${P}.tar.gz"
+
+# GPL-2 for Gentoo init script
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl"
+
+DEPEND="!libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-libressl.patch"
+}
+
+src_install() {
+ emake prefix="${D}/usr" install
+ dodoc ChangeLog README
+ newinitd "${FILESDIR}/tlswrap.init" tlswrap
+}