summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schuerch <nativemad@gentoo.org>2020-01-03 12:04:10 +0100
committerAndreas Schuerch <nativemad@gentoo.org>2020-01-03 12:04:10 +0100
commit9dd19782a4400174b4f33b36a21be137de341e69 (patch)
tree0ef7493135d8d4063c9e45d6f48d91f28ba3ac18 /net-im/coturn/coturn-4.5.1.1.ebuild
parentacct-user/turnserver: new user for coturn 235 (diff)
downloadgentoo-9dd19782a4400174b4f33b36a21be137de341e69.tar.gz
gentoo-9dd19782a4400174b4f33b36a21be137de341e69.tar.bz2
gentoo-9dd19782a4400174b4f33b36a21be137de341e69.zip
net-im/coturn: version bump and chmod -x on initscript
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Andreas Schuerch <nativemad@gentoo.org>
Diffstat (limited to 'net-im/coturn/coturn-4.5.1.1.ebuild')
-rw-r--r--net-im/coturn/coturn-4.5.1.1.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/net-im/coturn/coturn-4.5.1.1.ebuild b/net-im/coturn/coturn-4.5.1.1.ebuild
new file mode 100644
index 000000000000..9978e2829844
--- /dev/null
+++ b/net-im/coturn/coturn-4.5.1.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils user systemd tmpfiles
+DESCRIPTION="coturn TURN server project"
+HOMEPAGE="https://github.com/${PN}/${PN}"
+
+if [ ${PV} = 9999 ]; then
+ KEYWORDS=""
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ inherit git-r3
+ DEPEND="dev-vcs/git"
+# S="${WORKDIR}/${PN}-master"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="mongodb mysql postgres redis sqlite"
+RDEPEND="acct-group/turnserver
+ acct-user/turnserver
+ || ( dev-libs/libevent[-ssl,libressl] dev-libs/libevent[ssl,-libressl] >dev-libs/libevent-2.1.8[ssl,libressl] )
+ mongodb? ( dev-libs/mongo-c-driver )
+ mysql? ( dev-db/mysql-connector-c )
+ postgres? ( dev-db/postgresql:* )
+ redis? ( dev-libs/hiredis )
+ sqlite? ( dev-db/sqlite )"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ sed 's:#log-file=/var/tmp/turn.log:log-file=/var/log/turnserver.log:' \
+ -i "${S}/examples/etc/turnserver.conf" || die "sed for logdir failed"
+ sed 's:#simple-log:simple-log:' -i "${S}/examples/etc/turnserver.conf" \
+ || die "sed for simple-log failed"
+ if ! use mongodb; then
+ export TURN_NO_MONGO=yes
+ fi
+ if ! use mysql; then
+ export TURN_NO_MYSQL=yes
+ fi
+ if ! use postgres; then
+ export TURN_NO_PQ=yes
+ fi
+ if ! use redis; then
+ export TURN_NO_HIREDIS=yes
+ fi
+ if ! use sqlite; then
+ export TURN_NO_SQLITE=yes
+ fi
+
+ econf $(use_with sqlite)
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}/turnserver.init" turnserver
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/logrotate.${PN}" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ dotmpfiles "${FILESDIR}/${PN}.conf"
+}
+
+pkg_postinst() {
+ tmpfiles_process "${PN}.conf"
+ elog "You need to copy /etc/turnserver.conf.default to"
+ elog "/etc/turnserver.conf and do your settings there."
+}