summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-03-16 21:49:27 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-03-16 21:49:27 +0100
commit6ae8f0c2bc5a33b534d1f73cbf09f32940d02057 (patch)
tree0a6a3bd3328d32be0a11607430bc27d9b1260472 /net-im/swift
parentapp-metrics/carbonapi-web-1.1: version bump (diff)
downloadgentoo-6ae8f0c2bc5a33b534d1f73cbf09f32940d02057.tar.gz
gentoo-6ae8f0c2bc5a33b534d1f73cbf09f32940d02057.tar.bz2
gentoo-6ae8f0c2bc5a33b534d1f73cbf09f32940d02057.zip
net-im/swift: fix compilation with libxml2-2.12
Closes: https://bugs.gentoo.org/923288 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-im/swift')
-rw-r--r--net-im/swift/files/swift-4.0.3-libxml2-2.12-compatibility.patch11
-rw-r--r--net-im/swift/swift-4.0.3-r2.ebuild1
2 files changed, 12 insertions, 0 deletions
diff --git a/net-im/swift/files/swift-4.0.3-libxml2-2.12-compatibility.patch b/net-im/swift/files/swift-4.0.3-libxml2-2.12-compatibility.patch
new file mode 100644
index 000000000000..b08a480835f3
--- /dev/null
+++ b/net-im/swift/files/swift-4.0.3-libxml2-2.12-compatibility.patch
@@ -0,0 +1,11 @@
+--- a/Swiften/Parser/LibXMLParser.cpp
++++ b/Swiften/Parser/LibXMLParser.cpp
+@@ -97,7 +97,7 @@
+ if (xmlParseChunk(p->context_, data.c_str(), boost::numeric_cast<int>(data.size()), false) == XML_ERR_OK) {
+ return true;
+ }
+- xmlError* error = xmlCtxtGetLastError(p->context_);
++ const xmlError* error = xmlCtxtGetLastError(p->context_);
+ if (error->code == XML_WAR_NS_URI || error->code == XML_WAR_NS_URI_RELATIVE) {
+ xmlCtxtResetLastError(p->context_);
+ p->context_->errNo = XML_ERR_OK;
diff --git a/net-im/swift/swift-4.0.3-r2.ebuild b/net-im/swift/swift-4.0.3-r2.ebuild
index 686e9cf6c7c7..792b487871ed 100644
--- a/net-im/swift/swift-4.0.3-r2.ebuild
+++ b/net-im/swift/swift-4.0.3-r2.ebuild
@@ -58,6 +58,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-4.0.2-boost-1.69-compatibility.patch
"${FILESDIR}"/${PN}-4.0.2-qt-5.15-compatibility.patch
"${FILESDIR}"/${PN}-4.0.3-gcc11-compatibility.patch
+ "${FILESDIR}"/${PN}-4.0.3-libxml2-2.12-compatibility.patch
"${WORKDIR}"/${PN}-4.0.3-python3-compatibility.patch
"${FILESDIR}"/${PN}-4.0.3-reproducible-build.patch
)