summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/balde
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/balde')
-rw-r--r--net-libs/balde/Manifest1
-rw-r--r--net-libs/balde/balde-0.1.1.ebuild59
-rw-r--r--net-libs/balde/metadata.xml19
3 files changed, 79 insertions, 0 deletions
diff --git a/net-libs/balde/Manifest b/net-libs/balde/Manifest
new file mode 100644
index 000000000000..fdc0715f17ee
--- /dev/null
+++ b/net-libs/balde/Manifest
@@ -0,0 +1 @@
+DIST balde-0.1.1.tar.bz2 360412 SHA256 0da03157d0c87d8699ff36d98636ebfd3ca62bd0d4db15ea567601eaa0e40dba SHA512 fafb9e9344ecb1caf6a4451b99adb3505fb728015e2bcce3d81162f679a70267e49a0dc194c6c977a7a155f9b5ae3318fdfcb63fb0223e43943c0fc5e8503acd WHIRLPOOL bff449dfaf1ed45d6655fc861ab69b95a114abf41e5395f3988937af2c465d096f845e2bbb4294fb7fcc8b8ace8c125f149e074a636a0ab130975124a886cef5
diff --git a/net-libs/balde/balde-0.1.1.ebuild b/net-libs/balde/balde-0.1.1.ebuild
new file mode 100644
index 000000000000..e205e1a111e2
--- /dev/null
+++ b/net-libs/balde/balde-0.1.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/balde/balde.git
+ https://github.com/balde/balde.git"
+ inherit git-r3 autotools
+fi
+
+DESCRIPTION="A microframework for C based on GLib and bad intentions"
+HOMEPAGE="http://balde.io/"
+
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/glib-2.34
+ dev-libs/fcgi
+ x11-misc/shared-mime-info"
+
+if [[ ${PV} = *9999* ]]; then
+ RDEPEND="${RDEPEND}
+ dev-util/peg"
+fi
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_with doc doxygen) \
+ --disable-examples \
+ --without-valgrind
+}
+
+src_compile() {
+ default
+ use doc && emake doxygen
+}
+
+src_install() {
+ default
+ use doc && dohtml -r doc/build/html/.
+}
diff --git a/net-libs/balde/metadata.xml b/net-libs/balde/metadata.xml
new file mode 100644
index 000000000000..577f319f7966
--- /dev/null
+++ b/net-libs/balde/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <longdescription lang="en">
+ A microframework for C based on GLib and bad intentions.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <bugs-to>mailto:balde-dev@googlegroups.com</bugs-to>
+ <remote-id type="github">balde/balde</remote-id>
+ </upstream>
+</pkgmetadata>