summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-01 22:48:31 +0000
committerSam James <sam@gentoo.org>2021-01-01 22:53:40 +0000
commita2d85473cc13720c1c6d60875132c4a841c73795 (patch)
treed46d8d842c06f47ab0fa8c29d3ee8e6976e4cc89 /net-libs/libgsasl
parentmedia-libs/openimageio: bump to 2.2.10.0 (diff)
downloadgentoo-a2d85473cc13720c1c6d60875132c4a841c73795.tar.gz
gentoo-a2d85473cc13720c1c6d60875132c4a841c73795.tar.bz2
gentoo-a2d85473cc13720c1c6d60875132c4a841c73795.zip
net-libs/libgsasl: bump to 1.10.0
Drops likely-obsolete patch for referenced bug. Bug: https://bugs.gentoo.org/359005 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libgsasl')
-rw-r--r--net-libs/libgsasl/Manifest1
-rw-r--r--net-libs/libgsasl/libgsasl-1.10.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-libs/libgsasl/Manifest b/net-libs/libgsasl/Manifest
index 8398d6f53955..a58a5d0e9203 100644
--- a/net-libs/libgsasl/Manifest
+++ b/net-libs/libgsasl/Manifest
@@ -1,2 +1,3 @@
+DIST libgsasl-1.10.0.tar.gz 1854755 BLAKE2B 691c143ece57b0b895f17ff3bfce8e216adb2ffcc7f6058501626b7b2e83d9eb0a85a036b6c7978b10eefbc94aab7b191e056341732d155597be5037e527b0e0 SHA512 33a8ea43be90a00fcda1b099ced8086b2ef9f72ee0dbce07bca04c944fa2d17588b6e5a32b7ab4ffeaf7ee695f9c84d3eb89c757c71934300d35580e423196dd
DIST libgsasl-1.8.0.tar.gz 1208417 BLAKE2B 03eea4be45ccc28bbc5c98b5f266552e6f5da151dfc561b1f01dac107a6edf0f06a3000e868c07d5539df33334d3c965c6c276de30c75038e25165aa7e2db2e8 SHA512 7e591d12404919559bf67590f862270ffcae2030a14097cdaf92820aa79619b3048541e9f83b3fcb98a84622c44a52ecaceeebb1be55b9e9f68fb1790ade8721
DIST libgsasl-1.8.1.tar.gz 1791261 BLAKE2B bd8b954f9d950fe449fe140baca840a14f12ef6318e74a6fd070b35504b8c3a7002f13fe93142bce992e4a1df773ebaad4ec01d04c01c63a7374187a8142136b SHA512 52bda3a962a2cbb598009fd02c547a4f8b5b9a4243511aa8104df97b4737023281ab57dbbcf839db3cad73c64cbc72bbd89b49da8b0379dd635220ffb642aa22
diff --git a/net-libs/libgsasl/libgsasl-1.10.0.ebuild b/net-libs/libgsasl/libgsasl-1.10.0.ebuild
new file mode 100644
index 000000000000..4a2c6a4b7f09
--- /dev/null
+++ b/net-libs/libgsasl/libgsasl-1.10.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="The GNU SASL library"
+HOMEPAGE="https://www.gnu.org/software/gsasl/"
+SRC_URI="mirror://gnu/${PN/lib}/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="idn gcrypt kerberos nls ntlm static-libs"
+
+DEPEND="
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ idn? ( net-dns/libidn:= )
+ kerberos? ( virtual/krb5 )
+ nls? ( >=sys-devel/gettext-0.18.1 )
+ ntlm? ( net-libs/libntlm )
+"
+RDEPEND="${DEPEND}
+ !net-misc/gsasl"
+
+PATCHES=(
+ #"${FILESDIR}"/${PN}-1.8.1-gss-extra.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's/ -Werror//' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local krb5_impl
+ if use kerberos; then
+ krb5_impl="--with-gssapi-impl="
+ # These are the two providers of virtual/krb5
+ if has_version app-crypt/mit-krb5; then
+ krb5_impl+="mit"
+ else
+ krb5_impl+="heimdal"
+ fi
+ fi
+
+ local myeconfargs=(
+ $(use_with gcrypt libgcrypt)
+ $(use_with idn stringprep)
+ $(use_enable kerberos gssapi)
+ ${krb5_impl}
+ $(use_enable nls)
+ $(use_enable ntlm)
+ $(use_enable static-libs static)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ rm -f "${ED}"/usr/lib*/lib*.la || die
+ fi
+}