summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-02-22 23:02:22 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-02-22 23:51:04 +0100
commitd2327d9a1ba365f1b47b54fdcaadd01a29bc5792 (patch)
tree16b8fbf682a6a7125f76588177667b2b70ddfff7 /net-libs/librsync/librsync-2.3.4.ebuild
parentwww-apps/element: add 1.11.23 (diff)
downloadgentoo-d2327d9a1ba365f1b47b54fdcaadd01a29bc5792.tar.gz
gentoo-d2327d9a1ba365f1b47b54fdcaadd01a29bc5792.tar.bz2
gentoo-d2327d9a1ba365f1b47b54fdcaadd01a29bc5792.zip
net-libs/librsync: add 2.3.4
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-libs/librsync/librsync-2.3.4.ebuild')
-rw-r--r--net-libs/librsync/librsync-2.3.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-libs/librsync/librsync-2.3.4.ebuild b/net-libs/librsync/librsync-2.3.4.ebuild
new file mode 100644
index 000000000000..1a3139b85484
--- /dev/null
+++ b/net-libs/librsync/librsync-2.3.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Remote delta-compression library"
+HOMEPAGE="https://librsync.github.io/"
+SRC_URI="https://github.com/librsync/librsync/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/2.2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="dev-libs/popt"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_LIBB2=OFF
+ )
+
+ cmake_src_configure
+}