summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-04-23 22:09:39 +0200
committerDavid Seifert <soap@gentoo.org>2017-04-23 22:59:07 +0200
commitef50a8b9159484de6941c0af921734c4a42e519d (patch)
tree9fb7e2e0e99ab7cdb437d14600708562c12ea825 /net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild
parentnet-libs/gupnp-igd: [QA] Add missing python metadata variables (diff)
downloadgentoo-ef50a8b9159484de6941c0af921734c4a42e519d.tar.gz
gentoo-ef50a8b9159484de6941c0af921734c4a42e519d.tar.bz2
gentoo-ef50a8b9159484de6941c0af921734c4a42e519d.zip
net-libs/nfqueue-bindings: [QA] Add missing python metadata variables
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild')
-rw-r--r--net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild b/net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild
index ee81ba0f637f..9b53a58b9d8d 100644
--- a/net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild
+++ b/net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
+
inherit cmake-utils perl-module linux-info python-single-r1
DESCRIPTION="High-level language bindings for libnetfilter_queue"
@@ -13,12 +15,14 @@ KEYWORDS="~x86 ~amd64"
SLOT="0"
LICENSE="GPL-3"
IUSE="perl python examples"
-REQUIRED_USE="|| ( perl python )"
+REQUIRED_USE="|| ( perl python ) python? ( ${PYTHON_REQUIRED_USE} )"
-DEPEND="python? (
+RDEPEND="
+ python? (
dev-python/dpkt[${PYTHON_USEDEP}]
${PYTHON_DEPS}
- )
+ )"
+DEPEND="${RDEPEND}
perl? ( dev-lang/perl )
net-libs/libnetfilter_queue
dev-lang/swig"