summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-09-05 08:48:08 -0400
committerCraig Andrews <candrews@gentoo.org>2023-09-05 08:53:24 -0400
commit12f0d6e85ce9a91c4d4355580e1babcdd8335bad (patch)
tree36767aeb7c8c1e7926be8ceac5a8c22c17cb6a79 /net-libs/nghttp3
parentwww-apps/lidarr: drop 1.4.0.3554 (diff)
downloadgentoo-12f0d6e85ce9a91c4d4355580e1babcdd8335bad.tar.gz
gentoo-12f0d6e85ce9a91c4d4355580e1babcdd8335bad.tar.bz2
gentoo-12f0d6e85ce9a91c4d4355580e1babcdd8335bad.zip
net-libs/nghttp3: add 0.15.0
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs/nghttp3')
-rw-r--r--net-libs/nghttp3/Manifest1
-rw-r--r--net-libs/nghttp3/nghttp3-0.15.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
index ae2d3e2d1aca..f163cf6f2c84 100644
--- a/net-libs/nghttp3/Manifest
+++ b/net-libs/nghttp3/Manifest
@@ -2,3 +2,4 @@ DIST nghttp3-0.11.0.tar.xz 367392 BLAKE2B 908da41e168e83d82de7649051c66866682c58
DIST nghttp3-0.12.0.tar.xz 369576 BLAKE2B 552fab00de7c6d1917ac1b680547aa57e02ae32e6347e9915d743daa217ce2d6d201e3ab8f1cf00072e80f489e8bb7af648d46f9805816923b8e7ccd8319bc44 SHA512 4bfde5506bbd193107cac3f548952ae692934b7b9e5639fa843ee99a7da5ee7ca816880fc5575efd57959770e633cdba1efb4fd60ba39fff043e62a6358f721b
DIST nghttp3-0.13.0.tar.xz 367992 BLAKE2B 381677866a327cbb5638aa2e6f4a770d15879d05ca432c3fca7e92a8a815ae62857c386ba660805e97f649f9bc7c9c4c7077a92d2296b3303347e3d1dff12b6c SHA512 63de094ae62c641388ea909b28df2cce58df5e372237519fb6ef62bbd937ff20f6e571cb99f0fac8b8781e619fc229ec931fb5c6a1165727829d6b0c3a779ef8
DIST nghttp3-0.14.0.tar.xz 367992 BLAKE2B a7109d735b4fd9117caaec128bb9631e1a75514475bebcf039b605fcac4d68faa4bfa51c77123d456cba19c52e9436839adccd7449a126b5befe445860a3d5d3 SHA512 163bf8dee3e100dd95e73fbe0176d0dc9c86e9139d96cc98fa7e7c279dbcc699cee79998b2784fb21f8da745be98ba8e86c7387f8166907d89eace8f97176779
+DIST nghttp3-0.15.0.tar.xz 368348 BLAKE2B 2488a944beb0165e8cad26ddc37b79eb50f7c16807902fc43f97afc57c46a9bb5857eb041c870dbdcd3d817c3b45e1849c325cbea5ef67c9198adec7421e38d6 SHA512 f65cb3b2de1abb12b13b214a60b83c9570a265f99e082cc62b6791a32c929cd78c3a228e38ccd5edd36c12998486633b660b6737fe6c1fbe1b03acdb9ca033dd
diff --git a/net-libs/nghttp3/nghttp3-0.15.0.ebuild b/net-libs/nghttp3/nghttp3-0.15.0.ebuild
new file mode 100644
index 000000000000..7f4078fba594
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-0.15.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~hppa"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="static-libs test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LIB_ONLY=ON
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ -DENABLE_EXAMPLES=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}