summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-04-05 11:05:05 -0400
committerCraig Andrews <candrews@gentoo.org>2024-04-05 11:08:35 -0400
commit3c9d5c9ce6dbf1dc41413ba829f51ee73d5b11cb (patch)
treeeda202650557b4179c2925f62532d5d0d1a4fdc9 /net-libs/nghttp3
parentmedia-gfx/inkscape: drop 1.2.2-r4, 1.3.2 (diff)
downloadgentoo-3c9d5c9ce6dbf1dc41413ba829f51ee73d5b11cb.tar.gz
gentoo-3c9d5c9ce6dbf1dc41413ba829f51ee73d5b11cb.tar.bz2
gentoo-3c9d5c9ce6dbf1dc41413ba829f51ee73d5b11cb.zip
net-libs/nghttp3: no longer uses cunit
Closes: https://bugs.gentoo.org/924750 See: https://github.com/ngtcp2/nghttp3/releases/tag/v1.2.0 See: https://github.com/ngtcp2/nghttp3/commit/67f39861a81d8d19ea085b62655353e484d2080f Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs/nghttp3')
-rw-r--r--net-libs/nghttp3/nghttp3-1.2.0-r1.ebuild39
-rw-r--r--net-libs/nghttp3/nghttp3-9999.ebuild5
2 files changed, 41 insertions, 3 deletions
diff --git a/net-libs/nghttp3/nghttp3-1.2.0-r1.ebuild b/net-libs/nghttp3/nghttp3-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..3a8480492ead
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-1.2.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~hppa"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="static-libs test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LIB_ONLY=ON
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ -DENABLE_EXAMPLES=OFF
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}
diff --git a/net-libs/nghttp3/nghttp3-9999.ebuild b/net-libs/nghttp3/nghttp3-9999.ebuild
index 719966f4eab6..3a8480492ead 100644
--- a/net-libs/nghttp3/nghttp3-9999.ebuild
+++ b/net-libs/nghttp3/nghttp3-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -10,7 +10,7 @@ if [[ ${PV} == 9999 ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~hppa"
+ KEYWORDS="~amd64 ~arm64 ~hppa"
fi
DESCRIPTION="HTTP/3 library written in C"
@@ -30,7 +30,6 @@ multilib_src_configure() {
-DENABLE_LIB_ONLY=ON
-DENABLE_STATIC_LIB=$(usex static-libs)
-DENABLE_EXAMPLES=OFF
- -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
)
cmake_src_configure
}