summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/axel
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/axel')
-rw-r--r--net-misc/axel/Manifest3
-rw-r--r--net-misc/axel/axel-1.1.ebuild53
-rw-r--r--net-misc/axel/axel-2.3-r1.ebuild54
-rw-r--r--net-misc/axel/axel-2.4-r1.ebuild52
-rw-r--r--net-misc/axel/axel-2.4-r2.ebuild49
-rw-r--r--net-misc/axel/files/axel-2.4-bffr-overflow.patch16
-rw-r--r--net-misc/axel/files/axel-2.4-buildsystem.patch23
-rw-r--r--net-misc/axel/files/axel-2.4-max-redir.patch16
-rw-r--r--net-misc/axel/metadata.xml7
9 files changed, 273 insertions, 0 deletions
diff --git a/net-misc/axel/Manifest b/net-misc/axel/Manifest
new file mode 100644
index 000000000000..23bc717c19dd
--- /dev/null
+++ b/net-misc/axel/Manifest
@@ -0,0 +1,3 @@
+DIST axel-1.1.tar.gz 45650 SHA256 398ea22b9805e563c3f703377ae6fedd4e339e6702f0f2af11ac7a8180d3eb43 SHA512 a0de04c7a616b8ad4445d8ca9a07dd4e8eacc726adf7771e6d0e1918fca1d22dc114744f4eb34ea53e3e09a08b6fc9ab987aae712284b460aa142df2b742dbc4 WHIRLPOOL 018e2dc856c3accbb926e551ed285a7cb6bb0eb88e17d023f5a805495e452467bb751ffc5c5f2d84c221587cabb726204fa544a3c77ed9b63602205b73a01b81
+DIST axel-2.3.tar.bz2 44827 SHA256 9b373cd840eb905551d5e16089dfa01e17b2bdb6f8d5cd3d59a8c0a6b4c19ac4
+DIST axel-2.4.tar.bz2 44995 SHA256 ebc7d40e989c680d2afa632a17e5208101608924cf446da20814a6f3c3338612 SHA512 34d73cea19f2bf393aa8d3e4b6c24296f8b1d4e6177da6f4728763e013d5d9d073aa5dae31d0ff175126e8fcbd973daf94674a70f100afc9e7d00b92b78b8ec9 WHIRLPOOL 373af984738008572847ae0ed84a518d0b61323e3612f48affa96175792b0856c2bd13601ddcdd0c81ead5059ee41130759bf9b0ada2a2654f767ec69d992a0f
diff --git a/net-misc/axel/axel-1.1.ebuild b/net-misc/axel/axel-1.1.ebuild
new file mode 100644
index 000000000000..2e97ada1401e
--- /dev/null
+++ b/net-misc/axel/axel-1.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DOWNLOAD_ID=2287
+
+DESCRIPTION="Light Unix download accelerator"
+HOMEPAGE="http://axel.alioth.debian.org/"
+SRC_URI="http://alioth.debian.org/frs/download.php/${DOWNLOAD_ID}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 hppa ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="debug nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Set LDFLAGS and fix expr
+ sed -i -e 's/expr/& --/' -e "s/^LFLAGS=$/&${LDFLAGS}/" configure
+}
+
+src_compile() {
+ local myconf
+
+ use debug && myconf="--debug=1"
+ use nls && myconf="--i18n=1"
+ econf \
+ --strip=0 \
+ --etcdir=/etc \
+ ${myconf} \
+ || die
+
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc API CHANGES CREDITS README axelrc.example
+}
+
+pkg_postinst() {
+ einfo 'To use axel with portage, try these settings in your make.conf'
+ einfo
+ einfo ' FETCHCOMMAND="/usr/bin/axel -a -o \${DISTDIR}/\${FILE} \${URI}"'
+ einfo ' RESUMECOMMAND="${FETCHCOMMAND}"'
+}
diff --git a/net-misc/axel/axel-2.3-r1.ebuild b/net-misc/axel/axel-2.3-r1.ebuild
new file mode 100644
index 000000000000..81905b863f99
--- /dev/null
+++ b/net-misc/axel/axel-2.3-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="light Unix download accelerator"
+HOMEPAGE="http://axel.alioth.debian.org/"
+SRC_URI="http://alioth.debian.org/frs/download.php/2718/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc ~ppc64 sparc x86 ~x86-fbsd"
+IUSE="debug nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${RDEPEND}"
+
+#S="${WORKDIR}/${PN}-1.1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Set LDFLAGS and fix expr
+ sed -i -e 's/expr/& --/' -e "s/^LFLAGS=$/&${LDFLAGS}/" configure
+}
+
+src_compile() {
+ local myconf
+
+ use debug && myconf="--debug=1"
+ use nls && myconf="--i18n=1"
+ econf \
+ --strip=0 \
+ --etcdir=/etc \
+ ${myconf} \
+ || die
+
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc API CHANGES CREDITS README axelrc.example
+}
+
+pkg_postinst() {
+ einfo 'To use axel with portage, try these settings in your make.conf'
+ einfo
+ einfo ' FETCHCOMMAND='\''/usr/bin/axel -a -o "\${DISTDIR}/\${FILE}.axel" "\${URI}" && mv "\${DISTDIR}/\${FILE}.axel" "\${DISTDIR}/\${FILE}"'\'
+ einfo ' RESUMECOMMAND="${FETCHCOMMAND}"'
+}
diff --git a/net-misc/axel/axel-2.4-r1.ebuild b/net-misc/axel/axel-2.4-r1.ebuild
new file mode 100644
index 000000000000..b4bc67b05476
--- /dev/null
+++ b/net-misc/axel/axel-2.4-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DOWNLOAD_ID=3016
+
+DESCRIPTION="Light Unix download accelerator"
+HOMEPAGE="http://axel.alioth.debian.org/"
+SRC_URI="http://alioth.debian.org/frs/download.php/${DOWNLOAD_ID}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+IUSE="debug nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+src_prepare() {
+ append-lfs-flags
+ sed -i -e "s/^LFLAGS=$/&${LDFLAGS}/" configure || die "sed failed"
+}
+
+src_configure() {
+ local myconf=""
+
+ use debug && myconf+=" --debug=1"
+ use nls && myconf+=" --i18n=$(use nls && echo 1 || echo 0)"
+ econf \
+ --strip=0 \
+ ${myconf}
+}
+
+src_compile() {
+ emake CFLAGS="${CPPFLAGS} ${CFLAGS}" CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc API CHANGES CREDITS README axelrc.example || die "dodoc failed"
+}
+
+pkg_postinst() {
+ einfo 'To use axel with portage, try these settings in your make.conf'
+ einfo
+ einfo ' FETCHCOMMAND='\''axel -a -o "\${DISTDIR}/\${FILE}.axel" "\${URI}" && mv "\${DISTDIR}/\${FILE}.axel" "\${DISTDIR}/\${FILE}"'\'
+ einfo ' RESUMECOMMAND="${FETCHCOMMAND}"'
+}
diff --git a/net-misc/axel/axel-2.4-r2.ebuild b/net-misc/axel/axel-2.4-r2.ebuild
new file mode 100644
index 000000000000..f6eacf841651
--- /dev/null
+++ b/net-misc/axel/axel-2.4-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DOWNLOAD_ID=3016
+
+DESCRIPTION="Light Unix download accelerator"
+HOMEPAGE="http://axel.alioth.debian.org/"
+SRC_URI="http://alioth.debian.org/frs/download.php/${DOWNLOAD_ID}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris"
+IUSE="debug nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+DOCS=( API CHANGES CREDITS README axelrc.example )
+
+src_prepare() {
+ append-lfs-flags
+ epatch \
+ "${FILESDIR}"/${P}-buildsystem.patch \
+ "${FILESDIR}"/${P}-bffr-overflow.patch \
+ "${FILESDIR}"/${P}-max-redir.patch
+ tc-export CC
+}
+
+src_configure() {
+ local myconf=""
+
+ use debug && myconf+=" --debug=1"
+ use nls && myconf+=" --i18n=$(use nls && echo 1 || echo 0)"
+ econf \
+ --strip=0 \
+ ${myconf}
+}
+
+pkg_postinst() {
+ einfo 'To use axel with portage, try these settings in your make.conf'
+ einfo
+ einfo ' FETCHCOMMAND='\''axel -a -o "\${DISTDIR}/\${FILE}.axel" "\${URI}" && mv "\${DISTDIR}/\${FILE}.axel" "\${DISTDIR}/\${FILE}"'\'
+ einfo ' RESUMECOMMAND="${FETCHCOMMAND}"'
+}
diff --git a/net-misc/axel/files/axel-2.4-bffr-overflow.patch b/net-misc/axel/files/axel-2.4-bffr-overflow.patch
new file mode 100644
index 000000000000..24fae8ce19c0
--- /dev/null
+++ b/net-misc/axel/files/axel-2.4-bffr-overflow.patch
@@ -0,0 +1,16 @@
+ http.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/http.c b/http.c
+index 5d64e9b..db91701 100644
+--- a/http.c
++++ b/http.c
+@@ -164,7 +164,7 @@ int http_exec( http_t *conn )
+ {
+ i ++;
+ }
+- strncat( conn->headers, s, MAX_QUERY );
++ strncat( conn->headers, s, MAX_QUERY - 1);
+ }
+
+ #ifdef DEBUG
diff --git a/net-misc/axel/files/axel-2.4-buildsystem.patch b/net-misc/axel/files/axel-2.4-buildsystem.patch
new file mode 100644
index 000000000000..a1571f0fc576
--- /dev/null
+++ b/net-misc/axel/files/axel-2.4-buildsystem.patch
@@ -0,0 +1,23 @@
+ Makefile | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 1c3863a..b43fcff 100644
+--- a/Makefile
++++ b/Makefile
+@@ -51,13 +51,13 @@ uninstall-etc:
+ ### MAIN PROGRAM
+
+ $(OUTFILE): axel.o conf.o conn.o ftp.o http.o search.o tcp.o text.o
+- $(CC) *.o -o $(OUTFILE) $(LFLAGS)
++ $(CC) $(LDFLAGS) *.o -o $(OUTFILE) $(LFLAGS)
+ ifndef DEBUG
+ -$(STRIP) $(OUTFILE)
+ endif
+
+ .c.o:
+- $(CC) -c $*.c -o $*.o -Wall $(CFLAGS)
++ $(CC) $(CPPFLAGS) -c $*.c -o $*.o -Wall $(CFLAGS)
+
+ install-bin:
+ mkdir -p $(DESTDIR)$(BINDIR)/
diff --git a/net-misc/axel/files/axel-2.4-max-redir.patch b/net-misc/axel/files/axel-2.4-max-redir.patch
new file mode 100644
index 000000000000..f52796c35e2d
--- /dev/null
+++ b/net-misc/axel/files/axel-2.4-max-redir.patch
@@ -0,0 +1,16 @@
+ axel.h | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/axel.h b/axel.h
+index e90d30d..f6ebfe8 100644
+--- a/axel.h
++++ b/axel.h
+@@ -66,7 +66,7 @@
+ /* Compiled-in settings */
+ #define MAX_STRING 1024
+ #define MAX_ADD_HEADERS 10
+-#define MAX_REDIR 5
++#define MAX_REDIR 25
+ #define AXEL_VERSION_STRING "2.4"
+ #define DEFAULT_USER_AGENT "Axel " AXEL_VERSION_STRING " (" ARCH ")"
+
diff --git a/net-misc/axel/metadata.xml b/net-misc/axel/metadata.xml
new file mode 100644
index 000000000000..c845479d513e
--- /dev/null
+++ b/net-misc/axel/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>