summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/capiisdnmon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/capiisdnmon')
-rw-r--r--net-misc/capiisdnmon/Manifest1
-rw-r--r--net-misc/capiisdnmon/capiisdnmon-0.42-r2.ebuild46
-rw-r--r--net-misc/capiisdnmon/files/capiisdnmon-0.42-capiv3.patch11
-rw-r--r--net-misc/capiisdnmon/files/capiisdnmon-0.42-gcc44.patch23
-rw-r--r--net-misc/capiisdnmon/metadata.xml10
5 files changed, 91 insertions, 0 deletions
diff --git a/net-misc/capiisdnmon/Manifest b/net-misc/capiisdnmon/Manifest
new file mode 100644
index 000000000000..862da9a131c8
--- /dev/null
+++ b/net-misc/capiisdnmon/Manifest
@@ -0,0 +1 @@
+DIST capiisdnmon-0.42.tar.gz 79945 SHA256 c5e5de33fa5d4c2392e603c4c3d376c94e41f916ced360754844bce4a14d04ec SHA512 61a87aff01835969bb842c603609c1e3a95c4ad62de36bb96c992217d806ea8a48babd47c3371b5ab288d8f710b677c283daf1130adbbfba37c4b088b9bbd217 WHIRLPOOL 4ad59dd72f1abbd0bac1974520be30e6a8c0cc322857131b4770985cc963be57a27568d7abd5dca123eb16627ea011f08ba7925721044fa6e00bc168b69e0c6c
diff --git a/net-misc/capiisdnmon/capiisdnmon-0.42-r2.ebuild b/net-misc/capiisdnmon/capiisdnmon-0.42-r2.ebuild
new file mode 100644
index 000000000000..171ba6d2ee68
--- /dev/null
+++ b/net-misc/capiisdnmon/capiisdnmon-0.42-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="a CAPI 2.0 ISDN call monitor with LDAP name resolution"
+HOMEPAGE="http://capiisdnmon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/capiisdnmon/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="net-dialup/capi4k-utils
+ net-nds/openldap
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/xosd
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-gcc44.patch" \
+ "${FILESDIR}/${P}-capiv3.patch"
+
+ append-cppflags -DLDAP_DEPRECATED
+
+ sed -i -e 's/capiIsdnMon:://' capiisdnmon.h || die
+
+ # Fix linking, bugs #370101 and #540672
+ append-libs -lX11 -llber
+ append-ldflags -pthread
+
+ epatch_user
+}
+
+src_install() {
+ default
+
+ newicon icon1.xpm capiisdnmon.xpm
+ make_desktop_entry capiIsdnMon "CAPI ISDN Monitor" capiisdnmon
+}
diff --git a/net-misc/capiisdnmon/files/capiisdnmon-0.42-capiv3.patch b/net-misc/capiisdnmon/files/capiisdnmon-0.42-capiv3.patch
new file mode 100644
index 000000000000..e7d22b254ff5
--- /dev/null
+++ b/net-misc/capiisdnmon/files/capiisdnmon-0.42-capiv3.patch
@@ -0,0 +1,11 @@
+--- capiinfo.cpp.orig 2005-08-06 14:13:17.763338743 +0200
++++ capiinfo.cpp 2005-08-06 14:16:33.362368161 +0200
+@@ -100,7 +100,7 @@
+ std::cout << "incomming call from :" << cmsg.CallingPartyNumber << std::endl;
+ #endif
+ std::string callingPartyNumber((char *) cmsg.CallingPartyNumber);
+- CONNECT_RESP(&cmsg, m_wApplId, m_wIntNr++, cmsg.adr.adrController, 0x1, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0);
++ CONNECT_RESP(&cmsg, m_wApplId, m_wIntNr++, cmsg.adr.adrController, 0x1, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0);
+ if (CAPI_PUT_CMSG(&cmsg) != CapiNoError)
+ throw capiError("CONNECT_RESP failed...");
+ //cut header from number (2 chars) if there is a number - leading 0 ist missing
diff --git a/net-misc/capiisdnmon/files/capiisdnmon-0.42-gcc44.patch b/net-misc/capiisdnmon/files/capiisdnmon-0.42-gcc44.patch
new file mode 100644
index 000000000000..e16dceec8905
--- /dev/null
+++ b/net-misc/capiisdnmon/files/capiisdnmon-0.42-gcc44.patch
@@ -0,0 +1,23 @@
+diff -ur capiisdnmon-0.42.orig/capiinfo.cpp capiisdnmon-0.42/capiinfo.cpp
+--- capiisdnmon-0.42.orig/capiinfo.cpp 2005-01-31 01:55:40.000000000 +0200
++++ capiisdnmon-0.42/capiinfo.cpp 2009-08-10 13:45:13.000000000 +0300
+@@ -10,6 +10,7 @@
+ static const char capiinfo_cpp[] = "$Id$";
+
+ #include "capiinfo.h"
++#include <stdio.h>
+ #include <iostream>
+ /**
+ * Class destructor.
+diff -ur capiisdnmon-0.42.orig/ldapaddressbook.cpp capiisdnmon-0.42/ldapaddressbook.cpp
+--- capiisdnmon-0.42.orig/ldapaddressbook.cpp 2005-01-30 18:28:59.000000000 +0200
++++ capiisdnmon-0.42/ldapaddressbook.cpp 2009-08-10 13:43:23.000000000 +0300
+@@ -1,6 +1,8 @@
+ #include "ldapaddressbook.h"
+ #include <iostream>
+
++#include <sys/time.h>
++
+ /**
+ * Class constructor.
+ * initialize ldap stuff:
diff --git a/net-misc/capiisdnmon/metadata.xml b/net-misc/capiisdnmon/metadata.xml
new file mode 100644
index 000000000000..5313bf560f2e
--- /dev/null
+++ b/net-misc/capiisdnmon/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-dialup</herd>
+ <longdescription>A CAPI 2.0 ISDN call monitor with LDAP name resolution</longdescription>
+ <longdescription lang="ja">CAPI 2.0 ISDN は LDAP の名前解決の様子を表示します。</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">capiisdnmon</remote-id>
+ </upstream>
+</pkgmetadata>