summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-09-13 13:44:45 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-09-13 13:45:19 +0200
commit64e2b7590889d33ecf888c528bfaefdbc341c932 (patch)
treea513ae530b6b77a2350eef1c31a96eb12f1af95b /net-misc/cni-plugins/cni-plugins-0.6.0.ebuild
parentnet-analyzer/ntopng: blocking net-libs/nDPI as it causes errors in this version (diff)
downloadgentoo-64e2b7590889d33ecf888c528bfaefdbc341c932.tar.gz
gentoo-64e2b7590889d33ecf888c528bfaefdbc341c932.tar.bz2
gentoo-64e2b7590889d33ecf888c528bfaefdbc341c932.zip
net-misc/cni-plugins: Initial version
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-misc/cni-plugins/cni-plugins-0.6.0.ebuild')
-rw-r--r--net-misc/cni-plugins/cni-plugins-0.6.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/cni-plugins/cni-plugins-0.6.0.ebuild b/net-misc/cni-plugins/cni-plugins-0.6.0.ebuild
new file mode 100644
index 000000000000..7a785167042e
--- /dev/null
+++ b/net-misc/cni-plugins/cni-plugins-0.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-vcs-snapshot
+
+KEYWORDS="~amd64"
+DESCRIPTION="Standard networking plugins for container networking"
+EGO_PN="github.com/containernetworking/plugins"
+HOMEPAGE="https://github.com/containernetworking/plugins"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened"
+
+src_compile() {
+ pushd src || die
+ local i
+ for i in plugins/{meta/{flannel,portmap,tuning},main/{bridge,ipvlan,loopback,macvlan,ptp,vlan},ipam/{dhcp,host-local},sample}; do
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" GOPATH="${WORKDIR}/${P}" go install -v "${EGO_PN}/${i}"
+ done
+ popd || die
+}
+
+src_install() {
+ exeinto /opt/cni/bin
+ doexe bin/*
+ pushd src/${EGO_PN} || die
+ dodoc README.md
+ local i
+ for i in plugins/{meta/{flannel,portmap,tuning},main/{bridge,ipvlan,loopback,macvlan,ptp,vlan},ipam/{dhcp,host-local},sample}; do
+ newdoc README.md ${i##*/}.README.md
+ done
+ popd || die
+}