summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-20 17:13:50 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-20 17:13:50 +0100
commitf46394d65f26b4fbcbe16aec44997c180b9a9cc5 (patch)
tree01c92b664c750a49977419224f33d6c5343cd28c /net-misc/mstpd/mstpd-0.0.9.ebuild
parentdev-python/pydecomp: fix copyright (diff)
downloadgentoo-f46394d65f26b4fbcbe16aec44997c180b9a9cc5.tar.gz
gentoo-f46394d65f26b4fbcbe16aec44997c180b9a9cc5.tar.bz2
gentoo-f46394d65f26b4fbcbe16aec44997c180b9a9cc5.zip
net-misc/mstpd: Multiple spanning tree protocol daemon
* mstpd is an user-space daemon that implements RSTP and MSTP protocols Bug: https://github.com/mstpd/mstpd/issues/105 Closes: https://github.com/gentoo/gentoo/pull/19359 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-misc/mstpd/mstpd-0.0.9.ebuild')
-rw-r--r--net-misc/mstpd/mstpd-0.0.9.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-misc/mstpd/mstpd-0.0.9.ebuild b/net-misc/mstpd/mstpd-0.0.9.ebuild
new file mode 100644
index 000000000000..adbcac48da08
--- /dev/null
+++ b/net-misc/mstpd/mstpd-0.0.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1 systemd
+
+DESCRIPTION="Multiple spanning tree protocol daemon"
+HOMEPAGE="https://github.com/mstpd/mstpd"
+SRC_URI="https://github.com/mstpd/mstpd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-bashcompletiondir="$(get_bashcompdir)" \
+ --with-systemdunitdir="$(systemd_get_systemunitdir)" \
+ --localstatedir="${EPREFIX}"/var
+}