summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-01-16 16:58:24 +0100
committerSam James <sam@gentoo.org>2023-01-17 01:52:14 +0000
commit051d0acb4405d2214b33fe840c97d346aa53af65 (patch)
treec020bd6b61801f24f8d63be1b72a67e6772258c7 /net-misc/s6-networking
parentnet-dns/s6-dns: add 2.3.5.5 (diff)
downloadgentoo-051d0acb4405d2214b33fe840c97d346aa53af65.tar.gz
gentoo-051d0acb4405d2214b33fe840c97d346aa53af65.tar.bz2
gentoo-051d0acb4405d2214b33fe840c97d346aa53af65.zip
net-misc/s6-networking: add 2.5.1.2
The --disable-static needs to be explicitly specified in configuration phase otherwise static libraries are created. Fixes: 5687d4da75fd ("net-misc/s6-networking: drop IUSE="static static-libs"") Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/s6-networking')
-rw-r--r--net-misc/s6-networking/Manifest1
-rw-r--r--net-misc/s6-networking/s6-networking-2.5.1.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-misc/s6-networking/Manifest b/net-misc/s6-networking/Manifest
index b02e7e3425c6..9837c8c86d42 100644
--- a/net-misc/s6-networking/Manifest
+++ b/net-misc/s6-networking/Manifest
@@ -1 +1,2 @@
DIST s6-networking-2.5.1.1.tar.gz 110431 BLAKE2B 67776a8aa6b02d20ed73c8b8d45e255677c3688973f9ee5f8dcc0de5cfd26146b7ccdc680b22a57e2523d8ab3c08d6e090252e376d09c1edd971a391632d83a0 SHA512 a9c1970cad5b3aeee447cce7c858e8bd88ee378fe456cc68d032f195373dabf658eacf55d9fa39ec635e893116296c1c614b89d97c5045b90dbe745a52e24021
+DIST s6-networking-2.5.1.2.tar.gz 114109 BLAKE2B 8c503fcd92957d9678ed45ac41f264dfb3aebf22006907f0ba1c0dfd2b698d5c60e43ed9d2201ef8feee66813c949e4a17d857d0314a32725edb38c01fc84060 SHA512 6b9198e3c4276f716bf7a3e4bfe5357b372eb01a1944e710a5c92a30033d78400ba18eb937dab2d03993deee91586dfd94f56e399d7ef58fc0ba85d8fd31f0d5
diff --git a/net-misc/s6-networking/s6-networking-2.5.1.2.ebuild b/net-misc/s6-networking/s6-networking-2.5.1.2.ebuild
new file mode 100644
index 000000000000..4e0888f8ac6c
--- /dev/null
+++ b/net-misc/s6-networking/s6-networking-2.5.1.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Suite of small networking utilities for Unix systems"
+HOMEPAGE="https://www.skarnet.org/software/s6-networking/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+RDEPEND="dev-lang/execline:=
+ >=dev-libs/skalibs-2.13.0.0:=
+ net-dns/s6-dns:=
+ sys-apps/s6:=[execline]
+ ssl? ( dev-libs/libretls )
+"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ local myconf=(
+ --bindir=/bin
+ --dynlibdir=/usr/$(get_libdir)
+ --libdir=/usr/$(get_libdir)/${PN}
+ --with-dynlib=/usr/$(get_libdir)
+ --with-lib=/usr/$(get_libdir)/s6
+ --with-lib=/usr/$(get_libdir)/s6-dns
+ --with-lib=/usr/$(get_libdir)/skalibs
+ --with-sysdeps=/usr/$(get_libdir)/skalibs
+ --enable-shared
+ --disable-allstatic
+ --disable-static
+ --disable-static-libc
+ $(use_enable ssl ssl libtls)
+ )
+
+ econf "${myconf[@]}"
+}