summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-01-21 01:09:56 -0500
committerSam James <sam@gentoo.org>2024-01-22 05:54:48 +0000
commit35ebdaf0752bac87a599f52f116f0109419ebf0b (patch)
treee1a86d2b3bfad42dd77385ef17d135f93c9e1f93 /net-p2p/qbittorrent/qbittorrent-9999.ebuild
parentnet-p2p/qbittorrent: drop old (diff)
downloadgentoo-35ebdaf0752bac87a599f52f116f0109419ebf0b.tar.gz
gentoo-35ebdaf0752bac87a599f52f116f0109419ebf0b.tar.bz2
gentoo-35ebdaf0752bac87a599f52f116f0109419ebf0b.zip
net-p2p/qbittorrent: drop acct-* dependencies to USE=webui
The relevant accounts are tied to use of qbittorrent-nox, the daemonized system service with systemd/openrc service files that launch as the created user accounts. It is totally unneeded by purely USE=gui users (the default configuration) as that simply runs in the context of the logged in desktop user. While we are at it, ensure the openrc service files are only installed for USE=webui as well. The service files attempt to run qbittorrent-nox, and for that very reason the upstream systemd unit is only installed for USE=webui. The openrc services stick out like a sore thumb. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p/qbittorrent/qbittorrent-9999.ebuild')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index d2fd716fffa9..7c839c086c0b 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -48,8 +48,11 @@ RDEPEND="
dev-qt/qtsql:5[sqlite]
dev-qt/qtxml:5
)
- acct-group/qbittorrent
- acct-user/qbittorrent"
+ webui? (
+ acct-group/qbittorrent
+ acct-user/qbittorrent
+ )
+"
DEPEND="
${RDEPEND}
dev-libs/boost
@@ -132,6 +135,8 @@ src_install() {
multibuild_foreach_variant cmake_src_install
einstalldocs
- newconfd "${FILESDIR}/${PN}.confd" "${PN}"
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ if use webui; then
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ fi
}