summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-02-13 12:24:49 -0300
committerPacho Ramos <pacho@gentoo.org>2024-07-15 22:32:15 +0200
commite6d8dc66ce7cebf05e23d97c1ba1e4be2e1a7121 (patch)
tree3aa026386f3dcce637c4e63de86ec165f92001d1 /net-wireless
parentsys-apps/gnome-disk-utility: update HOMEPAGE (diff)
downloadgentoo-e6d8dc66ce7cebf05e23d97c1ba1e4be2e1a7121.tar.gz
gentoo-e6d8dc66ce7cebf05e23d97c1ba1e4be2e1a7121.tar.bz2
gentoo-e6d8dc66ce7cebf05e23d97c1ba1e4be2e1a7121.zip
net-wireless/gnome-bluetooth: Bump to 46.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/35303 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/gnome-bluetooth/Manifest1
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-46.0.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/net-wireless/gnome-bluetooth/Manifest b/net-wireless/gnome-bluetooth/Manifest
index 012cbc97a02f..9ea6a8fc92ea 100644
--- a/net-wireless/gnome-bluetooth/Manifest
+++ b/net-wireless/gnome-bluetooth/Manifest
@@ -1 +1,2 @@
DIST gnome-bluetooth-42.8.tar.xz 304908 BLAKE2B c487e0c278b316ecdcbdd39421389ce95024b06bf0e350d59dcac06d7a7e8b982da12b1088701e479d0b5c64b123899a5351a00c477208946bb1f44f3c8f30a6 SHA512 1c3d1db874b54ebae3cf59e526db8ff71131daea0c994abeefd95b51abf590bbba0baa8314ebbd1d3efe7973021327c7b8257163ed8f0567fe610b4e0c3dba88
+DIST gnome-bluetooth-46.0.tar.xz 306148 BLAKE2B cc2ecb80b69bab74f878eb640f8b65505b0a5e12d4c661bd2491cbb70c4020db7f191e604805df788e3bd45c46de38c8069434a8615874006368e027dd5608b6 SHA512 48ed8aeaa59aba1997991a6ae6113a4d3c9e286aa4e34f3f2611e33582ffa53f9f3f5a81052320292ccb576904d0f3cf8074c0fff6d0f56995266188441e6f7b
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-46.0.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-46.0.ebuild
new file mode 100644
index 000000000000..bb80dbb3a638
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-46.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
+
+DESCRIPTION="Bluetooth graphical utilities integrated with GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeBluetooth"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="3/13" # subslot = libgnome-bluetooth-3 soname version
+IUSE="gtk-doc +introspection sendto test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.44:2
+ >=gui-libs/gtk-4.4:4[introspection?]
+ media-libs/gsound
+ >=gui-libs/libadwaita-1.1:1
+ >=x11-libs/libnotify-0.7.0
+ virtual/libudev:=
+ >=sys-power/upower-0.99.14:=
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+RDEPEND="${DEPEND}
+ acct-group/plugdev
+ virtual/udev
+ >=net-wireless/bluez-5
+ sendto? ( !net-wireless/gnome-bluetooth:2 )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.9 )
+ virtual/pkgconfig
+ test? (
+ $(python_gen_any_dep '
+ >=dev-python/python-dbusmock-0.26.0[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ if use test; then
+ python_has_version ">=dev-python/python-dbusmock-0.26.0[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/dbus-python[${PYTHON_USEDEP}]"
+ fi
+}
+
+pkg_setup() {
+ # Check for python is unconditional
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use sendto)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # Workaround test failures caused by flatpak being installed that adds to XDG_DATA_DIRS
+ gnome2_environment_reset
+ export XDG_DATA_DIRS="${EPREFIX}"/usr/share
+
+ meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}