summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 18:57:01 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:35:17 +0100
commitc2730034d27b574e5725cb7948658334adce6ff2 (patch)
tree306c08494440cb465ea181b39b9c41e35dc36898 /sci-calculators/gonvert/gonvert-0.2.39-r1.ebuild
parentsci-biology/tophat: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-c2730034d27b574e5725cb7948658334adce6ff2.tar.gz
gentoo-c2730034d27b574e5725cb7948658334adce6ff2.tar.bz2
gentoo-c2730034d27b574e5725cb7948658334adce6ff2.zip
sci-calculators/gonvert: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-calculators/gonvert/gonvert-0.2.39-r1.ebuild')
-rw-r--r--sci-calculators/gonvert/gonvert-0.2.39-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-calculators/gonvert/gonvert-0.2.39-r1.ebuild b/sci-calculators/gonvert/gonvert-0.2.39-r1.ebuild
new file mode 100644
index 000000000000..94ef697d8f02
--- /dev/null
+++ b/sci-calculators/gonvert/gonvert-0.2.39-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Unit conversion utility written in PyGTK"
+HOMEPAGE="http://unihedron.com/projects/gonvert/index.php"
+SRC_URI="http://unihedron.com/projects/gonvert/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygtk:2[${PYTHON_MULTI_USEDEP}]
+ ')"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/0.2.23-paths.patch )
+
+src_install () {
+ emake install DESTDIR="${D}" prefix="${EPREFIX}/usr"
+ python_fix_shebang "${ED%/}"/usr/bin
+ rm -fr "${ED%/}/usr/share/doc/${PN}" || die
+ einstalldocs
+}