summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/bkchem/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/bkchem/files')
-rw-r--r--sci-chemistry/bkchem/files/0.14.0_pre1-piddle-Fix-assertions.patch48
-rw-r--r--sci-chemistry/bkchem/files/bkchem-0.14.0_pre2-nolauncher.patch106
2 files changed, 154 insertions, 0 deletions
diff --git a/sci-chemistry/bkchem/files/0.14.0_pre1-piddle-Fix-assertions.patch b/sci-chemistry/bkchem/files/0.14.0_pre1-piddle-Fix-assertions.patch
new file mode 100644
index 000000000000..6270e59d5320
--- /dev/null
+++ b/sci-chemistry/bkchem/files/0.14.0_pre1-piddle-Fix-assertions.patch
@@ -0,0 +1,48 @@
+diff --git a/bkchem/plugins/piddle/pdfgen.py b/bkchem/plugins/piddle/pdfgen.py
+index 5213672..4c056c7 100644
+--- a/bkchem/plugins/piddle/pdfgen.py
++++ b/bkchem/plugins/piddle/pdfgen.py
+@@ -639,7 +639,7 @@ class Canvas:
+
+ #use a flate filter and Ascii Base 85 to compress
+ raw = myimage.tostring()
+- assert(len(raw) == imgwidth * imgheight, "Wrong amount of data for image")
++ assert len(raw) == imgwidth * imgheight, "Wrong amount of data for image"
+ compressed = zlib.compress(raw) #this bit is very fast...
+ encoded = pdfutils._AsciiBase85Encode(compressed) #...sadly this isn't
+
+diff --git a/bkchem/plugins/piddle/pdfutils.py b/bkchem/plugins/piddle/pdfutils.py
+index ebde677..4a7675d 100644
+--- a/bkchem/plugins/piddle/pdfutils.py
++++ b/bkchem/plugins/piddle/pdfutils.py
+@@ -27,7 +27,7 @@ def cacheImageFile(filename):
+ code.append('ID')
+ #use a flate filter and Ascii Base 85
+ raw = img.tostring()
+- assert(len(raw) == imgwidth * imgheight, "Wrong amount of data for image")
++ assert len(raw) == imgwidth * imgheight, "Wrong amount of data for image"
+ compressed = zlib.compress(raw) #this bit is very fast...
+ encoded = _AsciiBase85Encode(compressed) #...sadly this isn't
+
+diff --git a/bkchem/plugins/piddle/piddlePS.py b/bkchem/plugins/piddle/piddlePS.py
+index 4d3c327..3afa361 100644
+--- a/bkchem/plugins/piddle/piddlePS.py
++++ b/bkchem/plugins/piddle/piddlePS.py
+@@ -866,7 +866,7 @@ translate
+ # piddlePDF again
+
+ rawimage = myimage.tostring()
+- assert(len(rawimage) == imgwidth*imgheight, 'Wrong amount of data for image')
++ assert len(rawimage) == imgwidth*imgheight, 'Wrong amount of data for image'
+ #compressed = zlib.compress(rawimage) # no zlib at moment
+ hex_encoded = self._AsciiHexEncode(rawimage)
+
+@@ -957,7 +957,7 @@ translate
+ 'image'])
+ # after image operator just need to dump image dat to file as hexstring
+ rawimage = myimage.tostring()
+- assert(len(rawimage) == imwidth*imheight, 'Wrong amount of data for image')
++ assert len(rawimage) == imwidth*imheight, 'Wrong amount of data for image'
+ #compressed = zlib.compress(rawimage) # no zlib at moment
+ hex_encoded = self._AsciiHexEncode(rawimage)
+
diff --git a/sci-chemistry/bkchem/files/bkchem-0.14.0_pre2-nolauncher.patch b/sci-chemistry/bkchem/files/bkchem-0.14.0_pre2-nolauncher.patch
new file mode 100644
index 000000000000..202c47a9c74f
--- /dev/null
+++ b/sci-chemistry/bkchem/files/bkchem-0.14.0_pre2-nolauncher.patch
@@ -0,0 +1,106 @@
+ bkchem/bkchem.py | 24 +++++++++++++-----------
+ setup.py | 23 -----------------------
+ 2 files changed, 13 insertions(+), 34 deletions(-)
+
+diff --git a/bkchem/bkchem.py b/bkchem/bkchem.py
+index b336b9c..bcb68b0 100644
+--- a/bkchem/bkchem.py
++++ b/bkchem/bkchem.py
+@@ -1,3 +1,4 @@
++#!/usr/bin/env python2
+ #--------------------------------------------------------------------------
+ # This file is part of BKChem - a chemical drawing program
+ # Copyright (C) 2002-2009 Beda Kosata <beda@zirael.org>
+@@ -18,18 +19,19 @@
+ #--------------------------------------------------------------------------
+
+
+-"""this is just a starter of the application"""
++#"""this is just a starter of the application"""
+
+ ## support for loading from outside of bkchem dir
+
+-import os_support, sys
++from bkchem import os_support
++import sys
+ sys.path.insert( 1, os_support.get_module_path())
+
+
+ ### now starting for real
+
+-from singleton_store import Store
+-import pref_manager
++from bkchem.singleton_store import Store
++from bkchem import pref_manager
+
+ # at first preference manager
+ Store.pm = pref_manager.pref_manager(
+@@ -78,13 +80,13 @@ else:
+
+
+
+-import config
++from bkchem import config
+
+ if not config.debug:
+ # checking of important modules availability
+ # import modules
+- import import_checker
+- import messages
++ from bkchem import import_checker
++ from bkchem import messages
+
+ # we need sets from the 2.3 version
+ if not import_checker.python_version_ok:
+@@ -103,16 +105,16 @@ if not config.debug:
+
+
+ #import Tkinter
+-from main import BKChem
+-from splash import Splash
+-from singleton_store import Store
++from bkchem.main import BKChem
++from bkchem.splash import Splash
++from bkchem.singleton_store import Store
+
+ myapp = BKChem()
+ myapp.withdraw()
+
+ if __name__ == '__main__':
+
+- import messages
++ from bkchem import messages
+ enc = sys.getfilesystemencoding()
+ if not enc:
+ enc = sys.getdefaultencoding()
+diff --git a/setup.py b/setup.py
+index d4b2a21..2319216 100755
+--- a/setup.py
++++ b/setup.py
+@@ -91,26 +91,3 @@ if len( sys.argv) > 1 and sys.argv[1] == 'install' and '--help' not in sys.argv:
+ print "file %s created" % config_name
+
+
+- # the executable
+- if not os.path.isdir( bin_dir):
+- try:
+- os.mkdir( bin_dir)
+- except:
+- print "ERROR: could not create directory %s" % bin_dir
+- sys.exit( 201)
+- exec_name = os.path.join( bin_dir, 'bkchem')
+- try:
+- file = open( exec_name, 'w')
+- except:
+- print "ERROR: couldn't open the file %s for write" % exec_name
+- sys.exit( 201)
+- file.write( "#!/bin/sh\n")
+- file.write( 'python %s "$@"\n' % strip_path( os.path.join( py_dir, "bkchem", "bkchem.py")))
+- file.close()
+- print "file %s created" % exec_name
+- try:
+- os.chmod( os.path.join( bin_dir, 'bkchem'), 5+5*8+7*8*8)
+- except:
+- print "ERROR: failed to make %s executable" % exec_name
+- sys.exit( 201)
+- print "file %s made executable" % exec_name