summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/sparky
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/sparky')
-rw-r--r--sci-chemistry/sparky/Manifest1
-rw-r--r--sci-chemistry/sparky/files/3.115-fpic.patch42
-rw-r--r--sci-chemistry/sparky/files/3.115-ldflags.patch61
-rw-r--r--sci-chemistry/sparky/files/3.115-makefile.patch17
-rw-r--r--sci-chemistry/sparky/files/3.115-paths.patch13
-rw-r--r--sci-chemistry/sparky/files/3.115-wrapper-r1.patch41
-rw-r--r--sci-chemistry/sparky/files/3.115-wrapper.patch41
-rw-r--r--sci-chemistry/sparky/files/fix-install.patch259
-rw-r--r--sci-chemistry/sparky/metadata.xml8
-rw-r--r--sci-chemistry/sparky/sparky-3.115-r1.ebuild119
10 files changed, 602 insertions, 0 deletions
diff --git a/sci-chemistry/sparky/Manifest b/sci-chemistry/sparky/Manifest
new file mode 100644
index 000000000000..1e8514f6cde8
--- /dev/null
+++ b/sci-chemistry/sparky/Manifest
@@ -0,0 +1 @@
+DIST sparky-source-3.115.tar.gz 4103686 SHA256 c187546aaec3d6489c533c3a778e1fe6fa634a931dcaf245c1e13f5720a002b6 SHA512 33b0fd368f15bf4d091d7152a189f57279aea54fb89a12f15314f2a1414b073f7bd282afedeb72e79192195b0b6ac212ca74da3def513592af5400c118ac8e89 WHIRLPOOL 8557a525eab51150da437f78cb8e404adad4f41ed0884498601887e832f78bb316e4847cc3b3a7147ec66bcddd4e06064323bb2ce76452b37d504a809feee7ff
diff --git a/sci-chemistry/sparky/files/3.115-fpic.patch b/sci-chemistry/sparky/files/3.115-fpic.patch
new file mode 100644
index 000000000000..37725aa029e2
--- /dev/null
+++ b/sci-chemistry/sparky/files/3.115-fpic.patch
@@ -0,0 +1,42 @@
+diff --git a/c++/Makefile b/c++/Makefile
+index 421ff77..7442ed3 100644
+--- a/c++/Makefile
++++ b/c++/Makefile
+@@ -158,7 +158,7 @@ winsystem-$(PLATFORM).o: winsystem-$(PLATFORM).cc
+ $(CXX) $(CXXFLAGS) $(TKFLAGS) -c $(SPARKY_SRC)/winsystem-$(PLATFORM).cc
+
+ python.o: python.cc
+- $(CXX) $(CXXFLAGS) $(PYFLAGS) $(TKFLAGS) -c $(SPARKY_SRC)/python.cc
++ $(CXX) $(CXXFLAGS) -fPIC $(PYFLAGS) $(TKFLAGS) -c $(SPARKY_SRC)/python.cc
+
+ _tkinter.so: _tkinter.o
+ $(CXX) $(LDSHARED) $(LDFLAGS) -o $@ _tkinter.o $(TKLIBS)
+diff --git a/c++/Makefile b/c++/Makefile
+index 353122d..84b0c24 100644
+--- a/c++/Makefile
++++ b/c++/Makefile
+@@ -168,7 +168,7 @@ _tkinter.o: _tkinter.c
+
+ Makefile.dep: force
+ cd $(SPARKY_SRC) ; \
+- $(CXX) $(DEPEND) $(CXXFLAGS) $(TKFLAGS) $(PYFLAGS) \
++ $(CXX) $(DEPEND) $(CXXFLAGS) -fPIC $(TKFLAGS) $(PYFLAGS) \
+ $(SPARKY_OBJS:.o=.cc) $(OTHER_OBJS:.o=.cc) > $@
+
+ TAGS: force
+diff --git a/c++/Makefile b/c++/Makefile
+index 84b0c24..933f347 100644
+--- a/c++/Makefile
++++ b/c++/Makefile
+@@ -30,9 +30,9 @@ TCL_LIBNAME = tcl$(TCLTK_VERSION)
+ PLATFORM = unix
+
+ CXX = g++
+-CXXFLAGS =
++CXXFLAGS += -fPIC
+ CC = gcc
+-CFLAGS =
++CFLAGS += -fPIC
+ PYFLAGS = -I$(PYTHON_INC) -I$(PYTHON_LIB)/config
+ TKFLAGS = -I$(TK_PREFIX)/include
+ TKLIBS = -L$(TK_PREFIX)/lib -l$(TK_LIBNAME) -l$(TCL_LIBNAME) -lX11
diff --git a/sci-chemistry/sparky/files/3.115-ldflags.patch b/sci-chemistry/sparky/files/3.115-ldflags.patch
new file mode 100644
index 000000000000..bd4020387682
--- /dev/null
+++ b/sci-chemistry/sparky/files/3.115-ldflags.patch
@@ -0,0 +1,61 @@
+diff --git a/c++/Makefile b/c++/Makefile
+index aeb4daa..5cab356 100644
+--- a/c++/Makefile
++++ b/c++/Makefile
+@@ -131,28 +131,28 @@ $(SPARKY_INSTALL)/python/sparky $(SPARKY_INSTALL)/python/lib-tk:
+ chmod 755 $@
+
+ sparky-no-python$(EXE_SUFFIX): main.o $(SPARKY_OBJS)
+- $(CXX) -o $@ main.o $(SPARKY_OBJS) $(LDFLAGS) $(LDLIBS)
++ $(CXX) $(LDFLAGS) -o $@ main.o $(SPARKY_OBJS) $(LDLIBS)
+
+ ucsfdata$(EXE_SUFFIX): ucsfdata.o $(NMR_OBJS)
+- $(CXX) -o $@ ucsfdata.o $(NMR_OBJS) $(LDFLAGS) $(SYSLIBS) $(EXTRALIBS)
++ $(CXX) $(LDFLAGS) -o $@ ucsfdata.o $(NMR_OBJS) $(SYSLIBS) $(EXTRALIBS)
+
+ pipe2ucsf$(EXE_SUFFIX): pipe2ucsf.o $(NMR_OBJS)
+- $(CXX) -o $@ pipe2ucsf.o $(NMR_OBJS) $(LDFLAGS) $(SYSLIBS) $(EXTRALIBS)
++ $(CXX) $(LDFLAGS) -o $@ pipe2ucsf.o $(NMR_OBJS) $(SYSLIBS) $(EXTRALIBS)
+
+ vnmr2ucsf$(EXE_SUFFIX): vnmr2ucsf.o $(NMR_OBJS)
+- $(CXX) -o $@ vnmr2ucsf.o $(NMR_OBJS) $(LDFLAGS) $(SYSLIBS) $(EXTRALIBS)
++ $(CXX) $(LDFLAGS) -o $@ vnmr2ucsf.o $(NMR_OBJS) $(SYSLIBS) $(EXTRALIBS)
+
+ bruk2ucsf$(EXE_SUFFIX): bruk2ucsf.o $(NMR_OBJS)
+- $(CXX) -o $@ bruk2ucsf.o $(NMR_OBJS) $(LDFLAGS) $(SYSLIBS) $(EXTRALIBS)
++ $(CXX) $(LDFLAGS) -o $@ bruk2ucsf.o $(NMR_OBJS) $(SYSLIBS) $(EXTRALIBS)
+
+ peaks2ucsf$(EXE_SUFFIX): peaks2ucsf.o $(NMR_OBJS)
+- $(CXX) -o $@ peaks2ucsf.o $(NMR_OBJS) $(LDFLAGS) $(SYSLIBS) $(EXTRALIBS)
++ $(CXX) $(LDFLAGS) -o $@ peaks2ucsf.o $(NMR_OBJS) $(SYSLIBS) $(EXTRALIBS)
+
+ matrix2ucsf$(EXE_SUFFIX): matrix2ucsf.o $(NMR_OBJS)
+- $(CXX) -o $@ matrix2ucsf.o $(NMR_OBJS) $(LDFLAGS) $(SYSLIBS) $(EXTRALIBS)
++ $(CXX) $(LDFLAGS) -o $@ matrix2ucsf.o $(NMR_OBJS) $(SYSLIBS) $(EXTRALIBS)
+
+ spy.so: python.o $(SPARKY_OBJS)
+- $(CXX) $(LDSHARED) -o $@ python.o $(SPARKY_OBJS) $(LDFLAGS) $(LDLIBS)
++ $(CXX) $(LDSHARED) $(LDFLAGS) -o $@ python.o $(SPARKY_OBJS) $(LDLIBS)
+
+ winsystem-$(PLATFORM).o: winsystem-$(PLATFORM).cc
+ $(CXX) $(CXXFLAGS) $(TKFLAGS) -c $(SPARKY_SRC)/winsystem-$(PLATFORM).cc
+@@ -161,7 +161,7 @@ python.o: python.cc
+ $(CXX) $(CXXFLAGS) $(PYFLAGS) $(TKFLAGS) -c $(SPARKY_SRC)/python.cc
+
+ _tkinter.so: _tkinter.o
+- $(CXX) $(LDSHARED) -o $@ _tkinter.o $(LDFLAGS) $(TKLIBS)
++ $(CXX) $(LDSHARED) $(LDFLAGS) -o $@ _tkinter.o $(TKLIBS)
+
+ _tkinter.o: _tkinter.c
+ $(CC) $(CFLAGS) $(TKFLAGS) $(PYFLAGS) -c $(SPARKY_SRC)/_tkinter.c
+@@ -188,8 +188,8 @@ PYLDFLAGS = -L$(PYTHON_LIB)/config -lpython$(PYTHON_VERSION)
+ PYIFLAGS = -I$(PYTHON_INC)
+
+ debug-sparky: main-debug.o python.o _tkinter.o $(SPARKY_OBJS)
+- $(CXX) -o $@ main-debug.o python.o _tkinter.o $(SPARKY_OBJS) \
+- $(LDFLAGS) $(PYLDFLAGS) $(LDLIBS)
++ $(CXX) $(LDFLAGS) -o $@ main-debug.o python.o _tkinter.o $(SPARKY_OBJS) \
++ $(PYLDFLAGS) $(LDLIBS)
+
+ main-debug.o: main-debug.cc
+ $(CXX) $(CXXFLAGS) $(PYIFLAGS) -c $(SPARKY_SRC)/main-debug.cc
diff --git a/sci-chemistry/sparky/files/3.115-makefile.patch b/sci-chemistry/sparky/files/3.115-makefile.patch
new file mode 100644
index 000000000000..7c810dcbd8ae
--- /dev/null
+++ b/sci-chemistry/sparky/files/3.115-makefile.patch
@@ -0,0 +1,17 @@
+diff --git a/Makefile b/Makefile
+index bb27034..30979bd 100644
+--- a/Makefile
++++ b/Makefile
+@@ -48,6 +48,12 @@ TKINTER_PYMOD = _tkinter$(PYMOD_SUFFIX)
+ all nopython $(SPY_PYMOD) $(TKINTER_PYMOD) $(EXECUTABLES) debug-sparky clean: force
+ cd $(SPARKY_OBJ) && $(MAKE) -f $(SPARKY_SRC)/Makefile -e $@
+
++libraries:
++ cd $(SPARKY_OBJ) && $(MAKE) -f $(SPARKY_SRC)/Makefile -e $(SPY_PYMOD) $(TKINTER_PYMOD)
++
++binaries:
++ cd $(SPARKY_OBJ) && $(MAKE) -f $(SPARKY_SRC)/Makefile -e $(EXECUTABLES) debug-sparky
++
+ Makefile.dep TAGS: force
+ cd $(SPARKY_SRC) && $(MAKE) -f Makefile -e $@
+
diff --git a/sci-chemistry/sparky/files/3.115-paths.patch b/sci-chemistry/sparky/files/3.115-paths.patch
new file mode 100644
index 000000000000..20d9a801ecd6
--- /dev/null
+++ b/sci-chemistry/sparky/files/3.115-paths.patch
@@ -0,0 +1,13 @@
+diff --git a/c++/paths.h b/c++/paths.h
+index 2a21366..38aff52 100644
+--- a/c++/paths.h
++++ b/c++/paths.h
+@@ -19,7 +19,7 @@
+ // Installation subdirectories and files
+ //
+ #define SPARKY_MANUAL "manual"
+-#define SPARKY_LIB "lib"
++#define SPARKY_LIB "."
+ #define SPARKY_PRINT "print-prolog.ps" // under lib directory
+ #define SPARKY_RESOURCE "Sparky" // under lib directory
+ #define SPARKY_SAMPLE_DATA "example"
diff --git a/sci-chemistry/sparky/files/3.115-wrapper-r1.patch b/sci-chemistry/sparky/files/3.115-wrapper-r1.patch
new file mode 100644
index 000000000000..d83b5b8510cc
--- /dev/null
+++ b/sci-chemistry/sparky/files/3.115-wrapper-r1.patch
@@ -0,0 +1,41 @@
+diff --git a/bin/sparky b/bin/sparky
+index 8b51212..270723a 100644
+--- a/bin/sparky
++++ b/bin/sparky
+@@ -4,18 +4,6 @@
+ #
+
+ # -----------------------------------------------------------------------------
+-# Figure out Sparky installation directory from $0.
+-#
+-set sparky_exe = "$0"
+-while (-l "$sparky_exe")
+- set ls_sparky_exe = `ls -l "$sparky_exe"`
+- set sparky_exe = `echo "$ls_sparky_exe" | sed 's/.* -> //'`
+-end
+-set sparky_bin = `dirname "$sparky_exe"`
+-set sparky_bin = `cd "$sparky_bin"; pwd`
+-set sparky_inst = `dirname "$sparky_bin"`
+-
+-# -----------------------------------------------------------------------------
+ # Sparky uses the SPARKY_INSTALL environment variable to find its
+ # application resource file and print prolog file.
+ #
+@@ -25,7 +13,7 @@ setenv SPARKY_INSTALL "$sparky_inst"
+ # If Python is available start Sparky as a Python extension.
+ # Otherwise the standalone version of Sparky is started.
+ #
+-set PYTHON = "$SPARKY_INSTALL/python2.5/bin/python2.5"
++set PYTHON = GENTOO_PYTHON
+ if (! -e "$PYTHON") then
+ set PYTHON = python2.5
+ endif
+@@ -79,7 +67,7 @@ if ($status == 0) then
+ # ---------------------------------------------------------------------------
+ # Add the Sparky package and Tkinter to the Python path
+ #
+- set SPARKY_PYTHONPATH = "$SPARKY_INSTALL/python:$SPARKY_INSTALL/python/lib-tk"
++ set SPARKY_PYTHONPATH = "$SPARKY_INSTALL/python:$SPARKY_INSTALL/python/sparky"
+ if ($?PYTHONPATH) then
+ setenv PYTHONPATH "${SPARKY_PYTHONPATH}:$PYTHONPATH"
+ else
diff --git a/sci-chemistry/sparky/files/3.115-wrapper.patch b/sci-chemistry/sparky/files/3.115-wrapper.patch
new file mode 100644
index 000000000000..9498c0bec837
--- /dev/null
+++ b/sci-chemistry/sparky/files/3.115-wrapper.patch
@@ -0,0 +1,41 @@
+diff --git a/bin/sparky b/bin/sparky
+index 8b51212..270723a 100644
+--- a/bin/sparky
++++ b/bin/sparky
+@@ -4,18 +4,6 @@
+ #
+
+ # -----------------------------------------------------------------------------
+-# Figure out Sparky installation directory from $0.
+-#
+-set sparky_exe = "$0"
+-while (-l "$sparky_exe")
+- set ls_sparky_exe = `ls -l "$sparky_exe"`
+- set sparky_exe = `echo "$ls_sparky_exe" | sed 's/.* -> //'`
+-end
+-set sparky_bin = `dirname "$sparky_exe"`
+-set sparky_bin = `cd "$sparky_bin"; pwd`
+-set sparky_inst = `dirname "$sparky_bin"`
+-
+-# -----------------------------------------------------------------------------
+ # Sparky uses the SPARKY_INSTALL environment variable to find its
+ # application resource file and print prolog file.
+ #
+@@ -25,7 +13,7 @@ setenv SPARKY_INSTALL "$sparky_inst"
+ # If Python is available start Sparky as a Python extension.
+ # Otherwise the standalone version of Sparky is started.
+ #
+-set PYTHON = "$SPARKY_INSTALL/python2.5/bin/python2.5"
++set PYTHON = "@GENTOO_PORTAGE_EPREFIX@/usr/bin/python"
+ if (! -e "$PYTHON") then
+ set PYTHON = python2.5
+ endif
+@@ -79,7 +67,7 @@ if ($status == 0) then
+ # ---------------------------------------------------------------------------
+ # Add the Sparky package and Tkinter to the Python path
+ #
+- set SPARKY_PYTHONPATH = "$SPARKY_INSTALL/python:$SPARKY_INSTALL/python/lib-tk"
++ set SPARKY_PYTHONPATH = "$SPARKY_INSTALL/python:$SPARKY_INSTALL/python/sparky"
+ if ($?PYTHONPATH) then
+ setenv PYTHONPATH "${SPARKY_PYTHONPATH}:$PYTHONPATH"
+ else
diff --git a/sci-chemistry/sparky/files/fix-install.patch b/sci-chemistry/sparky/files/fix-install.patch
new file mode 100644
index 000000000000..4eefaa891f99
--- /dev/null
+++ b/sci-chemistry/sparky/files/fix-install.patch
@@ -0,0 +1,259 @@
+diff -ur -x make-sparky sparky.orig/bin/sparky sparky/bin/sparky
+--- sparky.orig/bin/sparky 2004-03-05 11:32:10.000000000 -0800
++++ sparky/bin/sparky 2005-12-17 17:36:51.000000000 -0800
+@@ -4,22 +4,10 @@
+ #
+
+ # -----------------------------------------------------------------------------
+-# Figure out Sparky installation directory from $0.
+-#
+-set sparky_exe = $0
+-while (-l $sparky_exe)
+- set ls_sparky_exe = `ls -l "$sparky_exe"`
+- set sparky_exe = `echo "$ls_sparky_exe" | sed 's/.* -> //'`
+-end
+-set sparky_bin = `dirname "$sparky_exe"`
+-set sparky_bin = `cd "$sparky_bin"; pwd`
+-set sparky_inst = `dirname "$sparky_bin"`
+-
+-# -----------------------------------------------------------------------------
+ # Sparky uses the SPARKY_INSTALL environment variable to find its
+ # application resource file and print prolog file.
+ #
+-setenv SPARKY_INSTALL $sparky_inst
++setenv SPARKY_INSTALL @GENTOO_PORTAGE_EPREFIX@/usr/lib/sparky
+
+ # -----------------------------------------------------------------------------
+ # If Python is available start Sparky as a Python extension.
+diff -ur -x make-sparky sparky.orig/c++/Makefile sparky/c++/Makefile
+--- sparky.orig/c++/Makefile 2004-02-03 15:56:24.000000000 -0800
++++ sparky/c++/Makefile 2005-12-18 10:49:08.000000000 -0800
+@@ -22,6 +22,7 @@
+ PYTHON_PREFIX = /usr/local
+ PYTHON_LIB = $(PYTHON_PREFIX)/lib/python$(PYTHON_VERSION)
+ PYTHON_INC = $(PYTHON_PREFIX)/include/python$(PYTHON_VERSION)
++PYDIR = $(SPARKY_INSTALL)/lib/python$(PYTHON_VERSION)/site-packages
+ TCLTK_VERSION = 8.4
+ TCLTK_VER_WIN32 = 84
+ TK_PREFIX = /usr/local
+@@ -113,21 +114,20 @@
+
+ nopython: $(EXECUTABLES)
+
+-install-python: $(SPY_PYMOD) $(TKINTER_PYMOD) $(SPARKY_INSTALL)/python \
+- $(SPARKY_INSTALL)/python/sparky $(SPARKY_INSTALL)/python/lib-tk
+- $(INSTALL) $(SPY_PYMOD) $(SPARKY_INSTALL)/python/sparky
+- chmod 755 $(SPARKY_INSTALL)/python/sparky/$(SPY_PYMOD)
+- $(INSTALL) $(TKINTER_PYMOD) $(SPARKY_INSTALL)/python/lib-tk
+- chmod 755 $(SPARKY_INSTALL)/python/lib-tk/$(TKINTER_PYMOD)
++install-python: $(SPY_PYMOD) $(TKINTER_PYMOD) $(PYDIR) \
++ $(PYDIR)/sparky $(PYDIR)/lib-tk
++ $(INSTALL) $(SPY_PYMOD) $(PYDIR)/sparky
++ chmod 755 $(PYDIR)/sparky/$(SPY_PYMOD)
++ $(INSTALL) $(TKINTER_PYMOD) $(PYDIR)/lib-tk
++ chmod 755 $(PYDIR)/lib-tk/$(TKINTER_PYMOD)
+
+ install-nopython: $(EXECUTABLES) $(SPARKY_INSTALL)/bin
+ $(INSTALL) $(EXECUTABLES) $(SPARKY_INSTALL)/bin
+ cd $(SPARKY_INSTALL)/bin ; \
+ chmod 755 $(EXECUTABLES)
+
+-$(SPARKY_INSTALL)/bin $(SPARKY_INSTALL)/python \
+-$(SPARKY_INSTALL)/python/sparky $(SPARKY_INSTALL)/python/lib-tk:
+- mkdir $@
++$(SPARKY_INSTALL)/bin $(PYDIR) $(PYDIR)/sparky $(PYDIR)/lib-tk:
++ mkdir -p $@
+ chmod 755 $@
+
+ sparky-no-python$(EXE_SUFFIX): main.o $(SPARKY_OBJS)
+diff -ur -x make-sparky sparky.orig/c++/paths.h sparky/c++/paths.h
+--- sparky.orig/c++/paths.h 2002-01-17 19:15:06.000000000 -0800
++++ sparky/c++/paths.h 2005-12-17 20:57:15.000000000 -0800
+@@ -19,7 +19,7 @@
+ // Installation subdirectories and files
+ //
+ #define SPARKY_MANUAL "manual"
+-#define SPARKY_LIB "lib"
++#define SPARKY_LIB ""
+ #define SPARKY_PRINT "print-prolog.ps" // under lib directory
+ #define SPARKY_RESOURCE "Sparky" // under lib directory
+ #define SPARKY_SAMPLE_DATA "example"
+diff -ur -x make-sparky sparky.orig/c++/system-unix.cc sparky/c++/system-unix.cc
+--- sparky.orig/c++/system-unix.cc 2004-02-26 10:57:54.000000000 -0800
++++ sparky/c++/system-unix.cc 2005-12-17 20:56:58.000000000 -0800
+@@ -95,7 +95,7 @@
+ //
+ Stringy default_sparky_install_path()
+ {
+- return file_path(file_path(file_path("", "usr"), "local"), "sparky");
++ return file_path(file_path(file_path("", "usr"), "lib"), "sparky");
+ }
+
+ // ----------------------------------------------------------------------------
+diff -ur -x make-sparky sparky.orig/lib/Makefile sparky/lib/Makefile
+--- sparky.orig/lib/Makefile 2004-02-18 10:53:29.000000000 -0800
++++ sparky/lib/Makefile 2005-12-17 16:03:21.000000000 -0800
+@@ -18,9 +18,9 @@
+ TCL_SHLIB = lib$(TCL_VERSION)$(TCLTK_SHLIB_SUFFIX)
+ TK_SHLIB = lib$(TK_VERSION)$(TCLTK_SHLIB_SUFFIX)
+
+-install: $(SPARKY_INSTALL)/lib install-tcl-tk
+- $(INSTALL) Sparky print-prolog.ps $(SPARKY_INSTALL)/lib
+- cd $(SPARKY_INSTALL)/lib ; \
++install: $(SPARKY_INSTALL)/lib
++ $(INSTALL) Sparky print-prolog.ps $(SPARKY_INSTALL)/lib/sparky
++ cd $(SPARKY_INSTALL)/lib/sparky ; \
+ chmod 644 Sparky print-prolog.ps
+
+ install-tcl-tk: $(SPARKY_INSTALL)/lib
+diff -ur -x make-sparky sparky.orig/Makefile sparky/Makefile
+--- sparky.orig/Makefile 2004-02-18 10:40:04.000000000 -0800
++++ sparky/Makefile 2005-12-17 19:40:48.000000000 -0800
+@@ -40,18 +40,22 @@
+
+ PYTHON_VERSION = 2.3
+ PYTHON_DIR =
++PYDIR = $(SPARKY_INSTALL)/lib/python$(PYTHON_VERSION)/site-packages
+
+ PYMOD_SUFFIX = .so
+ SPY_PYMOD = spy$(PYMOD_SUFFIX)
+ TKINTER_PYMOD = _tkinter$(PYMOD_SUFFIX)
+
++PYDIR = $(SPARKY_INSTALL)/lib/sparky/python
++DOCDIR = $(SPARKY_INSTALL)/share/doc/sparky
++
+ all nopython $(SPY_PYMOD) $(TKINTER_PYMOD) $(EXECUTABLES) debug-sparky clean: force
+ cd $(SPARKY_OBJ) && $(MAKE) -f $(SPARKY_SRC)/Makefile -e $@
+
+ Makefile.dep TAGS: force
+ cd $(SPARKY_SRC) && $(MAKE) -f Makefile -e $@
+
+-install: install-nopython $(SPARKY_INSTALL) install-python
++install: install-nopython $(SPARKY_INSTALL)
+ cd $(SPARKY_OBJ) && \
+ $(MAKE) -f $(SPARKY_SRC)/Makefile -e install-python
+ cd $(SPARKY)/python && $(MAKE) -f Makefile -e install
+@@ -67,7 +71,8 @@
+ chmod 755 sparky$(SCRIPT_SUFFIX)
+
+ install-example: $(SPARKY_INSTALL)
+- cd $(SPARKY) ; $(INSTALLDIR) example $(SPARKY_INSTALL)
++ mkdir -p $(DOCDIR)/example
++ cd $(SPARKY) ; $(INSTALLDIR) example $(DOCDIR)
+
+ install-lib: $(SPARKY_INSTALL)
+ cd $(SPARKY)/lib && $(MAKE) -f Makefile -e install
+@@ -76,21 +81,14 @@
+ cd $(SPARKY)/manual && $(MAKE) -f Makefile -e install
+
+ install-misc: $(SPARKY_INSTALL)
+- cd $(SPARKY) ; $(INSTALL) LICENSE README $(SPARKY_INSTALL)
+- cd $(SPARKY_INSTALL) ; chmod 644 LICENSE README
+-
+-install-python: $(SPARKY_INSTALL) $(SPARKY_INSTALL)/python$(PYTHON_VERSION)
+-ifdef PYTHON_DIR
+- $(INSTALLDIR) $(PYTHON_DIR)/* $(SPARKY_INSTALL)/python$(PYTHON_VERSION)
+-else
+- echo "Not packaging Python with Sparky."
+-endif
++ cd $(SPARKY) ; $(INSTALL) LICENSE README $(DOCDIR)
++ cd $(DOCDIR) ; chmod 644 LICENSE README
+
+ install-mac:
+ cd $(SPARKY)/mac && $(MAKE) -f Makefile -e install
+
+-$(SPARKY_INSTALL) $(SPARKY_INSTALL)/bin $(SPARKY_INSTALL)/python$(PYTHON_VERSION):
+- mkdir $@
++$(SPARKY_INSTALL) $(SPARKY_INSTALL)/bin $(PYDIR):
++ mkdir -p $@
+ chmod 755 $@
+
+ force:
+diff -ur -x make-sparky sparky.orig/manual/Makefile sparky/manual/Makefile
+--- sparky.orig/manual/Makefile 2004-03-08 15:40:06.000000000 -0800
++++ sparky/manual/Makefile 2005-12-17 19:37:45.000000000 -0800
+@@ -13,6 +13,8 @@
+
+ SPARKY_INSTALL = /usr/local/sparky
+ MANUAL_WWW = /usr/local/html/cgl/sparky/manual
++DOCDIR = $(SPARKY_INSTALL)/share/doc/sparky
++MANUAL_LOC = $(DOCDIR)/manual
+
+ MANUAL_SECTIONS = overview.html intro.html views.html peaks.html \
+ extensions.html autoassign.html misc.html \
+@@ -45,17 +47,17 @@
+
+ all: $(MANUAL_FILES)
+
+-install: $(MANUAL_FILES) $(SPARKY_INSTALL)/manual \
+- $(SPARKY_INSTALL)/manual/images
+- $(INSTALL) $(MANUAL_FILES) $(SPARKY_INSTALL)/manual
+- cd $(SPARKY_INSTALL)/manual ; \
++install: $(MANUAL_FILES) $(MANUAL_LOC) \
++ $(MANUAL_LOC)/images
++ $(INSTALL) $(MANUAL_FILES) $(MANUAL_LOC)
++ cd $(MANUAL_LOC) ; \
+ chmod 644 $(MANUAL_FILES)
+ cd images ; \
+- $(INSTALL) $(IMAGE_FILES) $(SPARKY_INSTALL)/manual/images
+- cd $(SPARKY_INSTALL)/manual/images ; \
++ $(INSTALL) $(IMAGE_FILES) $(MANUAL_LOC)/images
++ cd $(MANUAL_LOC)/images ; \
+ chmod 644 $(IMAGE_FILES)
+
+-$(SPARKY_INSTALL)/manual $(SPARKY_INSTALL)/manual/images:
++$(MANUAL_LOC) $(MANUAL_LOC)/images:
+ mkdir $@
+ chmod 755 $@
+
+Only in sparky/manual: manual-postscript.gz
+diff -ur -x make-sparky sparky.orig/python/Makefile sparky/python/Makefile
+--- sparky.orig/python/Makefile 2004-02-18 10:51:06.000000000 -0800
++++ sparky/python/Makefile 2005-12-17 19:43:06.000000000 -0800
+@@ -9,6 +9,8 @@
+ PYTHON_VERSION = 2.3
+ PYTHON = $(PYTHON_PREFIX)/bin/python$(PYTHON_VERSION)
+ PYTHON_LIB = $(PYTHON_PREFIX)/lib/python$(PYTHON_VERSION)
++PYDIR = $(SPARKY_INSTALL)/lib/python$(PYTHON_VERSION)/site-packages
++DOCDIR = $(SPARKY_INSTALL)/share/doc/sparky
+
+ PYTHON_CODE = __init__.py align.py assigngraph.py atomnames.py \
+ atoms.py autoassign.py axes.py \
+@@ -27,18 +29,13 @@
+ sputil.py start_in_chimera.py strips.py subprocess.py \
+ tkutil.py volumeerror.py xeasy.py xplor.py
+
+-install: $(SPARKY_INSTALL)/python $(SPARKY_INSTALL)/python/sparky \
+- $(SPARKY_INSTALL)/python/lib-tk
+- $(INSTALL) README $(SPARKY_INSTALL)/python
+- $(INSTALL) $(PYTHON_CODE) $(SPARKY_INSTALL)/python/sparky
+- $(INSTALL) lib-tk/*.py $(SPARKY_INSTALL)/python/lib-tk
+- chmod 644 $(SPARKY_INSTALL)/python/README
+- cd $(SPARKY_INSTALL)/python/sparky ; chmod 644 $(PYTHON_CODE)
+- chmod 644 $(SPARKY_INSTALL)/python/lib-tk/*.py
+- $(PYTHON) $(PYTHON_LIB)/compileall.py $(SPARKY_INSTALL)/python/sparky
+- $(PYTHON) $(PYTHON_LIB)/compileall.py $(SPARKY_INSTALL)/python/lib-tk
++install: $(PYDIR) $(PYDIR)/sparky $(DOCDIR)/python
++ $(INSTALL) README $(DOCDIR)/python
++ $(INSTALL) $(PYTHON_CODE) $(PYDIR)/sparky
++ chmod 644 $(DOCDIR)/python/README
++ cd $(PYDIR)/sparky ; chmod 644 $(PYTHON_CODE)
+
+-$(SPARKY_INSTALL)/python $(SPARKY_INSTALL)/python/sparky \
+- $(SPARKY_INSTALL)/python/lib-tk:
++$(PYDIR) $(PYDIR)/sparky \
++ $(PYDIR)/lib-tk $(DOCDIR)/python:
+ mkdir $@
+ chmod 755 $@
+diff -ur -x make-sparky sparky.orig/python/spingraph.py sparky/python/spingraph.py
+--- sparky.orig/python/spingraph.py 2001-12-17 10:51:10.000000000 -0800
++++ sparky/python/spingraph.py 2005-12-17 22:09:17.000000000 -0800
+@@ -831,7 +831,7 @@
+ 'by creating a file specifying atom positions, colors,\n' +
+ 'sizes, and text label positions. Sparky provides a\n' +
+ 'default layout file\n' +
+- '\n\t/usr/local/sparky/python/spinlayout.py\n\n' +
++ '\n\t/usr/lib/python*/site-packages/sparky/python/spinlayout.py\n\n' +
+ 'You override this file by making your own copy\n' +
+ '\n\t~/Sparky/Python/spinlayout.py\n\n' +
+ 'You can create the desired template on the screen\n'
diff --git a/sci-chemistry/sparky/metadata.xml b/sci-chemistry/sparky/metadata.xml
new file mode 100644
index 000000000000..ae9ec7c5f6a4
--- /dev/null
+++ b/sci-chemistry/sparky/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/sparky/sparky-3.115-r1.ebuild b/sci-chemistry/sparky/sparky-3.115-r1.ebuild
new file mode 100644
index 000000000000..b28e5351dc5b
--- /dev/null
+++ b/sci-chemistry/sparky/sparky-3.115-r1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk"
+
+inherit eutils flag-o-matic multilib prefix python-single-r1 toolchain-funcs
+
+DESCRIPTION="Graphical NMR assignment and integration program for proteins, nucleic acids, and other polymers"
+HOMEPAGE="http://www.cgl.ucsf.edu/home/sparky/"
+SRC_URI="http://www.cgl.ucsf.edu/home/sparky/distrib-${PV}/${PN}-source-${PV}.tar.gz"
+
+LICENSE="sparky"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ app-shells/tcsh
+ dev-lang/tcl:0=
+ dev-lang/tk:0="
+DEPEND="${RDEPEND}"
+
+RESTRICT="mirror"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-ldflags.patch
+ "${FILESDIR}"/${PV}-wrapper-r1.patch
+ "${FILESDIR}"/${PV}-paths.patch
+ "${FILESDIR}"/${PV}-makefile.patch
+ )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ TKVER=$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)
+ PYVER=${EPYTHON#python}
+}
+
+src_prepare() {
+ epatch ${PATCHES[@]}
+
+ sed -i \
+ -e "s:^\(set PYTHON =\).*:\1 ${EPREFIX}/usr/bin/${EPYTHON}:g" \
+ -e "s:^\(setenv SPARKY_INSTALL[[:space:]]*\).*:\1 ${EPREFIX}/usr/$(get_libdir)/${PN}:g" \
+ -e "s:tcl8.4:tcl${TKVER}:g" \
+ -e "s:tk8.4:tk${TKVER}:g" \
+ -e "s:^\(setenv TCLTK_LIB[[:space:]]*\).*:\1 ${EPREFIX}/usr/$(get_libdir):g" \
+ "${S}"/bin/sparky || die
+ eprefixify "${S}"/bin/sparky
+}
+
+src_compile() {
+ emake \
+ SPARKY="${S}" \
+ PYTHON_VERSION="${PYVER}" \
+ PYTHON_PREFIX="${EPREFIX}/usr" \
+ PYTHON_LIB="${EPREFIX}/usr/$(get_libdir)" \
+ PYTHON_INC="${EPREFIX}/usr/include/${EPYTHON}" \
+ TK_PREFIX="${EPREFIX}/usr" \
+ TCLTK_VERSION="${TKVER}" \
+ TKLIBS="-L${EPREFIX}/usr/$(get_libdir)/ -ltk -ltcl -lX11" \
+ CXX="$(tc-getCXX)" \
+ CC="$(tc-getCC)" \
+ LDSHARED="-shared" \
+ binaries
+
+ rm c++/*.o || die
+
+ emake \
+ SPARKY="${S}" \
+ PYTHON_VERSION="${PYVER}" \
+ PYTHON_PREFIX="${EPREFIX}/usr" \
+ PYTHON_LIB="${EPREFIX}/usr/$(get_libdir)" \
+ PYTHON_INC="${EPREFIX}/usr/include/${EPYTHON}" \
+ TK_PREFIX="${EPREFIX}/usr" \
+ TCLTK_VERSION="${TKVER}" \
+ TKLIBS="-L${EPREFIX}/usr/$(get_libdir)/ -ltk -ltcl -lX11" \
+ CXX="$(tc-getCXX)" \
+ CC="$(tc-getCC)" \
+ CXXFLAGS="${CXXFLAGS} -fPIC" \
+ CFLAGS="${CFLAGS} -fPIC" \
+ LDSHARED="-shared -fPIC" \
+ libraries
+}
+
+src_install() {
+ # The symlinks are needed to avoid hacking the complete code to fix the locations
+
+ dobin c++/{{bruk,matrix,peaks,pipe,vnmr}2ucsf,ucsfdata,sparky-no-python} bin/${PN}
+
+ insinto /usr/share/${PN}/
+ doins lib/{print-prolog.ps,Sparky}
+ dosym ../../share/${PN}/print-prolog.ps /usr/$(get_libdir)/${PN}/print-prolog.ps
+ dosym ../../share/${PN}/Sparky /usr/$(get_libdir)/${PN}/Sparky
+
+ dohtml -r manual/*
+ dosym ../../share/doc/${PF}/html /usr/$(get_libdir)/${PN}/manual
+
+ python_moduleinto ${PN}
+ python_domodule python/*.py c++/{spy.so,_tkinter.so}
+
+ python_optimize
+
+ dosym ../${EPYTHON}/site-packages /usr/$(get_libdir)/${PN}/python
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/
+ doins -r example || die
+ dosym ../../share/doc/${PF}/example /usr/$(get_libdir)/${PN}/example
+ fi
+
+ dodoc README
+ newdoc python/README README.python
+}