summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/oregano/oregano-0.82.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/oregano/oregano-0.82.ebuild')
-rw-r--r--sci-electronics/oregano/oregano-0.82.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/sci-electronics/oregano/oregano-0.82.ebuild b/sci-electronics/oregano/oregano-0.82.ebuild
new file mode 100644
index 000000000000..0ae4eb337190
--- /dev/null
+++ b/sci-electronics/oregano/oregano-0.82.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit autotools eutils fdo-mime vcs-snapshot gnome2-utils
+
+DESCRIPTION="Oregano is an application for schematic capture and simulation of electrical circuits"
+HOMEPAGE="https://github.com/marc-lorber/oregano"
+SRC_URI="https://github.com/marc-lorber/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+CDEPEND="dev-libs/libxml2:2
+ x11-libs/goocanvas:2.0
+ x11-libs/gtk+:3
+ x11-libs/gtksourceview:3.0
+ app-text/rarian"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ || ( gnome-base/dconf gnome-base/gconf )
+ sci-electronics/electronics-menu"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-format-security.patch
+ epatch "${FILESDIR}"/${P}-remove.unneeded.docs.patch
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ # Do not use GTK_DISABLE_DEPRECATED (needed by >=gtk+-3.8.1
+ sed -i -e "s/-DGTK_DISABLE_DEPRECATED//g" src/sheet/Makefile.am || die
+ sed -i -e "s/-DGTK_DISABLE_DEPRECATED//g" src/Makefile.am || die
+ sed -i -e "s/(OREGANO_LIBS)/(OREGANO_LIBS) -lm/" src/Makefile.am || die
+ # Aclocal 1.13 deprecated error #467708
+ epatch "${FILESDIR}"/${P}-automake.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-update-mimedb --disable-silent-rules
+}
+
+src_install() {
+ emake DESTDIR="${D}" oreganodocdir=/usr/share/doc/${PF} install
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ fdo-mime_desktop_database_update
+ elog "You'll need to emerge your prefered simulation backend"
+ elog "such ngspice or gnucap for simulation to work."
+ elog "As an alternative generate a netlist and use sci-electronics/spice"
+ elog "from the command line for simulation."
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}