summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-06-17 04:08:52 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-07-15 11:06:37 +0300
commitede0ccff7cf24d6313850f1d6af26de9fb942cb1 (patch)
tree38c1c2f09feeeef3393ab0628b53152bc3fd6434 /sci-libs/Shapely
parentdev-python/markups: use D_U_S on 3.0.0-r1 (diff)
downloadgentoo-ede0ccff7cf24d6313850f1d6af26de9fb942cb1.tar.gz
gentoo-ede0ccff7cf24d6313850f1d6af26de9fb942cb1.tar.bz2
gentoo-ede0ccff7cf24d6313850f1d6af26de9fb942cb1.zip
sci-libs/Shapely: version bump 1.7.0
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-libs/Shapely')
-rw-r--r--sci-libs/Shapely/Manifest1
-rw-r--r--sci-libs/Shapely/Shapely-1.7.0.ebuild34
-rw-r--r--sci-libs/Shapely/metadata.xml11
3 files changed, 45 insertions, 1 deletions
diff --git a/sci-libs/Shapely/Manifest b/sci-libs/Shapely/Manifest
index 7a73e5495f00..d651fc47bbeb 100644
--- a/sci-libs/Shapely/Manifest
+++ b/sci-libs/Shapely/Manifest
@@ -1 +1,2 @@
DIST Shapely-1.6.4.post2.tar.gz 225745 BLAKE2B 96e995db6dd1464bac7c2562efdc7f298a5f23c388e44f334db685b1cfa1025ff403db870e11328977a267483726504e03b6d7c47fe4234a3a5966a13b2b7311 SHA512 027c816ef2104f654569ca658b52b87c60e5ba6a45927fcc51c23dd1922f3f9f7fdcea3601160b0a999e39611617142833ccac790777093be8b96a0d9083f78f
+DIST Shapely-1.7.0.tar.gz 349089 BLAKE2B da2cb377334ea49c863cff1e22d3551a1015c6eb7284b8bb87743159050e279429728671a994f4858433ca8543b66504244203e1fd24811063f4f86365e04532 SHA512 ff7a14f20c05e3949c1e689175b80ec1f8248a0f45370a6313dbf4319ec018a8fafcfd171efbaa81bd8ceaab9c54488feca61bb03067e22a275da2b8663dc8bc
diff --git a/sci-libs/Shapely/Shapely-1.7.0.ebuild b/sci-libs/Shapely/Shapely-1.7.0.ebuild
new file mode 100644
index 000000000000..61402b2ac2a9
--- /dev/null
+++ b/sci-libs/Shapely/Shapely-1.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="https://pypi.org/project/Shapely/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=sci-libs/geos-3.3
+"
+
+BDEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ distutils_install_for_testing
+ ${PYTHON} -m pytest tests || die "tests failed under ${EPYTHON}"
+}
diff --git a/sci-libs/Shapely/metadata.xml b/sci-libs/Shapely/metadata.xml
index 8c6ed6fdd97a..4cb05623997a 100644
--- a/sci-libs/Shapely/metadata.xml
+++ b/sci-libs/Shapely/metadata.xml
@@ -1,8 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>expeditioneer@gentoo.org</email>
+ <name>Dennis Lamm</name>
+ </maintainer>
+ <longdescription>
+ Shapely is a BSD-licensed Python package for manipulation and analysis of planar geometric objects.
+ It is based on the widely deployed GEOS (the engine of PostGIS) and JTS (from which GEOS is ported) libraries.
+ Shapely is not concerned with data formats or coordinate systems, but can be readily integrated with packages that are.
+ </longdescription>
<upstream>
+ <remote-id type="github">Toblerity/Shapely</remote-id>
<remote-id type="pypi">Shapely</remote-id>
</upstream>
</pkgmetadata>