summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-12 07:57:05 +0100
committerSam James <sam@gentoo.org>2021-10-12 07:57:28 +0100
commit35ea7e100c06811630c44ad85a2c48db39494e9c (patch)
tree8a8eae40ebd3464aa8c1971bc760761b0e40179c /sci-libs/h5hut/h5hut-1.99.13-r1.ebuild
parentmedia-sound/yoshimi: bump to 2.1.1 (diff)
downloadgentoo-35ea7e100c06811630c44ad85a2c48db39494e9c.tar.gz
gentoo-35ea7e100c06811630c44ad85a2c48db39494e9c.tar.bz2
gentoo-35ea7e100c06811630c44ad85a2c48db39494e9c.zip
sci-libs/h5hut: depend on older hdf5lib for now
Doesn't seem to build with newer versions. Bug: https://bugs.gentoo.org/809221 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/h5hut/h5hut-1.99.13-r1.ebuild')
-rw-r--r--sci-libs/h5hut/h5hut-1.99.13-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-libs/h5hut/h5hut-1.99.13-r1.ebuild b/sci-libs/h5hut/h5hut-1.99.13-r1.ebuild
new file mode 100644
index 000000000000..ff0a0934aceb
--- /dev/null
+++ b/sci-libs/h5hut/h5hut-1.99.13-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MY_P="${P^h}"
+DESCRIPTION="High-Performance I/O Library for Particle-based Simulations"
+HOMEPAGE="http://www-vis.lbl.gov/Research/H5hut/"
+SRC_URI="https://amas.psi.ch/H5hut/raw-attachment/wiki/DownloadSources/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ virtual/mpi
+ <sci-libs/hdf5-1.12[mpi]
+ "
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-mpio.patch"
+ "${FILESDIR}/${P}-autotools.patch"
+ )
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-parallel --enable-shared --disable-static CC=mpicc CXX=mpicxx
+}