summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Persson Forsberg <cat@catcream.org>2023-08-03 02:00:31 +0200
committerSam James <sam@gentoo.org>2023-08-09 21:43:22 +0100
commit83c21c4aa868798e09be47c810f0478329c6dd1b (patch)
treec32cf6ae51dab31a028110de6414f8be3e27b6d7 /sci-libs/openlibm
parentdev-libs/libwapcaplet: drop obsolete -Werror patch (diff)
downloadgentoo-83c21c4aa868798e09be47c810f0478329c6dd1b.tar.gz
gentoo-83c21c4aa868798e09be47c810f0478329c6dd1b.tar.bz2
gentoo-83c21c4aa868798e09be47c810f0478329c6dd1b.zip
sci-libs/openlibm: add USE=static-libs
USE=static-libs is currently required for llvm-libc. Signed-off-by: Alfred Persson Forsberg <cat@catcream.org> Closes: https://github.com/gentoo/gentoo/pull/32151 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/openlibm')
-rw-r--r--sci-libs/openlibm/openlibm-0.8.0.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sci-libs/openlibm/openlibm-0.8.0.ebuild b/sci-libs/openlibm/openlibm-0.8.0.ebuild
index ba45cbd625fb..3d2362897851 100644
--- a/sci-libs/openlibm/openlibm-0.8.0.ebuild
+++ b/sci-libs/openlibm/openlibm-0.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,6 +9,7 @@ DESCRIPTION="High quality system independent, open source libm"
HOMEPAGE="https://github.com/JuliaLang/openlibm"
SRC_URI="https://github.com/JuliaMath/openlibm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="static-libs"
LICENSE="public-domain MIT ISC BSD-2 LGPL-2.1+"
# See https://abi-laboratory.pro/index.php?view=timeline&l=openlibm
SLOT="0/4"
@@ -16,9 +17,10 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
src_prepare() {
default
- sed -e "/^OLM_LIBS :=/s/^/#/" \
- -e "/install: /s/install-static//" \
- -i Makefile || die
+ sed -e "/^OLM_LIBS :=/s/^/#/" -i Makefile || die
+ if ! use static-libs ; then
+ sed -e "/install: /s/install-static//" -i Makefile || die
+ fi
}
src_configure() {