summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/spooles/spooles-2.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/spooles/spooles-2.2.ebuild')
-rw-r--r--sci-libs/spooles/spooles-2.2.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/sci-libs/spooles/spooles-2.2.ebuild b/sci-libs/spooles/spooles-2.2.ebuild
new file mode 100644
index 000000000000..3950a6621db2
--- /dev/null
+++ b/sci-libs/spooles/spooles-2.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs versionator flag-o-matic
+
+MYP=${PN}.${PV}
+
+DESCRIPTION="SParse Object Oriented Linear Equations Solver"
+HOMEPAGE="http://www.netlib.org/linalg/spooles"
+SRC_URI="http://www.netlib.org/linalg/${PN}/${MYP}.tgz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="mpi static-libs threads"
+
+RDEPEND="mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+make_shared_lib() {
+ local soname=$(basename "${1%.a}").so.$(get_major_version)
+ einfo "Making ${soname}"
+ ${2:-$(tc-getCC)} ${LDFLAGS} \
+ -shared -Wl,-soname="${soname}" \
+ -Wl,--whole-archive "${1}" -Wl,--no-whole-archive \
+ -o $(dirname "${1}")/"${soname}" || return 1
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-I2Ohash-64bit.patch
+ epatch "${FILESDIR}"/${P}-makefiles.patch
+ epatch "${FILESDIR}"/${P}-formats.patch
+ find . -name makefile -exec \
+ sed -i -e 's:make:$(MAKE):g' '{}' \;
+ sed -e "s/@CC@/$(tc-getCC)/" \
+ -e "s/@AR@/$(tc-getAR)/" \
+ -e "s/@RANLIB@/$(tc-getRANLIB)/" \
+ "${FILESDIR}"/Make.inc.in > Make.inc || die
+}
+
+src_compile () {
+ append-flags -fPIC
+ emake lib
+ use threads && emake -C MT lib
+ use mpi && emake -C MPI CC=mpicc lib
+ make_shared_lib libspooles.a $(use mpi && echo mpicc) || die "shared lib failed"
+ if use static-libs; then
+ filter-flags -fPIC
+ emake clean
+ emake lib
+ use threads && emake -C MT lib
+ use mpi && emake -C MPI CC=mpicc lib
+ fi
+}
+
+src_install () {
+ dolib.so libspooles.so.2
+ dosym libspooles.so.2 /usr/$(get_libdir)/libspooles.so
+ use static-libs && dolib.a libspooles.a
+ find . -name '*.h' -print0 | \
+ xargs -0 -n1 --replace=headerfile install -D headerfile tmp/headerfile
+ insinto /usr/include/${PN}
+ doins -r tmp/*
+}