summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-20 23:02:22 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-20 23:06:21 +0200
commitc1e4efd807e9cce5c6d5a9809360c83881a5f053 (patch)
treed3b64f40cd75513412a280483366252e87549d5c /sci-libs/spr/spr-3.3.2.ebuild
parentsci-chemistry/reduce: Allow for compiling with GCC 6 (diff)
downloadgentoo-c1e4efd807e9cce5c6d5a9809360c83881a5f053.tar.gz
gentoo-c1e4efd807e9cce5c6d5a9809360c83881a5f053.tar.bz2
gentoo-c1e4efd807e9cce5c6d5a9809360c83881a5f053.zip
sci-libs/spr: Allow for compiling with GCC 6
Gentoo-bug: 594376 * EAPI=6 Package-Manager: portage-2.3.1
Diffstat (limited to 'sci-libs/spr/spr-3.3.2.ebuild')
-rw-r--r--sci-libs/spr/spr-3.3.2.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/sci-libs/spr/spr-3.3.2.ebuild b/sci-libs/spr/spr-3.3.2.ebuild
index dad4d53b9e76..d63e597993b8 100644
--- a/sci-libs/spr/spr-3.3.2.ebuild
+++ b/sci-libs/spr/spr-3.3.2.ebuild
@@ -1,15 +1,14 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
-inherit eutils autotools
+EAPI=6
-MYP=SPR-${PV}
+inherit autotools
DESCRIPTION="Statistical analysis and machine learning library"
HOMEPAGE="http://statpatrec.sourceforge.net/"
-SRC_URI="mirror://sourceforge/statpatrec/${MYP}.tar.gz"
+SRC_URI="mirror://sourceforge/statpatrec/${P^^}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -20,15 +19,18 @@ IUSE="root static-libs"
DEPEND="root? ( sci-physics/root )"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${MYP}
+S=${WORKDIR}/${P^^}
+PATCHES=(
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-gcc46.patch
+ "${FILESDIR}"/${P}-fix-c++14.patch
+)
src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-autotools.patch \
- "${FILESDIR}"/${P}-gcc46.patch
+ default
rm aclocal.m4 || die
eautoreconf
- cp data/gauss* src/
+ cp data/gauss* src/ || die
}
src_configure() {