summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Rossi <rossi.f@inwind.it>2022-05-31 15:12:48 +0200
committerSam James <sam@gentoo.org>2022-06-03 04:15:25 +0100
commit27ba48650af3037fa8adf06220d4e5f1373f5885 (patch)
treea80721ac0579795937499ddea466e42a1d92d406 /sci-mathematics/petsc
parentapp-vim/gitgutter: update Manifest (diff)
downloadgentoo-27ba48650af3037fa8adf06220d4e5f1373f5885.tar.gz
gentoo-27ba48650af3037fa8adf06220d4e5f1373f5885.tar.bz2
gentoo-27ba48650af3037fa8adf06220d4e5f1373f5885.zip
sci-mathematics/petsc: fix configuration with USE=mumps
Bug: https://bugs.gentoo.org/848789 Signed-off-by: Fabio Rossi <rossi.f@inwind.it> Closes: https://github.com/gentoo/gentoo/pull/25701 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics/petsc')
-rw-r--r--sci-mathematics/petsc/petsc-3.16.0.ebuild4
-rw-r--r--sci-mathematics/petsc/petsc-3.17.1.ebuild2
2 files changed, 3 insertions, 3 deletions
diff --git a/sci-mathematics/petsc/petsc-3.16.0.ebuild b/sci-mathematics/petsc/petsc-3.16.0.ebuild
index f39f87d8c281..efe8f2be01e6 100644
--- a/sci-mathematics/petsc/petsc-3.16.0.ebuild
+++ b/sci-mathematics/petsc/petsc-3.16.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -171,7 +171,7 @@ src_configure() {
[-lptesmumps,-lptscotch,-lptscotcherr,-lscotch,-lscotcherr]) \
$(petsc_with mumps scalapack \
/usr/include/scalapack -lscalapack) \
- $(use_with mumps mumps \
+ $(petsc_with mumps mumps \
/usr/include \
[-lcmumps,-ldmumps,-lsmumps,-lzmumps,-lmumps_common,-lpord]) \
--with-imagemagick=0 \
diff --git a/sci-mathematics/petsc/petsc-3.17.1.ebuild b/sci-mathematics/petsc/petsc-3.17.1.ebuild
index 241199f5fa1c..5b316ba60986 100644
--- a/sci-mathematics/petsc/petsc-3.17.1.ebuild
+++ b/sci-mathematics/petsc/petsc-3.17.1.ebuild
@@ -168,12 +168,12 @@ src_configure() {
$(petsc_with superlu superlu /usr/include/superlu -lsuperlu) \
$(petsc_with scotch ptscotch /usr/include/scotch [-lptesmumps,-lptscotch,-lptscotcherr,-lscotch,-lscotcherr]) \
$(petsc_with mumps scalapack /usr/include/scalapack -lscalapack) \
+ $(petsc_with mumps mumps /usr/include [-lcmumps,-ldmumps,-lsmumps,-lzmumps,-lmumps_common,-lpord]) \
$(use fortran && echo "$(petsc_select mpi fc mpif77 $(tc-getF77))") \
$(use int64 && echo "--with-index-size=64") \
$(use_with boost) \
$(use_with fftw) \
$(use_with hdf5) \
- $(use_with mumps mumps /usr/include [-lcmumps,-ldmumps,-lsmumps,-lzmumps,-lmumps_common,-lpord]) \
$(use_with X x) \
$(use_with X x11)
}