summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-07-23 19:28:01 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-07-23 19:41:00 +0200
commit09e3e38929c16b3cfde3d2ac41d780fc2c3bc9ba (patch)
tree4e2a7142085f90a8547e8e509ac50fb1e4fb825a /sci-mathematics
parentsci-mathematics/vampire: restrict z3 dep version (diff)
downloadgentoo-09e3e38929c16b3cfde3d2ac41d780fc2c3bc9ba.tar.gz
gentoo-09e3e38929c16b3cfde3d2ac41d780fc2c3bc9ba.tar.bz2
gentoo-09e3e38929c16b3cfde3d2ac41d780fc2c3bc9ba.zip
sci-mathematics/vampire: bump to 4.7
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/vampire/Manifest1
-rw-r--r--sci-mathematics/vampire/vampire-4.7.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sci-mathematics/vampire/Manifest b/sci-mathematics/vampire/Manifest
index fc80f8c57360..68e6a43c3a78 100644
--- a/sci-mathematics/vampire/Manifest
+++ b/sci-mathematics/vampire/Manifest
@@ -1 +1,2 @@
DIST vampire-4.6.1.tar.gz 1511760 BLAKE2B 52ede8ac009379b15bc57b2ffe45965cbaf772f0e90bc619d859b85b77ce81eadbdd7ddae7c5e0e9cc69564a07f0abefa17109f7192e6afe634a5a929817fe92 SHA512 7ffeee64e9e4666344c0f9155c7e980920666813388416062cee89e43003fef5a8a54b8656cc42d2fa58b6fb3b87ef7f2c671bfc6787075df4058dcc3a1d46e1
+DIST vampire-4.7.tar.gz 1462358 BLAKE2B 10fdf4076bbcd7113da575d19890634a5142dd6917c028eb7ae0e94405df9e6915fc6127956d39b6f9f97242958b0fa04fa9e835853f09cec381786862009ef5 SHA512 978169a9b4d561dce1d55aa9a61a8b302657ff758036309d9c5f58a5d9271b874ac020d110fbb2a16d34f2ccdd10a497eb469829c91d58530dba5e1cd8978d78
diff --git a/sci-mathematics/vampire/vampire-4.7.ebuild b/sci-mathematics/vampire/vampire-4.7.ebuild
new file mode 100644
index 000000000000..bd33eda2b980
--- /dev/null
+++ b/sci-mathematics/vampire/vampire-4.7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=2d02e4655e1b08d1ca9ee7c0aade40f59f046460 # "bump to 4.7"
+
+inherit cmake
+
+DESCRIPTION="The Vampire Prover, theorem prover for first-order logic"
+HOMEPAGE="https://vprover.github.io"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vprover/${PN}.git"
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/vprover/${PN}/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${H}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE="debug +z3"
+# debug mode needs to be enabled for tests
+# https://github.com/vprover/vampire/blob/8197e1d2d86a0b276b5fcb6c02d8122f66b7277e/CMakeLists.txt#L38
+RESTRICT="!debug? ( test )"
+
+RDEPEND="
+ z3? (
+ dev-libs/gmp:=
+ <sci-mathematics/z3-4.10:=
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local CMAKE_BUILD_TYPE
+ if use debug ; then
+ CMAKE_BUILD_TYPE=Debug
+ else
+ CMAKE_BUILD_TYPE=Release
+ fi
+
+ local mycmakeargs=( -DZ3_DIR=$(usex z3 "/usr/$(get_libdir)/cmake/z3/" "") )
+ cmake_src_configure
+}
+
+src_install() {
+ local bin_name=$(find "${BUILD_DIR}"/bin/ -type f -name "${PN}*")
+ dobin "${bin_name}"
+ dosym $(basename "${bin_name}") /usr/bin/${PN}
+
+ einstalldocs
+}