summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-19 03:30:06 +0000
committerSam James <sam@gentoo.org>2023-03-19 03:30:06 +0000
commitc99effcf638c1461308af9068c8f7aeca6b374bd (patch)
treea7291e658f539e85ab235a7b931fe7e728a148b2 /sys-apps/dmidecode
parentsys-apps/dmidecode: Enable LFS (diff)
downloadgentoo-c99effcf638c1461308af9068c8f7aeca6b374bd.tar.gz
gentoo-c99effcf638c1461308af9068c8f7aeca6b374bd.tar.bz2
gentoo-c99effcf638c1461308af9068c8f7aeca6b374bd.zip
sys-apps/dmidecode: simplify via append-lfs-flags
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/dmidecode')
-rw-r--r--sys-apps/dmidecode/dmidecode-3.4-r1.ebuild8
-rw-r--r--sys-apps/dmidecode/dmidecode-3.5-r1.ebuild6
2 files changed, 9 insertions, 5 deletions
diff --git a/sys-apps/dmidecode/dmidecode-3.4-r1.ebuild b/sys-apps/dmidecode/dmidecode-3.4-r1.ebuild
index 92d65b193d64..cf9d5fc8f094 100644
--- a/sys-apps/dmidecode/dmidecode-3.4-r1.ebuild
+++ b/sys-apps/dmidecode/dmidecode-3.4-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# Upstream often give "recommended patches" at https://www.nongnu.org/dmidecode/
# Check regularly after releases!
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="DMI (Desktop Management Interface) table related utilities"
HOMEPAGE="https://www.nongnu.org/dmidecode/"
@@ -29,8 +29,10 @@ src_prepare() {
}
src_compile() {
+ append-lfs-flags
+
emake \
- CFLAGS="-D_FILE_OFFSET_BITS=64 ${CFLAGS} ${CPPFLAGS}" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" \
CC="$(tc-getCC)"
}
diff --git a/sys-apps/dmidecode/dmidecode-3.5-r1.ebuild b/sys-apps/dmidecode/dmidecode-3.5-r1.ebuild
index 07d8528c8c98..516ba585f352 100644
--- a/sys-apps/dmidecode/dmidecode-3.5-r1.ebuild
+++ b/sys-apps/dmidecode/dmidecode-3.5-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
# Upstream often give "recommended patches" at https://www.nongnu.org/dmidecode/
# Check regularly after releases!
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="DMI (Desktop Management Interface) table related utilities"
HOMEPAGE="https://www.nongnu.org/dmidecode/"
@@ -29,8 +29,10 @@ src_prepare() {
}
src_compile() {
+ append-lfs-flags
+
emake \
- CFLAGS="-D_FILE_OFFSET_BITS=64 ${CFLAGS} ${CPPFLAGS}" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" \
CC="$(tc-getCC)"
}