summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-15 11:40:04 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-15 11:47:18 +0200
commita2c43d94372373d59388982648872d7c308ac7a9 (patch)
treeca8dd06d972528ddfc5d9624d1a4b7a9e35ab329 /sys-apps/gsmartcontrol
parentdev-python/testtools: Bump to version 2.3.0 (diff)
downloadgentoo-a2c43d94372373d59388982648872d7c308ac7a9.tar.gz
gentoo-a2c43d94372373d59388982648872d7c308ac7a9.tar.bz2
gentoo-a2c43d94372373d59388982648872d7c308ac7a9.zip
sys-apps/gsmartcontrol: Bump to version 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sys-apps/gsmartcontrol')
-rw-r--r--sys-apps/gsmartcontrol/Manifest1
-rw-r--r--sys-apps/gsmartcontrol/gsmartcontrol-0.9.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/gsmartcontrol/Manifest b/sys-apps/gsmartcontrol/Manifest
index 85a7c9d95bb1..f7b0dee6e11b 100644
--- a/sys-apps/gsmartcontrol/Manifest
+++ b/sys-apps/gsmartcontrol/Manifest
@@ -1 +1,2 @@
DIST gsmartcontrol-0.8.7.tar.bz2 684394 SHA256 708fa803243abb852ed52050fc82cd3592a798c02743342441996e77f19ffec6 SHA512 3258ddcb448460afeef8d617ab5bb4720c9b2444452bc45d6798ec645da4862236fbb3fe0116a1cc904f5353481df87603bd2b6d808f348c250bde3624c8403a WHIRLPOOL 24fb546c7175306c8cdd8906b506471d20668de0cd078a8205ec87eff50ce0eb52dc04b3b05e771f8789ef852e5f97675c7c224ab6450d90a3e2ac3e51578d2a
+DIST gsmartcontrol-0.9.0.tar.bz2 710515 SHA256 5da6435aa0845acef134f72c2b5f6fce79f9c51bebe9d099402e0f21a3388651 SHA512 c7a6f4dbb748bdef14a3a18a98d30f8ba8595017c99d7ac6817a33d537f19ab55d2c5674fb1f44f77381e54e22b894d8cca700554186a8132b04249001fcda98 WHIRLPOOL 2b9e926e86bbd351ec3ed331abec508cbc129e1ca340106ffa2cd8aa8f9db13c721512f8afa4e70cd83ea1ae855e0fb494223264129ce6a583fb717d69d2a1ca
diff --git a/sys-apps/gsmartcontrol/gsmartcontrol-0.9.0.ebuild b/sys-apps/gsmartcontrol/gsmartcontrol-0.9.0.ebuild
new file mode 100644
index 000000000000..b74f1347fff2
--- /dev/null
+++ b/sys-apps/gsmartcontrol/gsmartcontrol-0.9.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic gnome2-utils
+
+DESCRIPTION="Hard disk drive health inspection tool"
+HOMEPAGE="http://gsmartcontrol.sourceforge.net/home/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 GPL-3 ) Boost-1.0 BSD Unlicense ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="
+ dev-cpp/gtkmm:2.4
+ dev-libs/libpcre:3
+ sys-apps/smartmontools
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xmessage
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/gtk-builder-convert )
+"
+
+DOCS="TODO" # See 'dist_doc_DATA' value in Makefile.am
+
+src_prepare() {
+ default
+ append-cxxflags -std=c++11
+}
+
+src_configure() {
+ econf $(use test tests)
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/share/doc/${PF}/LICENSE_* || die
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }