summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2018-01-21 21:41:44 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-24 20:52:12 +0100
commitfb58aa1b3479fb9014d2aeccac0cda8dea7a4e0f (patch)
treebf56c2c80a49ad7d4c16c27df74cdf5437185391 /sys-apps/hd-idle/hd-idle-1.05.ebuild
parentdev-db/etcd: Version bump to 3.3.0_rc4 (diff)
downloadgentoo-fb58aa1b3479fb9014d2aeccac0cda8dea7a4e0f.tar.gz
gentoo-fb58aa1b3479fb9014d2aeccac0cda8dea7a4e0f.tar.bz2
gentoo-fb58aa1b3479fb9014d2aeccac0cda8dea7a4e0f.zip
sys-apps/hd-idle: new package.
Utility for spinning down hard disks after a period of idle time. Package-Manager: Portage-2.3.20, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/6927
Diffstat (limited to 'sys-apps/hd-idle/hd-idle-1.05.ebuild')
-rw-r--r--sys-apps/hd-idle/hd-idle-1.05.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-apps/hd-idle/hd-idle-1.05.ebuild b/sys-apps/hd-idle/hd-idle-1.05.ebuild
new file mode 100644
index 000000000000..4da29a661672
--- /dev/null
+++ b/sys-apps/hd-idle/hd-idle-1.05.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info
+
+DESCRIPTION="Utility for spinning down hard disks after a period of idle time"
+HOMEPAGE="http://hd-idle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}"
+
+CONFIG_CHECK="~PROC_FS"
+
+DOCS=( debian/changelog README )
+
+src_install() {
+ default_src_install
+ newinitd "${FILESDIR}"/hd-idle-init hd-idle
+ newconfd "${FILESDIR}"/hd-idle-conf hd-idle
+}