summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-11-05 00:14:25 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-11-05 00:33:07 -0800
commitdadadaf7df6321b7ae80cc28404c2e31968df393 (patch)
tree9f59e536e44fbf7be7f76abb670ac95b48e58276 /sys-apps/hwloc
parentprofiles/arch/base/package.use.mask: update hwloc mask (diff)
downloadgentoo-dadadaf7df6321b7ae80cc28404c2e31968df393.tar.gz
gentoo-dadadaf7df6321b7ae80cc28404c2e31968df393.tar.bz2
gentoo-dadadaf7df6321b7ae80cc28404c2e31968df393.zip
sys-apps/hwloc: timeout bump to 2.3.0, fix multiple issues
fixed bash completion installation and aliases fixed rustatedir, previosly it pointed to /var/lib/hwloc/run dropped USE=plugins, disabled ltdl dep. add missing nvml dependency only install systemd unit on *86/64 arches. use BDEPEND for some deps. Closes: https://bugs.gentoo.org/727174 Closes: https://bugs.gentoo.org/723018 Closes: https://bugs.gentoo.org/711890 Closes: https://bugs.gentoo.org/724622 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-apps/hwloc')
-rw-r--r--sys-apps/hwloc/Manifest1
-rw-r--r--sys-apps/hwloc/hwloc-2.3.0.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/sys-apps/hwloc/Manifest b/sys-apps/hwloc/Manifest
index 592f63c97ac7..d68e9a55e661 100644
--- a/sys-apps/hwloc/Manifest
+++ b/sys-apps/hwloc/Manifest
@@ -3,3 +3,4 @@ DIST hwloc-1.11.13.tar.bz2 4120436 BLAKE2B a6a09f7d6abeaa9d23df555cfd2186ae61f0f
DIST hwloc-1.11.2.tar.bz2 4019136 BLAKE2B 29a959c48b3be347b5816333c3f9948ddafc6c4882d7c646c956ae08d72827dd4cef22da7842a034e3131e0044f9528573c6dfceb373869c326890f23651d967 SHA512 aa54b6389c303470a00dbbb3ae5f688244d0f1e0d84e661b739933ff9d86928869f2f3be04fe621cdf06c206defcd4ea1c9e8b72696f7cada9bb3243c3feba68
DIST hwloc-2.0.4.tar.bz2 6057001 BLAKE2B 0d73c2ec544263bb36404d8112412b6b308935b9b8b4ba37cac05d8bdc525763fa862c63d387545cb0e02e1bd8f1c931e034381dede83b7119f30928f4e54bf4 SHA512 c7bb69f0e536188921138d003f3854a12f942a4f625e665d5ce6d32c1c4a884e0a91f9125de33dd292f522032b759e6240df3f3e53534033567ea0d829feefce
DIST hwloc-2.1.0.tar.bz2 6272755 BLAKE2B 3ab13bd5cd00c4c19a1c4b1de21fb799038bd0afaa86520696478eada8d0ac11a4f4de11b96b0d92495b431f4b49ccb4185b176ad5abb9372ba6c5c9794ef21c SHA512 3fda7c4152c3f1b701c3da0fcbbe7e1dffb502042cb86e9a44ce6df8e227c005333e61d5459407f88efbd56816db0ab90b19f75d047e0c77b3b7f5c6405ea501
+DIST hwloc-2.3.0.tar.bz2 6414781 BLAKE2B 60bc80ae73d0ae9ff9a438474efe682dfff28149b843645c928d4c5531f25c7763311816d5c86028efa9e07aa86935dbb6cff56ec429ee607ce4e5b5b88d4bbe SHA512 ecb0950cd08eab7d97f7cbef9db0dc31cb5b4debedaae6f48814625ee5da0153fdc1f863fa84c5d59b76634e877a348fa556f3c8c29fc43bc6ae7211c313906c
diff --git a/sys-apps/hwloc/hwloc-2.3.0.ebuild b/sys-apps/hwloc/hwloc-2.3.0.ebuild
new file mode 100644
index 000000000000..6167e28c6bfc
--- /dev/null
+++ b/sys-apps/hwloc/hwloc-2.3.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools bash-completion-r1 cuda flag-o-matic systemd toolchain-funcs multilib-minimal
+
+MY_PV="v$(ver_cut 1-2)"
+
+DESCRIPTION="displays the hardware topology in convenient formats"
+HOMEPAGE="https://www.open-mpi.org/projects/hwloc/"
+SRC_URI="https://www.open-mpi.org/software/${PN}/${MY_PV}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0/15"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="cairo +cpuid cuda debug gl libudev netloc nvml +pci static-libs svg xml X"
+
+# opencl support dropped with x11-drivers/ati-drivers being removed (#582406).
+# Anyone with hardware is welcome to step up and help test to get it re-added.
+
+RDEPEND=">=sys-libs/ncurses-5.9-r3:0[${MULTILIB_USEDEP}]
+
+ cairo? ( >=x11-libs/cairo-1.12.14-r4[X?,svg?,${MULTILIB_USEDEP}] )
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-6.5.19-r1:= )
+ gl? ( x11-drivers/nvidia-drivers[static-libs,tools] )
+ libudev? ( virtual/libudev )
+ netloc? ( !sys-apps/netloc )
+ nvml? ( x11-drivers/nvidia-drivers[${MULTILIB_USEDEP}] )
+ pci? (
+ >=sys-apps/pciutils-3.3.0-r2[${MULTILIB_USEDEP}]
+ >=x11-libs/libpciaccess-0.13.1-r1[${MULTILIB_USEDEP}]
+ )
+ xml? ( >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+# 2.69-r5 for --runstatedir
+BDEPEND="
+ >=sys-devel/autoconf-2.69-r5
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}/${PN}-1.8.1-gl.patch" )
+DOCS=( AUTHORS NEWS README VERSION )
+
+src_prepare() {
+ default
+ eautoreconf
+
+ if use cuda ; then
+ append-cflags "-I${EPREFIX}/opt/cuda/include"
+ append-cppflags "-I${EPREFIX}/opt/cuda/include"
+ fi
+}
+
+multilib_src_configure() {
+ export HWLOC_PKG_CONFIG="$(tc-getPKG_CONFIG)" #393467
+
+ if use cuda ; then
+ local -x LDFLAGS="${LDFLAGS}"
+ append-ldflags "-L${EPREFIX}/opt/cuda/$(get_libdir)"
+ fi
+
+ local myconf=(
+ --disable-opencl
+ --disable-plugin-ltdl
+ --enable-plugins
+ --enable-shared
+ --runstatedir="${EPREFIX}/run"
+ $(multilib_native_use_enable cuda)
+ $(multilib_native_use_enable gl)
+ $(use_enable cairo)
+ $(use_enable cpuid)
+ $(use_enable debug)
+ $(use_enable libudev)
+ $(use_enable netloc)
+ $(use_enable nvml)
+ $(use_enable pci)
+ $(use_enable static-libs static)
+ $(use_enable xml libxml2)
+ $(use_with X x)
+ )
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ default
+ case ${ARCH} in
+ # hwloc-dump-hwdata binary only built on those arches, so don't install non-working unit.
+ amd64|x86)
+ systemd_dounit "${ED}/usr/share/hwloc/hwloc-dump-hwdata.service" ;;
+ esac
+ mv "${ED}"/usr/share/bash-completion/completions/hwloc{,-annotate} || die
+ bashcomp_alias hwloc-annotate \
+ hwloc-{diff,ps,compress-dir,gather-cpuid,distrib,info,bind,patch,calc,ls,gather-topology}
+ bashcomp_alias hwloc-annotate lstopo{,-no-graphics}
+ find "${ED}" -name '*.la' -delete || die
+}