summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-12-22 17:51:08 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-12-22 17:51:08 +0200
commitadbb1e89cc535aa8fb55a3047e2102ea24ee3c28 (patch)
tree5cf6c7296978ed721f50f013044dbe3149a2aa43 /sys-apps/pkgcore
parentdev-python/snakeoil: add 0.10.6 (diff)
downloadgentoo-adbb1e89cc535aa8fb55a3047e2102ea24ee3c28.tar.gz
gentoo-adbb1e89cc535aa8fb55a3047e2102ea24ee3c28.tar.bz2
gentoo-adbb1e89cc535aa8fb55a3047e2102ea24ee3c28.zip
sys-apps/pkgcore: add 0.12.24
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-apps/pkgcore')
-rw-r--r--sys-apps/pkgcore/Manifest1
-rw-r--r--sys-apps/pkgcore/pkgcore-0.12.24.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/pkgcore/Manifest b/sys-apps/pkgcore/Manifest
index 03dab10606e7..c6b11b9a3b54 100644
--- a/sys-apps/pkgcore/Manifest
+++ b/sys-apps/pkgcore/Manifest
@@ -1 +1,2 @@
DIST pkgcore-0.12.23.tar.gz 632146 BLAKE2B c5e5911c957c48edac39e6da54456d0691205c4ccf170f34379d4e69ab519f5985247e172f63aac69c8fd2ef0c8bf5ec710faf6d3f88ccdd8718b50f919d5a17 SHA512 a5ff9c8cae148caa62e5562941d62da9964d1c0bab237249b258b46b225223c5cf630db1cf13dd9e03fc4936382eddaf823c4cb32d52578764ef903a678f845d
+DIST pkgcore-0.12.24.tar.gz 634733 BLAKE2B 0d235f7acf81ead37ea30cd4cc2423a00cca92f0e3188b113f1171cb88a07cfa3829161f6e5c90bbdfcd96f0d579c48cf880474f07268dae885588e3fc724ce3 SHA512 956c7a4b637611e8f2bb2e7b35224c2c1adc2c26e0ee56b3d832b3a0533e46d36fdfeca0d82d835a24b604e22c7e8915e8ffdb0098a6a761e539b98b2ceab962
diff --git a/sys-apps/pkgcore/pkgcore-0.12.24.ebuild b/sys-apps/pkgcore/pkgcore-0.12.24.ebuild
new file mode 100644
index 000000000000..3f64d0ccb6e6
--- /dev/null
+++ b/sys-apps/pkgcore/pkgcore-0.12.24.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/pkgcore/pkgcore.git
+ https://github.com/pkgcore/pkgcore.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ inherit pypi
+fi
+
+DESCRIPTION="a framework for package management"
+HOMEPAGE="https://github.com/pkgcore/pkgcore"
+
+LICENSE="BSD MIT"
+SLOT="0"
+
+RDEPEND="
+ >=app-shells/bash-5.0[readline]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND+=" >=dev-python/snakeoil-0.10.4[${PYTHON_USEDEP}]"
+fi
+BDEPEND="
+ >=dev-python/flit-core-3.8[${PYTHON_USEDEP}]
+ test? (
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ local DOCS=( NEWS.rst )
+ [[ ${PV} == *9999 ]] || doman build/sphinx/man/*
+ distutils-r1_python_install_all
+}