summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2022-06-03 09:44:02 -0400
committerKenton Groombridge <concord@gentoo.org>2022-06-03 21:03:20 -0400
commitf542f2f9aa91006f03d936da1afe731086be12e9 (patch)
treefd3caf81a189741179686777f7b9f435f7cd9136 /sys-apps/secilc/secilc-3.4_rc1.ebuild
parentsys-libs/libsepol: drop 3.4_rc1 (diff)
downloadgentoo-f542f2f9aa91006f03d936da1afe731086be12e9.tar.gz
gentoo-f542f2f9aa91006f03d936da1afe731086be12e9.tar.bz2
gentoo-f542f2f9aa91006f03d936da1afe731086be12e9.zip
sys-apps/secilc: drop 3.4_rc1
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'sys-apps/secilc/secilc-3.4_rc1.ebuild')
-rw-r--r--sys-apps/secilc/secilc-3.4_rc1.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/sys-apps/secilc/secilc-3.4_rc1.ebuild b/sys-apps/secilc/secilc-3.4_rc1.ebuild
deleted file mode 100644
index 13b261011af0..000000000000
--- a/sys-apps/secilc/secilc-3.4_rc1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-inherit toolchain-funcs
-
-MY_PV="${PV//_/-}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="SELinux Common Intermediate Language (CIL) Compiler"
-HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
- S="${WORKDIR}/${P}/${PN}"
-else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-DEPEND=">=sys-libs/libsepol-${PV}"
-RDEPEND="${DEPEND}"
-BDEPEND="app-text/xmlto"
-
-# tests are not meant to be run outside of the
-# full SELinux userland repo
-RESTRICT="test"
-
-src_compile() {
- tc-export CC
- default
-}