summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-28 15:58:42 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-28 16:43:18 -0400
commit948dbb676ad148f1b0288d8a95de6f8c19dd486c (patch)
treeba40a1f34fd7c2682b8e2475781033fbbecc7465 /sys-apps/vbetool/vbetool-1.2.2.ebuild
parentsci-calculators/hcalc: fix build with clang16 (diff)
downloadgentoo-948dbb676ad148f1b0288d8a95de6f8c19dd486c.tar.gz
gentoo-948dbb676ad148f1b0288d8a95de6f8c19dd486c.tar.bz2
gentoo-948dbb676ad148f1b0288d8a95de6f8c19dd486c.zip
sys-apps/vbetool: add 1.2.2
This fork is ~13 years old but it fixes our clang16 issues and several distros are using it, let's take it (albeit unsure how useful this package still is, don't use myself). dev.g.o tarball is a checkout of upstream v1.2.2 tag with no changes. Closes: https://bugs.gentoo.org/787245 Closes: https://bugs.gentoo.org/870523 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'sys-apps/vbetool/vbetool-1.2.2.ebuild')
-rw-r--r--sys-apps/vbetool/vbetool-1.2.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/vbetool/vbetool-1.2.2.ebuild b/sys-apps/vbetool/vbetool-1.2.2.ebuild
new file mode 100644
index 000000000000..9ad425b7bd53
--- /dev/null
+++ b/sys-apps/vbetool/vbetool-1.2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Run real-mode video BIOS code to alter hw state (i.e. reinitialize video card)"
+HOMEPAGE="https://cgit.freedesktop.org/~airlied/vbetool/"
+SRC_URI="https://dev.gentoo.org/~ionen/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/libx86
+ sys-libs/zlib:=
+ x11-libs/libpciaccess"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-libx86.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}