summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-04-05 18:27:07 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-04-05 18:33:49 +0200
commit1330255e5a87db8af331f727e0fac3efbc265923 (patch)
tree3b54a8045acdd1df6d99eff8c83de782012ad2b9 /sys-apps/xdg-desktop-portal
parentnet-misc/smb4k: 3.1.2 version bump (diff)
downloadgentoo-1330255e5a87db8af331f727e0fac3efbc265923.tar.gz
gentoo-1330255e5a87db8af331f727e0fac3efbc265923.tar.bz2
gentoo-1330255e5a87db8af331f727e0fac3efbc265923.zip
sys-apps/xdg-desktop-portal: 1.14.2 version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-apps/xdg-desktop-portal')
-rw-r--r--sys-apps/xdg-desktop-portal/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.14.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal/Manifest b/sys-apps/xdg-desktop-portal/Manifest
index 908b32900129..d2c044635c6e 100644
--- a/sys-apps/xdg-desktop-portal/Manifest
+++ b/sys-apps/xdg-desktop-portal/Manifest
@@ -1 +1,2 @@
DIST xdg-desktop-portal-1.12.1.tar.xz 484352 BLAKE2B afa14ab78f35cb1c0e66514f313f5dc297ceef88af1ca7b3028305faa8398bdae1b9e897289b18a93b1cda1a8290c0e51bf73e66c9dce231f57a58652fb9e120 SHA512 62df427e2d8d54acd9a34a02a77c26ae3911fbb4c5844eff4a253dc839775c929c6945401b93549ba200ba637d315146767e41f18a831d7627b35de880de0da1
+DIST xdg-desktop-portal-1.14.2.tar.xz 504088 BLAKE2B e0a378c1f1d80afda7d73fd8e545f7304eeab349cf3298ebb616021c7e16e8a088360681e31eedca9ac90978eb04167a7e857ddaa5e023a2a8c24c9f959f9b2c SHA512 7164d6c0d89843d117e03bc46963d72f24dae2b9fc8e173f06a78bbc80655ccf192d86f951d3c404c88bf5da88d9d2053ea52cf3e541b833ee937b6931d803d7
diff --git a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.14.2.ebuild b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.14.2.ebuild
new file mode 100644
index 000000000000..32e526740664
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.14.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Desktop integration portal"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="geolocation screencast systemd"
+
+DEPEND="
+ >=dev-libs/glib-2.66:2
+ dev-libs/json-glib
+ >=sys-fs/fuse-3.10.0:3
+ x11-libs/gdk-pixbuf
+ geolocation? ( >=app-misc/geoclue-2.5.3:2.0 )
+ screencast? ( >=media-video/pipewire-0.3:= )
+"
+RDEPEND="${DEPEND}
+ sys-apps/dbus
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-docbook-docs # requires flatpak
+ --disable-libportal # not packaged
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ $(use_enable geolocation geoclue)
+ $(use_enable screencast pipewire)
+ $(use_with systemd)
+ )
+ econf "${myeconfargs[@]}"
+}