summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-07-22 00:15:36 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-07-22 15:09:41 +0200
commitc4bf5766d04a4a350ae99e62b03470a8af4f2849 (patch)
tree60a56c100c5de4dca5e448c3fadb5ee93c4e10ee /sys-apps
parentapp-text/pandoc-bin: bump to 3.1.6 (diff)
downloadgentoo-c4bf5766d04a4a350ae99e62b03470a8af4f2849.tar.gz
gentoo-c4bf5766d04a4a350ae99e62b03470a8af4f2849.tar.bz2
gentoo-c4bf5766d04a4a350ae99e62b03470a8af4f2849.zip
sys-apps/system-monitoring-center: bump to 2.18.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/system-monitoring-center/Manifest1
-rw-r--r--sys-apps/system-monitoring-center/system-monitoring-center-2.18.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/system-monitoring-center/Manifest b/sys-apps/system-monitoring-center/Manifest
index 9e75a540bc38..3bbec0607b06 100644
--- a/sys-apps/system-monitoring-center/Manifest
+++ b/sys-apps/system-monitoring-center/Manifest
@@ -2,3 +2,4 @@ DIST system-monitoring-center-2.14.0.tar.gz 550257 BLAKE2B 3ea3b392c08bcbdba960f
DIST system-monitoring-center-2.16.1.tar.gz 539174 BLAKE2B eca36d31a5f42632611e2dec78afe94d109522e6028331587760037cdf05e334369a7491ba703262c1fd1d45817da1041a5214e1ec779d55bdf0c19c4995bfd6 SHA512 e30e3abf00d6d3612b6406d6f4439bc0f0d384dddd4ddc2059193cb06f3968bfe64d93b46c38edff4fd290a9b39b3f6d3f595ee3f3c04b125db3e41525a01205
DIST system-monitoring-center-2.17.2.tar.gz 534153 BLAKE2B af347f35e4e29e0e8a075176fd971b60e1d474fd620ae01716de629008fac0d25a92c09271b47508173e39385927820f321e73abd6bceb46d76de88254fa257c SHA512 e98115d518e45fffc1c5a1d3391362484fd6ce517e57ba6de93dbcd1ec10c5109642fb0eaa47381eb6ba7bf107838c7f444e3829e699e38218266ab65c15870b
DIST system-monitoring-center-2.18.1.tar.gz 1393879 BLAKE2B 54051c8bc38f29a5b517b32b1754db80c6520e9ee5fd8ae77da4ec2e32ffc01ae787ba464c991d7f77b78c200b63dfc14b57f3f51578a8c8f44d0661b9ef2d5e SHA512 e5aa1480e0c94dbc4d431a6f4040d1e0247c713de0ccd14d8597ba1dd57795f79593d3482c09cb69d5317567693e3c4f2797806f1a7202e39a67c194190aa27a
+DIST system-monitoring-center-2.18.3.tar.gz 1496729 BLAKE2B f9ea49d9bc04b6f395b6a19c4f4a75ad047fcb53e4d766b2a93acac5a05d9bbde89d206d55155fe07a6f52bec04c604bcdaeb9ac37ad4d91da0a2c8e0ae5f98d SHA512 ebe47064647a8089400e1697813e673ce0f8bcf7dde3e79a76670edfd65eea7b59d067544e61dc61c10422e46403174ee6042191e93a09adbcc0076d576372de
diff --git a/sys-apps/system-monitoring-center/system-monitoring-center-2.18.3.ebuild b/sys-apps/system-monitoring-center/system-monitoring-center-2.18.3.ebuild
new file mode 100644
index 000000000000..76cc6a9cbef0
--- /dev/null
+++ b/sys-apps/system-monitoring-center/system-monitoring-center-2.18.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit meson python-single-r1 xdg
+
+DESCRIPTION="Multi-featured system monitor GUI written in Python"
+HOMEPAGE="https://github.com/hakandundar34coding/system-monitoring-center/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hakandundar34coding/${PN}.git"
+else
+ SRC_URI="https://github.com/hakandundar34coding/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gui-libs/gtk:4[introspection]
+ sys-apps/dmidecode
+ sys-apps/hwdata
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+
+src_install() {
+ meson_src_install
+ python_optimize "${ED}"/usr/share/${PN}
+
+ mv "${ED}"/usr/share/appdata "${ED}"/usr/share/metainfo || die
+}