summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-08-26 16:52:09 -0400
committerMatt Turner <mattst88@gentoo.org>2022-08-26 17:01:37 -0400
commitfb61a37976b4f008365527f37317d0748277ae09 (patch)
tree5ed84bf3a4df30241d6d49af9d000619bea59795 /sys-apps
parentnet-libs/libssh: add 0.10.0 (diff)
downloadgentoo-fb61a37976b4f008365527f37317d0748277ae09.tar.gz
gentoo-fb61a37976b4f008365527f37317d0748277ae09.tar.bz2
gentoo-fb61a37976b4f008365527f37317d0748277ae09.zip
sys-apps/bolt: Version bump to 0.9.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/bolt/Manifest1
-rw-r--r--sys-apps/bolt/bolt-0.9.3.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/sys-apps/bolt/Manifest b/sys-apps/bolt/Manifest
index 96e5b97f9ed7..cedcf9f4e235 100644
--- a/sys-apps/bolt/Manifest
+++ b/sys-apps/bolt/Manifest
@@ -1,2 +1,3 @@
DIST bolt-0.9.1.tar.gz 250978 BLAKE2B a3b1ea51704e2b54abb0135013019b9cad6ed9c0acfdb56797e19c9b5a1abe9f921446cfcc5b664f73bbbff857cf8d420f588517d4c633d1b3776a35c37fc882 SHA512 c925c290de75d3fa2dfb9e86b2f14ea39279b3f2ab6bebeced72a7853c901d44de02157d684534af2b54edd3a2e0b2ba61e889579ab1b192f99e98a2d73685d9
DIST bolt-0.9.2.tar.gz 252532 BLAKE2B 45ea8ae2e77a90099152e708dafe68e63492d0370b734612b516d4a772507174c3df75ddd7d6bdea4be5022a88e1e286a738d3b8df6a662ef3b0b92ac7328730 SHA512 69e7ffa58a6dbc8a1b14fd7e11e2291fa60227896ead1a449839716b581c6ab0e351d3ed62f9b51c5e44a5a33ba5e23dc5af73a1b4eef87f733b3231d5454e90
+DIST bolt-0.9.3.tar.gz 253085 BLAKE2B 7547a35aa16a7681737989c72dfd2e13245eb50c7b814de979974750e3c8805156fd22054308d715299baab3ebd4144923aacc04ef301ee039e84b6370cbcba7 SHA512 2160831011090e75cf54408525f53ead6c0e7797de8a4afdd07ef5a035f8e1aa58f34efb9bd52e6e7cd93ac17751e72ff27e99f2b372a5720b2cbadd6abb3c26
diff --git a/sys-apps/bolt/bolt-0.9.3.ebuild b/sys-apps/bolt/bolt-0.9.3.ebuild
new file mode 100644
index 000000000000..b6e173c5433b
--- /dev/null
+++ b/sys-apps/bolt/bolt-0.9.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info meson udev
+
+DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3"
+HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.56.0:2
+ virtual/libudev:=
+ virtual/udev
+ sys-auth/polkit[introspection]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/umockdev )
+"
+BDEPEND="
+ app-text/asciidoc
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ if use kernel_linux && kernel_is lt 5 6; then
+ CONFIG_CHECK="~THUNDERBOLT"
+ ERROR_THUNDERBOLT="This package requires the thunderbolt kernel driver."
+ else
+ CONFIG_CHECK="~USB4"
+ ERROR_USB4="This package requires the USB4 kernel driver for Thunderbolt support."
+ fi
+ CONFIG_CHECK+=" ~HOTPLUG_PCI"
+ ERROR_HOTPLUG_PCI="Thunderbolt requires PCI hotplug support."
+
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dman=true
+ --sysconfdir="${EPREFIX}"/etc
+ --localstatedir="${EPREFIX}"/var
+ --sharedstatedir="${EPREFIX}"/var/lib
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}"/${PN}.openrc-r1 boltd
+ keepdir /var/lib/boltd
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}