summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-10-15 07:37:36 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-10-15 07:37:36 +0300
commit1228ce0c5b683ffde567bbf535a96ac96d546af4 (patch)
treed3243c4a38e5ab73c674fc60f1ab41f738a733fc /sys-boot
parentmail-filter/opendkim: drop 2.10.3-r30 (diff)
downloadgentoo-1228ce0c5b683ffde567bbf535a96ac96d546af4.tar.gz
gentoo-1228ce0c5b683ffde567bbf535a96ac96d546af4.tar.bz2
gentoo-1228ce0c5b683ffde567bbf535a96ac96d546af4.zip
sys-boot/gnu-efi: fix building on llvm profile
The llvm profile does not have sys-devel/binutils. Remove the check from pkg_pretend, before it being installed. Bug: https://bugs.gentoo.org/940728 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/gnu-efi/gnu-efi-3.0.18-r5.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-boot/gnu-efi/gnu-efi-3.0.18-r5.ebuild b/sys-boot/gnu-efi/gnu-efi-3.0.18-r5.ebuild
index d3d5d12d57b7..d42c0ae837f4 100644
--- a/sys-boot/gnu-efi/gnu-efi-3.0.18-r5.ebuild
+++ b/sys-boot/gnu-efi/gnu-efi-3.0.18-r5.ebuild
@@ -61,18 +61,18 @@ check_and_set_objcopy() {
fi
}
-check_comppiler() {
+check_compiler() {
if [[ ${MERGE_TYPE} != "binary" ]]; then
tc-is-gcc || tc-is-clang || die "Unsupported compiler"
fi
}
pkg_pretend() {
- check_comppiler
- check_and_set_objcopy
+ check_compiler
}
pkg_setup() {
+ check_compiler
check_and_set_objcopy
}