summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2021-12-19 16:37:34 +0100
committerSam James <sam@gentoo.org>2021-12-21 01:54:24 +0000
commit5dfd04eec175ce8a022c6adb8c287b89b81f0abe (patch)
treeed3bef919d24a19b05e0c237e931e357cd3d3bdc /sys-cluster/charliecloud
parentdev-libs/boxfort: drop old (diff)
downloadgentoo-5dfd04eec175ce8a022c6adb8c287b89b81f0abe.tar.gz
gentoo-5dfd04eec175ce8a022c6adb8c287b89b81f0abe.tar.bz2
gentoo-5dfd04eec175ce8a022c6adb8c287b89b81f0abe.zip
sys-cluster/charliecloud: Add argp compat on musl systems.
Patch also submitted to upstream: https://github.com/hpc/charliecloud/pull/1258 Closes: https://bugs.gentoo.org/829607 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Closes: https://github.com/gentoo/gentoo/pull/23420 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster/charliecloud')
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.24.ebuild5
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.25.ebuild8
-rw-r--r--sys-cluster/charliecloud/charliecloud-9999.ebuild4
-rw-r--r--sys-cluster/charliecloud/files/charliecloud-0.24-musl-argp.patch43
4 files changed, 57 insertions, 3 deletions
diff --git a/sys-cluster/charliecloud/charliecloud-0.24.ebuild b/sys-cluster/charliecloud/charliecloud-0.24.ebuild
index ad6833306501..951128bbb6df 100644
--- a/sys-cluster/charliecloud/charliecloud-0.24.ebuild
+++ b/sys-cluster/charliecloud/charliecloud-0.24.ebuild
@@ -30,7 +30,9 @@ RESTRICT="test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}"
+RDEPEND="${PYTHON_DEPS}
+ elibc_musl? ( sys-libs/argp-standalone )
+"
DEPEND="
ch-image? (
$(python_gen_cond_dep '
@@ -48,6 +50,7 @@ DEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-0.24-dash.patch
+ "${FILESDIR}"/${PN}-0.24-musl-argp.patch
)
src_prepare() {
diff --git a/sys-cluster/charliecloud/charliecloud-0.25.ebuild b/sys-cluster/charliecloud/charliecloud-0.25.ebuild
index 1d092db33c89..f54e49ec426d 100644
--- a/sys-cluster/charliecloud/charliecloud-0.25.ebuild
+++ b/sys-cluster/charliecloud/charliecloud-0.25.ebuild
@@ -30,7 +30,9 @@ RESTRICT="test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}"
+RDEPEND="${PYTHON_DEPS}
+ elibc_musl? ( sys-libs/argp-standalone )
+"
DEPEND="
ch-image? (
$(python_gen_cond_dep '
@@ -46,6 +48,10 @@ DEPEND="
net-misc/rsync
)"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.24-musl-argp.patch
+)
+
src_prepare() {
default
eautoreconf
diff --git a/sys-cluster/charliecloud/charliecloud-9999.ebuild b/sys-cluster/charliecloud/charliecloud-9999.ebuild
index 1d092db33c89..8a596e2fb8a1 100644
--- a/sys-cluster/charliecloud/charliecloud-9999.ebuild
+++ b/sys-cluster/charliecloud/charliecloud-9999.ebuild
@@ -30,7 +30,9 @@ RESTRICT="test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}"
+RDEPEND="${PYTHON_DEPS}
+ elibc_musl? ( sys-libs/argp-standalone )
+"
DEPEND="
ch-image? (
$(python_gen_cond_dep '
diff --git a/sys-cluster/charliecloud/files/charliecloud-0.24-musl-argp.patch b/sys-cluster/charliecloud/files/charliecloud-0.24-musl-argp.patch
new file mode 100644
index 000000000000..71817111cdcd
--- /dev/null
+++ b/sys-cluster/charliecloud/files/charliecloud-0.24-musl-argp.patch
@@ -0,0 +1,43 @@
+From 1832d5ff905b16435efa64e458e2ca2f656f0ab5 Mon Sep 17 00:00:00 2001
+From: Oliver Freyermuth <o.freyermuth@googlemail.com>
+Date: Sun, 19 Dec 2021 16:30:27 +0100
+Subject: [PATCH] configure: Add musl compatibility (external argp).
+
+---
+ configure.ac | 20 ++++++++++++++++++++
+ 1 file changed, 20 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 687d4d4..9f708cf 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -109,6 +109,26 @@ AC_CHECK_LIB([rt], [shm_open], [LIBRT=-lrt], [
+ ])
+ AC_SUBST([LIBRT])
+
++# argp_parse, needed externally from libargp / argp_standalone e.g. with musl.
++# First, check if available in used libc out of the box.
++AC_LINK_IFELSE(
++ [AC_LANG_PROGRAM(
++ [#include <argp.h>],
++ [int argc=1; char **argv=NULL; argp_parse(0,argc,argv,0,0,0); return 0;]
++ )],
++ [libc_provides_argp="true"],
++ [libc_provides_argp="false"]
++)
++# If libc doesn't provide argp, test for libargp
++if test "$libc_provides_argp" = "false" ; then
++ AC_MSG_WARN("libc does not provide argp")
++ AC_CHECK_LIB([argp], [argp_parse], [have_largp="true"], [have_largp="false"])
++ if test "$have_largp" = "false"; then
++ AC_MSG_ERROR([*** argp functions not found - install libargp or argp_standalone])
++ else
++ CH_RUN_LIBS="-largp $CH_RUN_LIBS"
++ fi
++fi
+
+ ## Options
+
+--
+2.32.0
+