summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-cluster/knem
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-cluster/knem')
-rw-r--r--sys-cluster/knem/Manifest1
-rw-r--r--sys-cluster/knem/files/45-knem.rules1
-rw-r--r--sys-cluster/knem/knem-1.1.1.ebuild76
-rw-r--r--sys-cluster/knem/knem-9999.ebuild76
-rw-r--r--sys-cluster/knem/metadata.xml9
5 files changed, 163 insertions, 0 deletions
diff --git a/sys-cluster/knem/Manifest b/sys-cluster/knem/Manifest
new file mode 100644
index 000000000000..fdb9c2a8040c
--- /dev/null
+++ b/sys-cluster/knem/Manifest
@@ -0,0 +1 @@
+DIST knem-1.1.1.tar.gz 321401 SHA256 4bfbb4c237022cfebbe6b80c9d181252ee3a09cd42bc9dd1e90a81575fbbbef6 SHA512 6b53748df8ffcfa400870657d5c121f51e132d2b724bca832b00d7c16c546299d1dd29739fe1d4b00cc33010558ae584e7c0078de2c56d8ea92ce7880b4bfedc WHIRLPOOL 74908664d734d880082e35ec5707887dd17745b0edc161926906fcab9767bdc59d98bd710463188a6d73da781265d8ab83a8dd15beae57058455e734480a46d5
diff --git a/sys-cluster/knem/files/45-knem.rules b/sys-cluster/knem/files/45-knem.rules
new file mode 100644
index 000000000000..1b87b1eb7a64
--- /dev/null
+++ b/sys-cluster/knem/files/45-knem.rules
@@ -0,0 +1 @@
+KERNEL=="knem", MODE="0666"
diff --git a/sys-cluster/knem/knem-1.1.1.ebuild b/sys-cluster/knem/knem-1.1.1.ebuild
new file mode 100644
index 000000000000..846b974924eb
--- /dev/null
+++ b/sys-cluster/knem/knem-1.1.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools linux-mod linux-info toolchain-funcs udev multilib
+
+DESCRIPTION="High-Performance Intra-Node MPI Communication"
+HOMEPAGE="http://runtime.bordeaux.inria.fr/knem/"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://gforge.inria.fr/git/knem/knem.git"
+ inherit git-2
+ KEYWORDS=""
+else
+ SRC_URI="http://runtime.bordeaux.inria.fr/knem/download/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+IUSE="debug modules"
+
+DEPEND="
+ sys-apps/hwloc
+ virtual/linux-sources"
+RDEPEND="
+ sys-apps/hwloc
+ virtual/modutils"
+
+MODULE_NAMES="knem(misc:${S}/driver/linux)"
+BUILD_TARGETS="all"
+BUILD_PARAMS="KDIR=${KERNEL_DIR}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ linux-mod_pkg_setup
+ ARCH="$(tc-arch-kernel)"
+ ABI="${KERNEL_ABI}"
+}
+
+src_prepare() {
+ sed 's:driver/linux::g' -i Makefile.am
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-hwloc \
+ --with-linux="${KERNEL_DIR}" \
+ --with-linux-release=${KV_FULL} \
+ $(use_enable debug)
+}
+
+src_compile() {
+ default
+ if use modules; then
+ cd "${S}/driver/linux"
+ linux-mod_src_compile || die "failed to build driver"
+ fi
+}
+
+src_install() {
+ default
+ if use modules; then
+ cd "${S}/driver/linux"
+ linux-mod_src_install || die "failed to install driver"
+ fi
+
+ # Drop funny unneded stuff
+ rm "${ED}/usr/sbin/knem_local_install" || die
+ rmdir "${ED}/usr/sbin" || die
+ # install udev rules
+ udev_dorules "${FILESDIR}/45-knem.rules"
+ rm "${ED}/etc/10-knem.rules" || die
+}
diff --git a/sys-cluster/knem/knem-9999.ebuild b/sys-cluster/knem/knem-9999.ebuild
new file mode 100644
index 000000000000..846b974924eb
--- /dev/null
+++ b/sys-cluster/knem/knem-9999.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools linux-mod linux-info toolchain-funcs udev multilib
+
+DESCRIPTION="High-Performance Intra-Node MPI Communication"
+HOMEPAGE="http://runtime.bordeaux.inria.fr/knem/"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://gforge.inria.fr/git/knem/knem.git"
+ inherit git-2
+ KEYWORDS=""
+else
+ SRC_URI="http://runtime.bordeaux.inria.fr/knem/download/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+IUSE="debug modules"
+
+DEPEND="
+ sys-apps/hwloc
+ virtual/linux-sources"
+RDEPEND="
+ sys-apps/hwloc
+ virtual/modutils"
+
+MODULE_NAMES="knem(misc:${S}/driver/linux)"
+BUILD_TARGETS="all"
+BUILD_PARAMS="KDIR=${KERNEL_DIR}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ linux-mod_pkg_setup
+ ARCH="$(tc-arch-kernel)"
+ ABI="${KERNEL_ABI}"
+}
+
+src_prepare() {
+ sed 's:driver/linux::g' -i Makefile.am
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-hwloc \
+ --with-linux="${KERNEL_DIR}" \
+ --with-linux-release=${KV_FULL} \
+ $(use_enable debug)
+}
+
+src_compile() {
+ default
+ if use modules; then
+ cd "${S}/driver/linux"
+ linux-mod_src_compile || die "failed to build driver"
+ fi
+}
+
+src_install() {
+ default
+ if use modules; then
+ cd "${S}/driver/linux"
+ linux-mod_src_install || die "failed to install driver"
+ fi
+
+ # Drop funny unneded stuff
+ rm "${ED}/usr/sbin/knem_local_install" || die
+ rmdir "${ED}/usr/sbin" || die
+ # install udev rules
+ udev_dorules "${FILESDIR}/45-knem.rules"
+ rm "${ED}/etc/10-knem.rules" || die
+}
diff --git a/sys-cluster/knem/metadata.xml b/sys-cluster/knem/metadata.xml
new file mode 100644
index 000000000000..a64f2d240d92
--- /dev/null
+++ b/sys-cluster/knem/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cluster</herd>
+ <maintainer>
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+</pkgmetadata>