summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-03-06 17:05:29 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-03-06 17:05:45 +0100
commita0bff5f8f325911ec904ac8eab65e4976d2aeda2 (patch)
treef8f8343a4b626d67abc8f090f7df7cc049f8b3ec /sys-cluster
parentdev-util/checkbashisms: bump to v2.21.1 (diff)
downloadgentoo-a0bff5f8f325911ec904ac8eab65e4976d2aeda2.tar.gz
gentoo-a0bff5f8f325911ec904ac8eab65e4976d2aeda2.tar.bz2
gentoo-a0bff5f8f325911ec904ac8eab65e4976d2aeda2.zip
sys-cluster/mpich2: Fix build with gcc-10
Closes: https://bugs.gentoo.org/716664 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpich2/files/mpich2-1.5-fno-common.patch21
-rw-r--r--sys-cluster/mpich2/mpich2-1.5.ebuild4
2 files changed, 24 insertions, 1 deletions
diff --git a/sys-cluster/mpich2/files/mpich2-1.5-fno-common.patch b/sys-cluster/mpich2/files/mpich2-1.5-fno-common.patch
new file mode 100644
index 000000000000..ce0c1911b16d
--- /dev/null
+++ b/sys-cluster/mpich2/files/mpich2-1.5-fno-common.patch
@@ -0,0 +1,21 @@
+--- a/src/pm/hydra/pm/pmiserv/pmip_cb.c
++++ b/src/pm/hydra/pm/pmiserv/pmip_cb.c
+@@ -12,7 +12,6 @@
+ #include "topo.h"
+ #include "hydt_ftb.h"
+
+-struct HYD_pmcd_pmip HYD_pmcd_pmip;
+ struct HYD_pmcd_pmip_pmi_handle *HYD_pmcd_pmip_pmi_handle = { 0 };
+
+ static int storage_len = 0;
+--- a/src/pm/hydra/pm/pmiserv/pmip.c
++++ b/src/pm/hydra/pm/pmiserv/pmip.c
+@@ -11,8 +11,6 @@
+ #include "topo.h"
+ #include "hydt_ftb.h"
+
+-struct HYD_pmcd_pmip HYD_pmcd_pmip;
+-
+ static HYD_status init_params(void)
+ {
+ HYD_status status = HYD_SUCCESS;
diff --git a/sys-cluster/mpich2/mpich2-1.5.ebuild b/sys-cluster/mpich2/mpich2-1.5.ebuild
index 1fc1095762f0..159474a613c1 100644
--- a/sys-cluster/mpich2/mpich2-1.5.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -43,6 +43,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}/${P}-fno-common.patch"
+
# Using MPICH2LIB_LDFLAGS doesn't seem to full work.
sed -i 's| *@WRAPPER_LDFLAGS@ *||' \
src/packaging/pkgconfig/mpich2.pc.in \