summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-09-23 21:48:40 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-09-23 23:35:58 +0100
commitfd1aa67de92c05d6a066e84ba5cd4236e637629e (patch)
tree19f44ae3b44786d86d0b71ee224b7c225e576e68 /sys-devel/gcc/gcc-7.3.0-r5.ebuild
parentsys-devel/gcc: cut 1.3 patchset for 8.2.0 (diff)
downloadgentoo-fd1aa67de92c05d6a066e84ba5cd4236e637629e.tar.gz
gentoo-fd1aa67de92c05d6a066e84ba5cd4236e637629e.tar.bz2
gentoo-fd1aa67de92c05d6a066e84ba5cd4236e637629e.zip
sys-devel/gcc: cut 1.7 patchset for 7.3.0
Three new patches: + 98_all_msp430-partial-int.patch: fix msp430 code generator on complex types + 99_all_x32-fix-eh-return-address.patch fix exception handler ABI on x32 + 100_all_respect-build-cxxflags.patch fix cross-build for arch-specific CXXFLAGS Bug: https://bugs.gentoo.org/664014 Bug: https://bugs.gentoo.org/664016 Bug: https://bugs.gentoo.org/581406 Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'sys-devel/gcc/gcc-7.3.0-r5.ebuild')
-rw-r--r--sys-devel/gcc/gcc-7.3.0-r5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-7.3.0-r5.ebuild b/sys-devel/gcc/gcc-7.3.0-r5.ebuild
new file mode 100644
index 000000000000..cb789c58b5cb
--- /dev/null
+++ b/sys-devel/gcc/gcc-7.3.0-r5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PATCH_VER="1.7"
+#UCLIBC_VER="1.0"
+
+inherit toolchain
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.13 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
+fi
+
+src_prepare() {
+ toolchain_src_prepare
+}