summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-05-06 13:48:11 +0200
committerJeroen Roovers <jer@gentoo.org>2017-05-06 13:48:11 +0200
commitbc25f24123a84a012c809679280a4459afe6dced (patch)
tree0882de10001292c8ff3f70f79a541dbea36985ea /sys-devel/kgcc64/kgcc64-4.6.3.ebuild
parentsys-devel/kgcc64: Stable for HPPA too. (diff)
downloadgentoo-bc25f24123a84a012c809679280a4459afe6dced.tar.gz
gentoo-bc25f24123a84a012c809679280a4459afe6dced.tar.bz2
gentoo-bc25f24123a84a012c809679280a4459afe6dced.zip
sys-devel/kgcc64: Old.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sys-devel/kgcc64/kgcc64-4.6.3.ebuild')
-rw-r--r--sys-devel/kgcc64/kgcc64-4.6.3.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/sys-devel/kgcc64/kgcc64-4.6.3.ebuild b/sys-devel/kgcc64/kgcc64-4.6.3.ebuild
deleted file mode 100644
index 579f3ff36876..000000000000
--- a/sys-devel/kgcc64/kgcc64-4.6.3.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-case ${CHOST} in
- hppa*) CTARGET=hppa64-${CHOST#*-};;
- mips*) CTARGET=${CHOST/mips/mips64};;
- powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
- s390*) CTARGET=${CHOST/s390/s390x};;
- sparc*) CTARGET=${CHOST/sparc/sparc64};;
- i?86*) CTARGET=x86_64-${CHOST#*-};;
-esac
-export CTARGET
-TOOLCHAIN_ALLOWED_LANGS="c"
-GCC_TARGET_NO_MULTILIB=true
-
-PATCH_VER="1.9"
-GCC_FILESDIR=${FILESDIR/${PN}/gcc}
-
-inherit eutils toolchain
-
-DESCRIPTION="64bit kernel compiler"
-
-# Works on mips and sparc; all other archs, refer to bug #228115
-KEYWORDS="hppa ~sparc"
-
-RDEPEND=">=dev-libs/gmp-4.3.2
- >=dev-libs/mpfr-2.4.2
- >=dev-libs/mpc-0.8.1
- >=sys-devel/gcc-config-1.4"
-# unlike every other target, hppa has not unified the 32/64 bit
-# ports in binutils yet
-DEPEND="${RDEPEND}
- hppa? ( sys-devel/binutils-hppa64 )
- !sys-devel/gcc-hppa64
- !sys-devel/gcc-mips64
- !sys-devel/gcc-powerpc64
- !sys-devel/gcc-sparc64
- >=sys-apps/texinfo-4.8
- >=sys-devel/bison-1.875"
-
-pkg_postinst() {
- toolchain_pkg_postinst
-
- cd "${ROOT}"/usr/bin
- local x
- for x in gcc cpp ; do
- cat <<-EOF >${CTARGET%%-*}-linux-${x}
- #!/bin/sh
- exec ${CTARGET}-${x} "\$@"
- EOF
- chmod a+rx ${CTARGET%%-*}-linux-${x}
- done
-}