summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-27 10:34:59 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-27 14:26:52 +0200
commit9f6c9012965dd7fcdbb89aeb873c1eb3f50d4f32 (patch)
tree48b0b8679ec095267be7098b030e5c48d34bafbd /sys-devel/llvm-common
parentllvm.org.eclass: Update cmake calls for EAPI 8 (diff)
downloadgentoo-9f6c9012965dd7fcdbb89aeb873c1eb3f50d4f32.tar.gz
gentoo-9f6c9012965dd7fcdbb89aeb873c1eb3f50d4f32.tar.bz2
gentoo-9f6c9012965dd7fcdbb89aeb873c1eb3f50d4f32.zip
sys-devel/llvm-common: Modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm-common')
-rw-r--r--sys-devel/llvm-common/llvm-common-15.0.0.9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-devel/llvm-common/llvm-common-15.0.0.9999.ebuild b/sys-devel/llvm-common/llvm-common-15.0.0.9999.ebuild
index fdadac15eda6..df37476f6fbc 100644
--- a/sys-devel/llvm-common/llvm-common-15.0.0.9999.ebuild
+++ b/sys-devel/llvm-common/llvm-common-15.0.0.9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit llvm.org
@@ -11,9 +11,10 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
KEYWORDS=""
-IUSE=""
-RDEPEND="!sys-devel/llvm:0"
+RDEPEND="
+ !sys-devel/llvm:0
+"
LLVM_COMPONENTS=( llvm/utils/vim )
llvm.org_set_globals