summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-02-12 16:14:13 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-02-12 16:14:13 +0100
commitff5c04761b1534110b752bddfe904114cd42f430 (patch)
treeb627475a997995a146726c8be104f6815ebacbb7 /sys-devel/patch/patch-2.7.6-r1.ebuild
parentapp-office/libreoffice-bin-debug: Version bump (diff)
downloadgentoo-ff5c04761b1534110b752bddfe904114cd42f430.tar.gz
gentoo-ff5c04761b1534110b752bddfe904114cd42f430.tar.bz2
gentoo-ff5c04761b1534110b752bddfe904114cd42f430.zip
sys-devel/patch: Rev bump to fix test suite
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-devel/patch/patch-2.7.6-r1.ebuild')
-rw-r--r--sys-devel/patch/patch-2.7.6-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-devel/patch/patch-2.7.6-r1.ebuild b/sys-devel/patch/patch-2.7.6-r1.ebuild
new file mode 100644
index 000000000000..388826a546a1
--- /dev/null
+++ b/sys-devel/patch/patch-2.7.6-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Utility to apply diffs to files"
+HOMEPAGE="https://www.gnu.org/software/patch/patch.html"
+SRC_URI="mirror://gnu/patch/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static test xattr"
+
+RDEPEND="xattr? ( sys-apps/attr )"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/ed )"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-test-suite.patch )
+
+src_configure() {
+ use static && append-ldflags -static
+
+ local myeconfargs=(
+ $(use_enable xattr)
+ --program-prefix="$(use userland_BSD && echo g)"
+ )
+ # Do not let $ED mess up the search for `ed` 470210.
+ ac_cv_path_ED=$(type -P ed) \
+ econf "${myeconfargs[@]}"
+}