summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 12:10:38 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 12:53:12 +0100
commit1aea2894cdc65d5a2aa39c675e39578dd6eceb06 (patch)
tree4f4d7cb3982d8d795cadc78a1216f80a8c414615 /sys-devel
parentMove sys-libs/llvm-libunwind → llvm-runtimes/libunwind (diff)
downloadgentoo-1aea2894cdc65d5a2aa39c675e39578dd6eceb06.tar.gz
gentoo-1aea2894cdc65d5a2aa39c675e39578dd6eceb06.tar.bz2
gentoo-1aea2894cdc65d5a2aa39c675e39578dd6eceb06.zip
Move sys-libs/libomp → llvm-runtimes/openmp
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild4
-rw-r--r--sys-devel/clang-runtime/clang-runtime-16.0.6.ebuild2
-rw-r--r--sys-devel/clang-runtime/clang-runtime-17.0.6.ebuild2
-rw-r--r--sys-devel/clang-runtime/clang-runtime-18.1.8.ebuild2
-rw-r--r--sys-devel/clang-runtime/clang-runtime-19.1.4.ebuild2
-rw-r--r--sys-devel/clang-runtime/clang-runtime-19.1.5.ebuild2
-rw-r--r--sys-devel/clang-runtime/clang-runtime-20.0.0.9999.ebuild2
-rw-r--r--sys-devel/clang-runtime/clang-runtime-20.0.0_pre20241207.ebuild2
-rw-r--r--sys-devel/clang-runtime/metadata.xml2
9 files changed, 10 insertions, 10 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild b/sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild
index c4f7620e1212..c80214039ada 100644
--- a/sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -22,5 +22,5 @@ RDEPEND="
)
)
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
- openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
"
diff --git a/sys-devel/clang-runtime/clang-runtime-16.0.6.ebuild b/sys-devel/clang-runtime/clang-runtime-16.0.6.ebuild
index 25889f60d661..c175cf8f6d82 100644
--- a/sys-devel/clang-runtime/clang-runtime-16.0.6.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-16.0.6.ebuild
@@ -22,7 +22,7 @@ RDEPEND="
)
)
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
- openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
"
pkg_pretend() {
diff --git a/sys-devel/clang-runtime/clang-runtime-17.0.6.ebuild b/sys-devel/clang-runtime/clang-runtime-17.0.6.ebuild
index 25889f60d661..c175cf8f6d82 100644
--- a/sys-devel/clang-runtime/clang-runtime-17.0.6.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-17.0.6.ebuild
@@ -22,7 +22,7 @@ RDEPEND="
)
)
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
- openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
"
pkg_pretend() {
diff --git a/sys-devel/clang-runtime/clang-runtime-18.1.8.ebuild b/sys-devel/clang-runtime/clang-runtime-18.1.8.ebuild
index e95d8a0af7dc..b8e570778a41 100644
--- a/sys-devel/clang-runtime/clang-runtime-18.1.8.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-18.1.8.ebuild
@@ -22,7 +22,7 @@ RDEPEND="
)
)
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
- openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
"
pkg_pretend() {
diff --git a/sys-devel/clang-runtime/clang-runtime-19.1.4.ebuild b/sys-devel/clang-runtime/clang-runtime-19.1.4.ebuild
index e95d8a0af7dc..b8e570778a41 100644
--- a/sys-devel/clang-runtime/clang-runtime-19.1.4.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-19.1.4.ebuild
@@ -22,7 +22,7 @@ RDEPEND="
)
)
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
- openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
"
pkg_pretend() {
diff --git a/sys-devel/clang-runtime/clang-runtime-19.1.5.ebuild b/sys-devel/clang-runtime/clang-runtime-19.1.5.ebuild
index 8ded193c919c..23682d8dbe5d 100644
--- a/sys-devel/clang-runtime/clang-runtime-19.1.5.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-19.1.5.ebuild
@@ -22,7 +22,7 @@ RDEPEND="
)
)
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
- openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
"
pkg_pretend() {
diff --git a/sys-devel/clang-runtime/clang-runtime-20.0.0.9999.ebuild b/sys-devel/clang-runtime/clang-runtime-20.0.0.9999.ebuild
index 88cc488d44f5..5096eef10239 100644
--- a/sys-devel/clang-runtime/clang-runtime-20.0.0.9999.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-20.0.0.9999.ebuild
@@ -22,7 +22,7 @@ RDEPEND="
)
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? (
- >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}]
+ >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}]
offload? (
>=llvm-runtimes/offload-${PV}
)
diff --git a/sys-devel/clang-runtime/clang-runtime-20.0.0_pre20241207.ebuild b/sys-devel/clang-runtime/clang-runtime-20.0.0_pre20241207.ebuild
index 88cc488d44f5..5096eef10239 100644
--- a/sys-devel/clang-runtime/clang-runtime-20.0.0_pre20241207.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-20.0.0_pre20241207.ebuild
@@ -22,7 +22,7 @@ RDEPEND="
)
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? (
- >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}]
+ >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}]
offload? (
>=llvm-runtimes/offload-${PV}
)
diff --git a/sys-devel/clang-runtime/metadata.xml b/sys-devel/clang-runtime/metadata.xml
index 91a68054aec8..1339c7657454 100644
--- a/sys-devel/clang-runtime/metadata.xml
+++ b/sys-devel/clang-runtime/metadata.xml
@@ -8,7 +8,7 @@
<flag name="compiler-rt">Install <pkg>sys-libs/compiler-rt</pkg> for -rtlib=compiler-rt</flag>
<flag name="libcxx">Install <pkg>sys-libs/libcxx</pkg> for -stdlib=libc++</flag>
<flag name="offload">Install <pkg>llvm-runtimes/offload</pkg> for -fopenmp GPU offloading</flag>
- <flag name="openmp">Install <pkg>sys-libs/libomp</pkg> for -fopenmp support</flag>
+ <flag name="openmp">Install <pkg>llvm-runtimes/openmp</pkg> for -fopenmp support</flag>
<flag name="sanitize">Enable compiler-rt sanitizer (-fsanitize*) support</flag>
</use>
<upstream>