summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 12:20:33 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 12:53:16 +0100
commit6aa98b9305c952a63d1a5f2d39f748ac9e3c5505 (patch)
tree33484157c68073f9ed2c9011f18c458788287bce /sys-devel
parentMove {sys-libs → llvm-runtimes}/compiler-rt (diff)
downloadgentoo-6aa98b9305c952a63d1a5f2d39f748ac9e3c5505.tar.gz
gentoo-6aa98b9305c952a63d1a5f2d39f748ac9e3c5505.tar.bz2
gentoo-6aa98b9305c952a63d1a5f2d39f748ac9e3c5505.zip
Move {sys-devel → llvm-core}/clang-runtime
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/clang-common-15.0.7-r10.ebuild4
-rw-r--r--sys-devel/clang-common/clang-common-16.0.6-r6.ebuild4
-rw-r--r--sys-devel/clang-common/clang-common-17.0.6-r10.ebuild4
-rw-r--r--sys-devel/clang-common/clang-common-17.0.6-r9.ebuild4
-rw-r--r--sys-devel/clang-common/clang-common-18.1.8-r3.ebuild4
-rw-r--r--sys-devel/clang-common/clang-common-19.1.4.ebuild4
-rw-r--r--sys-devel/clang-common/clang-common-19.1.5.ebuild4
-rw-r--r--sys-devel/clang-common/clang-common-20.0.0.9999.ebuild4
-rw-r--r--sys-devel/clang-common/clang-common-20.0.0_pre20241207.ebuild4
-rw-r--r--sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild26
-rw-r--r--sys-devel/clang-runtime/clang-runtime-16.0.6.ebuild40
-rw-r--r--sys-devel/clang-runtime/clang-runtime-17.0.6.ebuild40
-rw-r--r--sys-devel/clang-runtime/clang-runtime-18.1.8.ebuild40
-rw-r--r--sys-devel/clang-runtime/clang-runtime-19.1.4.ebuild40
-rw-r--r--sys-devel/clang-runtime/clang-runtime-19.1.5.ebuild40
-rw-r--r--sys-devel/clang-runtime/clang-runtime-20.0.0.9999.ebuild44
-rw-r--r--sys-devel/clang-runtime/clang-runtime-20.0.0_pre20241207.ebuild44
-rw-r--r--sys-devel/clang-runtime/metadata.xml17
-rw-r--r--sys-devel/clang/clang-15.0.7-r3.ebuild2
-rw-r--r--sys-devel/clang/clang-16.0.6.ebuild2
-rw-r--r--sys-devel/clang/clang-17.0.6.ebuild2
-rw-r--r--sys-devel/clang/clang-18.1.8-r6.ebuild2
-rw-r--r--sys-devel/clang/clang-19.1.4.ebuild2
-rw-r--r--sys-devel/clang/clang-19.1.5.ebuild2
-rw-r--r--sys-devel/clang/clang-20.0.0.9999.ebuild2
-rw-r--r--sys-devel/clang/clang-20.0.0_pre20241207.ebuild2
26 files changed, 26 insertions, 357 deletions
diff --git a/sys-devel/clang-common/clang-common-15.0.7-r10.ebuild b/sys-devel/clang-common/clang-common-15.0.7-r10.ebuild
index 928aee10456d..3f7409022c42 100644
--- a/sys-devel/clang-common/clang-common-15.0.7-r10.ebuild
+++ b/sys-devel/clang-common/clang-common-15.0.7-r10.ebuild
@@ -18,7 +18,7 @@ IUSE="
PDEPEND="
default-compiler-rt? (
- sys-devel/clang-runtime:${PV}[compiler-rt]
+ llvm-core/clang-runtime:${PV}[compiler-rt]
llvm-libunwind? ( llvm-runtimes/libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
@@ -67,7 +67,7 @@ src_install() {
insinto /etc/clang
newins - gentoo-runtimes.cfg <<-EOF
- # This file is initially generated by sys-devel/clang-runtime.
+ # This file is initially generated by llvm-core/clang-runtime.
# It is used to control the default runtimes using by clang.
--rtlib=$(usex default-compiler-rt compiler-rt libgcc)
diff --git a/sys-devel/clang-common/clang-common-16.0.6-r6.ebuild b/sys-devel/clang-common/clang-common-16.0.6-r6.ebuild
index e09335f6e3e5..34041427423f 100644
--- a/sys-devel/clang-common/clang-common-16.0.6-r6.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.6-r6.ebuild
@@ -18,7 +18,7 @@ IUSE="
PDEPEND="
default-compiler-rt? (
- sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
+ llvm-core/clang-runtime:${LLVM_MAJOR}[compiler-rt]
llvm-libunwind? ( llvm-runtimes/libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
@@ -67,7 +67,7 @@ src_install() {
insinto /etc/clang
newins - gentoo-runtimes.cfg <<-EOF
- # This file is initially generated by sys-devel/clang-runtime.
+ # This file is initially generated by llvm-core/clang-runtime.
# It is used to control the default runtimes using by clang.
--rtlib=$(usex default-compiler-rt compiler-rt libgcc)
diff --git a/sys-devel/clang-common/clang-common-17.0.6-r10.ebuild b/sys-devel/clang-common/clang-common-17.0.6-r10.ebuild
index 5870b71335a8..c66e0f184318 100644
--- a/sys-devel/clang-common/clang-common-17.0.6-r10.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.6-r10.ebuild
@@ -18,7 +18,7 @@ IUSE="
PDEPEND="
default-compiler-rt? (
- sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
+ llvm-core/clang-runtime:${LLVM_MAJOR}[compiler-rt]
llvm-libunwind? ( llvm-runtimes/libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
@@ -144,7 +144,7 @@ src_install() {
insinto /etc/clang
newins - gentoo-runtimes.cfg <<-EOF
- # This file is initially generated by sys-devel/clang-runtime.
+ # This file is initially generated by llvm-core/clang-runtime.
# It is used to control the default runtimes using by clang.
--rtlib=$(usex default-compiler-rt compiler-rt libgcc)
diff --git a/sys-devel/clang-common/clang-common-17.0.6-r9.ebuild b/sys-devel/clang-common/clang-common-17.0.6-r9.ebuild
index 7af16d4ac75b..f9569e9f3051 100644
--- a/sys-devel/clang-common/clang-common-17.0.6-r9.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.6-r9.ebuild
@@ -18,7 +18,7 @@ IUSE="
PDEPEND="
default-compiler-rt? (
- sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
+ llvm-core/clang-runtime:${LLVM_MAJOR}[compiler-rt]
llvm-libunwind? ( llvm-runtimes/libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
@@ -144,7 +144,7 @@ src_install() {
insinto /etc/clang
newins - gentoo-runtimes.cfg <<-EOF
- # This file is initially generated by sys-devel/clang-runtime.
+ # This file is initially generated by llvm-core/clang-runtime.
# It is used to control the default runtimes using by clang.
--rtlib=$(usex default-compiler-rt compiler-rt libgcc)
diff --git a/sys-devel/clang-common/clang-common-18.1.8-r3.ebuild b/sys-devel/clang-common/clang-common-18.1.8-r3.ebuild
index ae1a72c52b76..b078434e55bd 100644
--- a/sys-devel/clang-common/clang-common-18.1.8-r3.ebuild
+++ b/sys-devel/clang-common/clang-common-18.1.8-r3.ebuild
@@ -18,7 +18,7 @@ IUSE="
PDEPEND="
default-compiler-rt? (
- sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
+ llvm-core/clang-runtime:${LLVM_MAJOR}[compiler-rt]
llvm-libunwind? ( llvm-runtimes/libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
@@ -144,7 +144,7 @@ src_install() {
insinto /etc/clang
newins - gentoo-runtimes.cfg <<-EOF
- # This file is initially generated by sys-devel/clang-runtime.
+ # This file is initially generated by llvm-core/clang-runtime.
# It is used to control the default runtimes using by clang.
--rtlib=$(usex default-compiler-rt compiler-rt libgcc)
diff --git a/sys-devel/clang-common/clang-common-19.1.4.ebuild b/sys-devel/clang-common/clang-common-19.1.4.ebuild
index f33390a4b4f1..4631b0d33f81 100644
--- a/sys-devel/clang-common/clang-common-19.1.4.ebuild
+++ b/sys-devel/clang-common/clang-common-19.1.4.ebuild
@@ -18,7 +18,7 @@ IUSE="
PDEPEND="
default-compiler-rt? (
- sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
+ llvm-core/clang-runtime:${LLVM_MAJOR}[compiler-rt]
llvm-libunwind? ( llvm-runtimes/libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
@@ -144,7 +144,7 @@ src_install() {
insinto /etc/clang
newins - gentoo-runtimes.cfg <<-EOF
- # This file is initially generated by sys-devel/clang-runtime.
+ # This file is initially generated by llvm-core/clang-runtime.
# It is used to control the default runtimes using by clang.
--rtlib=$(usex default-compiler-rt compiler-rt libgcc)
diff --git a/sys-devel/clang-common/clang-common-19.1.5.ebuild b/sys-devel/clang-common/clang-common-19.1.5.ebuild
index 7fc5e4131cd6..3c1f4c76bfb7 100644
--- a/sys-devel/clang-common/clang-common-19.1.5.ebuild
+++ b/sys-devel/clang-common/clang-common-19.1.5.ebuild
@@ -18,7 +18,7 @@ IUSE="
PDEPEND="
default-compiler-rt? (
- sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
+ llvm-core/clang-runtime:${LLVM_MAJOR}[compiler-rt]
llvm-libunwind? ( llvm-runtimes/libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
@@ -144,7 +144,7 @@ src_install() {
insinto /etc/clang
newins - gentoo-runtimes.cfg <<-EOF
- # This file is initially generated by sys-devel/clang-runtime.
+ # This file is initially generated by llvm-core/clang-runtime.
# It is used to control the default runtimes using by clang.
--rtlib=$(usex default-compiler-rt compiler-rt libgcc)
diff --git a/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild
index 2c15d06f582f..d655b20767f9 100644
--- a/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild
@@ -17,7 +17,7 @@ IUSE="
PDEPEND="
default-compiler-rt? (
- sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
+ llvm-core/clang-runtime:${LLVM_MAJOR}[compiler-rt]
llvm-libunwind? ( llvm-runtimes/libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
@@ -143,7 +143,7 @@ src_install() {
insinto /etc/clang
newins - gentoo-runtimes.cfg <<-EOF
- # This file is initially generated by sys-devel/clang-runtime.
+ # This file is initially generated by llvm-core/clang-runtime.
# It is used to control the default runtimes using by clang.
--rtlib=$(usex default-compiler-rt compiler-rt libgcc)
diff --git a/sys-devel/clang-common/clang-common-20.0.0_pre20241207.ebuild b/sys-devel/clang-common/clang-common-20.0.0_pre20241207.ebuild
index 2c15d06f582f..d655b20767f9 100644
--- a/sys-devel/clang-common/clang-common-20.0.0_pre20241207.ebuild
+++ b/sys-devel/clang-common/clang-common-20.0.0_pre20241207.ebuild
@@ -17,7 +17,7 @@ IUSE="
PDEPEND="
default-compiler-rt? (
- sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
+ llvm-core/clang-runtime:${LLVM_MAJOR}[compiler-rt]
llvm-libunwind? ( llvm-runtimes/libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
@@ -143,7 +143,7 @@ src_install() {
insinto /etc/clang
newins - gentoo-runtimes.cfg <<-EOF
- # This file is initially generated by sys-devel/clang-runtime.
+ # This file is initially generated by llvm-core/clang-runtime.
# It is used to control the default runtimes using by clang.
--rtlib=$(usex default-compiler-rt compiler-rt libgcc)
diff --git a/sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild b/sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild
deleted file mode 100644
index 2d601d4a45c6..000000000000
--- a/sys-devel/clang-runtime/clang-runtime-15.0.7.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib-build
-
-DESCRIPTION="Meta-ebuild for clang runtime libraries"
-HOMEPAGE="https://clang.llvm.org/"
-
-LICENSE="metapackage"
-SLOT="$(ver_cut 1-3)"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
-IUSE="+compiler-rt libcxx openmp +sanitize"
-REQUIRED_USE="sanitize? ( compiler-rt )"
-
-RDEPEND="
- compiler-rt? (
- ~llvm-runtimes/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
- sanitize? (
- ~llvm-runtimes/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
- )
- )
- libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
- openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
-"
diff --git a/sys-devel/clang-runtime/clang-runtime-16.0.6.ebuild b/sys-devel/clang-runtime/clang-runtime-16.0.6.ebuild
deleted file mode 100644
index ead2c0032671..000000000000
--- a/sys-devel/clang-runtime/clang-runtime-16.0.6.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib-build toolchain-funcs
-
-DESCRIPTION="Meta-ebuild for clang runtime libraries"
-HOMEPAGE="https://clang.llvm.org/"
-
-LICENSE="metapackage"
-SLOT="${PV%%.*}"
-KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos"
-IUSE="+compiler-rt libcxx openmp +sanitize"
-REQUIRED_USE="sanitize? ( compiler-rt )"
-
-RDEPEND="
- compiler-rt? (
- ~llvm-runtimes/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
- sanitize? (
- ~llvm-runtimes/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
- )
- )
- libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
- openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
-"
-
-pkg_pretend() {
- if tc-is-clang; then
- ewarn "You seem to be using clang as a system compiler. As of clang-16,"
- ewarn "upstream has turned a few warnings that commonly occur during"
- ewarn "configure script runs into errors by default. This causes some"
- ewarn "configure tests to start failing, sometimes resulting in silent"
- ewarn "breakage, missing functionality or runtime misbehavior. It is"
- ewarn "not yet clear whether the change will remain or be reverted."
- ewarn
- ewarn "For more information, please see:"
- ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
- fi
-}
diff --git a/sys-devel/clang-runtime/clang-runtime-17.0.6.ebuild b/sys-devel/clang-runtime/clang-runtime-17.0.6.ebuild
deleted file mode 100644
index ead2c0032671..000000000000
--- a/sys-devel/clang-runtime/clang-runtime-17.0.6.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib-build toolchain-funcs
-
-DESCRIPTION="Meta-ebuild for clang runtime libraries"
-HOMEPAGE="https://clang.llvm.org/"
-
-LICENSE="metapackage"
-SLOT="${PV%%.*}"
-KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos"
-IUSE="+compiler-rt libcxx openmp +sanitize"
-REQUIRED_USE="sanitize? ( compiler-rt )"
-
-RDEPEND="
- compiler-rt? (
- ~llvm-runtimes/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
- sanitize? (
- ~llvm-runtimes/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
- )
- )
- libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
- openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
-"
-
-pkg_pretend() {
- if tc-is-clang; then
- ewarn "You seem to be using clang as a system compiler. As of clang-16,"
- ewarn "upstream has turned a few warnings that commonly occur during"
- ewarn "configure script runs into errors by default. This causes some"
- ewarn "configure tests to start failing, sometimes resulting in silent"
- ewarn "breakage, missing functionality or runtime misbehavior. It is"
- ewarn "not yet clear whether the change will remain or be reverted."
- ewarn
- ewarn "For more information, please see:"
- ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
- fi
-}
diff --git a/sys-devel/clang-runtime/clang-runtime-18.1.8.ebuild b/sys-devel/clang-runtime/clang-runtime-18.1.8.ebuild
deleted file mode 100644
index 630dde92a651..000000000000
--- a/sys-devel/clang-runtime/clang-runtime-18.1.8.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib-build toolchain-funcs
-
-DESCRIPTION="Meta-ebuild for clang runtime libraries"
-HOMEPAGE="https://clang.llvm.org/"
-
-LICENSE="metapackage"
-SLOT="${PV%%.*}"
-KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos"
-IUSE="+compiler-rt libcxx openmp +sanitize"
-REQUIRED_USE="sanitize? ( compiler-rt )"
-
-RDEPEND="
- compiler-rt? (
- ~llvm-runtimes/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
- sanitize? (
- ~llvm-runtimes/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
- )
- )
- libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
- openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
-"
-
-pkg_pretend() {
- if tc-is-clang; then
- ewarn "You seem to be using clang as a system compiler. As of clang-16,"
- ewarn "upstream has turned a few warnings that commonly occur during"
- ewarn "configure script runs into errors by default. This causes some"
- ewarn "configure tests to start failing, sometimes resulting in silent"
- ewarn "breakage, missing functionality or runtime misbehavior. It is"
- ewarn "not yet clear whether the change will remain or be reverted."
- ewarn
- ewarn "For more information, please see:"
- ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
- fi
-}
diff --git a/sys-devel/clang-runtime/clang-runtime-19.1.4.ebuild b/sys-devel/clang-runtime/clang-runtime-19.1.4.ebuild
deleted file mode 100644
index 630dde92a651..000000000000
--- a/sys-devel/clang-runtime/clang-runtime-19.1.4.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib-build toolchain-funcs
-
-DESCRIPTION="Meta-ebuild for clang runtime libraries"
-HOMEPAGE="https://clang.llvm.org/"
-
-LICENSE="metapackage"
-SLOT="${PV%%.*}"
-KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos"
-IUSE="+compiler-rt libcxx openmp +sanitize"
-REQUIRED_USE="sanitize? ( compiler-rt )"
-
-RDEPEND="
- compiler-rt? (
- ~llvm-runtimes/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
- sanitize? (
- ~llvm-runtimes/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
- )
- )
- libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
- openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
-"
-
-pkg_pretend() {
- if tc-is-clang; then
- ewarn "You seem to be using clang as a system compiler. As of clang-16,"
- ewarn "upstream has turned a few warnings that commonly occur during"
- ewarn "configure script runs into errors by default. This causes some"
- ewarn "configure tests to start failing, sometimes resulting in silent"
- ewarn "breakage, missing functionality or runtime misbehavior. It is"
- ewarn "not yet clear whether the change will remain or be reverted."
- ewarn
- ewarn "For more information, please see:"
- ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
- fi
-}
diff --git a/sys-devel/clang-runtime/clang-runtime-19.1.5.ebuild b/sys-devel/clang-runtime/clang-runtime-19.1.5.ebuild
deleted file mode 100644
index 156bf2451f7b..000000000000
--- a/sys-devel/clang-runtime/clang-runtime-19.1.5.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib-build toolchain-funcs
-
-DESCRIPTION="Meta-ebuild for clang runtime libraries"
-HOMEPAGE="https://clang.llvm.org/"
-
-LICENSE="metapackage"
-SLOT="${PV%%.*}"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos"
-IUSE="+compiler-rt libcxx openmp +sanitize"
-REQUIRED_USE="sanitize? ( compiler-rt )"
-
-RDEPEND="
- compiler-rt? (
- ~llvm-runtimes/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
- sanitize? (
- ~llvm-runtimes/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
- )
- )
- libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
- openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
-"
-
-pkg_pretend() {
- if tc-is-clang; then
- ewarn "You seem to be using clang as a system compiler. As of clang-16,"
- ewarn "upstream has turned a few warnings that commonly occur during"
- ewarn "configure script runs into errors by default. This causes some"
- ewarn "configure tests to start failing, sometimes resulting in silent"
- ewarn "breakage, missing functionality or runtime misbehavior. It is"
- ewarn "not yet clear whether the change will remain or be reverted."
- ewarn
- ewarn "For more information, please see:"
- ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
- fi
-}
diff --git a/sys-devel/clang-runtime/clang-runtime-20.0.0.9999.ebuild b/sys-devel/clang-runtime/clang-runtime-20.0.0.9999.ebuild
deleted file mode 100644
index 731f7ca4c926..000000000000
--- a/sys-devel/clang-runtime/clang-runtime-20.0.0.9999.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib-build toolchain-funcs
-
-DESCRIPTION="Meta-ebuild for clang runtime libraries"
-HOMEPAGE="https://clang.llvm.org/"
-
-LICENSE="metapackage"
-SLOT="${PV%%.*}"
-IUSE="+compiler-rt libcxx offload openmp +sanitize"
-REQUIRED_USE="sanitize? ( compiler-rt )"
-
-RDEPEND="
- compiler-rt? (
- ~llvm-runtimes/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
- sanitize? (
- ~llvm-runtimes/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
- )
- )
- libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
- openmp? (
- >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}]
- offload? (
- >=llvm-runtimes/offload-${PV}
- )
- )
-"
-
-pkg_pretend() {
- if tc-is-clang; then
- ewarn "You seem to be using clang as a system compiler. As of clang-16,"
- ewarn "upstream has turned a few warnings that commonly occur during"
- ewarn "configure script runs into errors by default. This causes some"
- ewarn "configure tests to start failing, sometimes resulting in silent"
- ewarn "breakage, missing functionality or runtime misbehavior. It is"
- ewarn "not yet clear whether the change will remain or be reverted."
- ewarn
- ewarn "For more information, please see:"
- ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
- fi
-}
diff --git a/sys-devel/clang-runtime/clang-runtime-20.0.0_pre20241207.ebuild b/sys-devel/clang-runtime/clang-runtime-20.0.0_pre20241207.ebuild
deleted file mode 100644
index 731f7ca4c926..000000000000
--- a/sys-devel/clang-runtime/clang-runtime-20.0.0_pre20241207.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib-build toolchain-funcs
-
-DESCRIPTION="Meta-ebuild for clang runtime libraries"
-HOMEPAGE="https://clang.llvm.org/"
-
-LICENSE="metapackage"
-SLOT="${PV%%.*}"
-IUSE="+compiler-rt libcxx offload openmp +sanitize"
-REQUIRED_USE="sanitize? ( compiler-rt )"
-
-RDEPEND="
- compiler-rt? (
- ~llvm-runtimes/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
- sanitize? (
- ~llvm-runtimes/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
- )
- )
- libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
- openmp? (
- >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}]
- offload? (
- >=llvm-runtimes/offload-${PV}
- )
- )
-"
-
-pkg_pretend() {
- if tc-is-clang; then
- ewarn "You seem to be using clang as a system compiler. As of clang-16,"
- ewarn "upstream has turned a few warnings that commonly occur during"
- ewarn "configure script runs into errors by default. This causes some"
- ewarn "configure tests to start failing, sometimes resulting in silent"
- ewarn "breakage, missing functionality or runtime misbehavior. It is"
- ewarn "not yet clear whether the change will remain or be reverted."
- ewarn
- ewarn "For more information, please see:"
- ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
- fi
-}
diff --git a/sys-devel/clang-runtime/metadata.xml b/sys-devel/clang-runtime/metadata.xml
deleted file mode 100644
index 2167c069cc50..000000000000
--- a/sys-devel/clang-runtime/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>llvm@gentoo.org</email>
- </maintainer>
- <use>
- <flag name="compiler-rt">Install <pkg>llvm-runtimes/compiler-rt</pkg> for -rtlib=compiler-rt</flag>
- <flag name="libcxx">Install <pkg>llvm-runtimes/libcxx</pkg> for -stdlib=libc++</flag>
- <flag name="offload">Install <pkg>llvm-runtimes/offload</pkg> for -fopenmp GPU offloading</flag>
- <flag name="openmp">Install <pkg>llvm-runtimes/openmp</pkg> for -fopenmp support</flag>
- <flag name="sanitize">Enable compiler-rt sanitizer (-fsanitize*) support</flag>
- </use>
- <upstream>
- <remote-id type="github">llvm/llvm-project</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/sys-devel/clang/clang-15.0.7-r3.ebuild b/sys-devel/clang/clang-15.0.7-r3.ebuild
index 0d07b49a63ac..b8fec6c1f0a3 100644
--- a/sys-devel/clang/clang-15.0.7-r3.ebuild
+++ b/sys-devel/clang/clang-15.0.7-r3.ebuild
@@ -41,7 +41,7 @@ BDEPEND="
"
PDEPEND="
sys-devel/clang-toolchain-symlinks:${LLVM_MAJOR}
- ~sys-devel/clang-runtime-${PV}
+ ~llvm-core/clang-runtime-${PV}
"
LLVM_COMPONENTS=(
diff --git a/sys-devel/clang/clang-16.0.6.ebuild b/sys-devel/clang/clang-16.0.6.ebuild
index bd1e86a5edd7..3ad2f3f9eadb 100644
--- a/sys-devel/clang/clang-16.0.6.ebuild
+++ b/sys-devel/clang/clang-16.0.6.ebuild
@@ -41,7 +41,7 @@ BDEPEND="
xml? ( virtual/pkgconfig )
"
PDEPEND="
- ~sys-devel/clang-runtime-${PV}
+ ~llvm-core/clang-runtime-${PV}
sys-devel/clang-toolchain-symlinks:${LLVM_MAJOR}
"
diff --git a/sys-devel/clang/clang-17.0.6.ebuild b/sys-devel/clang/clang-17.0.6.ebuild
index 71d4d04a4823..60e15bf6b1de 100644
--- a/sys-devel/clang/clang-17.0.6.ebuild
+++ b/sys-devel/clang/clang-17.0.6.ebuild
@@ -41,7 +41,7 @@ BDEPEND="
xml? ( virtual/pkgconfig )
"
PDEPEND="
- ~sys-devel/clang-runtime-${PV}
+ ~llvm-core/clang-runtime-${PV}
sys-devel/clang-toolchain-symlinks:${LLVM_MAJOR}
"
diff --git a/sys-devel/clang/clang-18.1.8-r6.ebuild b/sys-devel/clang/clang-18.1.8-r6.ebuild
index cbe318e41295..d721d9f94467 100644
--- a/sys-devel/clang/clang-18.1.8-r6.ebuild
+++ b/sys-devel/clang/clang-18.1.8-r6.ebuild
@@ -39,7 +39,7 @@ BDEPEND="
xml? ( virtual/pkgconfig )
"
PDEPEND="
- ~sys-devel/clang-runtime-${PV}
+ ~llvm-core/clang-runtime-${PV}
sys-devel/clang-toolchain-symlinks:${LLVM_MAJOR}
"
diff --git a/sys-devel/clang/clang-19.1.4.ebuild b/sys-devel/clang/clang-19.1.4.ebuild
index 27febbc8c67a..7de1a2a6d4d2 100644
--- a/sys-devel/clang/clang-19.1.4.ebuild
+++ b/sys-devel/clang/clang-19.1.4.ebuild
@@ -38,7 +38,7 @@ BDEPEND="
xml? ( virtual/pkgconfig )
"
PDEPEND="
- ~sys-devel/clang-runtime-${PV}
+ ~llvm-core/clang-runtime-${PV}
sys-devel/clang-toolchain-symlinks:${LLVM_MAJOR}
"
diff --git a/sys-devel/clang/clang-19.1.5.ebuild b/sys-devel/clang/clang-19.1.5.ebuild
index 2d7aae85f170..079f8030764b 100644
--- a/sys-devel/clang/clang-19.1.5.ebuild
+++ b/sys-devel/clang/clang-19.1.5.ebuild
@@ -38,7 +38,7 @@ BDEPEND="
xml? ( virtual/pkgconfig )
"
PDEPEND="
- ~sys-devel/clang-runtime-${PV}
+ ~llvm-core/clang-runtime-${PV}
sys-devel/clang-toolchain-symlinks:${LLVM_MAJOR}
"
diff --git a/sys-devel/clang/clang-20.0.0.9999.ebuild b/sys-devel/clang/clang-20.0.0.9999.ebuild
index 302925ded5b2..076fef92f016 100644
--- a/sys-devel/clang/clang-20.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-20.0.0.9999.ebuild
@@ -37,7 +37,7 @@ BDEPEND="
xml? ( virtual/pkgconfig )
"
PDEPEND="
- ~sys-devel/clang-runtime-${PV}
+ ~llvm-core/clang-runtime-${PV}
sys-devel/clang-toolchain-symlinks:${LLVM_MAJOR}
"
diff --git a/sys-devel/clang/clang-20.0.0_pre20241207.ebuild b/sys-devel/clang/clang-20.0.0_pre20241207.ebuild
index 302925ded5b2..076fef92f016 100644
--- a/sys-devel/clang/clang-20.0.0_pre20241207.ebuild
+++ b/sys-devel/clang/clang-20.0.0_pre20241207.ebuild
@@ -37,7 +37,7 @@ BDEPEND="
xml? ( virtual/pkgconfig )
"
PDEPEND="
- ~sys-devel/clang-runtime-${PV}
+ ~llvm-core/clang-runtime-${PV}
sys-devel/clang-toolchain-symlinks:${LLVM_MAJOR}
"